]> git.pld-linux.org Git - packages/libvirt.git/blobdiff - libvirt.spec
Patches updated
[packages/libvirt.git] / libvirt.spec
index 2d6029bdfc58b1130793b8782536e0b95d0d5e7a..f2e5cf4bbdc56161813024f0e8887937b7f916ed 100644 (file)
@@ -1,10 +1,13 @@
-#
-# TODO: - seems that lxc patch is not needed anymore, verify that before removing
+# TODO:
+# - wireshark-dissector
+# - seems that lxc patch is not needed anymore, verify that before removing
 # - pldize virtlockd.init
+# - updated vserver patch, if anybody needs it
 #
 # Conditional build:
 %bcond_without ceph            # RADOS BD (Ceph) storage support
 %bcond_without esx             # VMware ESX support
+%bcond_without glusterfs       # GlusterFS storage support
 %bcond_without hyperv          # Hyper-V support
 %bcond_without libxl           # libxenlight support
 %bcond_without lxc             # LXC support
 %bcond_without polkit          # PolicyKit support
 %bcond_without qemu            # Qemu support
 %bcond_without sanlock         # sanlock storage lock manager
+%bcond_without systemtap       # systemtap/dtrace probes
 %bcond_without uml             # UML support
 %bcond_without vbox            # VirtualBox support
 %bcond_without vmware          # VMware Workstation/Player support
+%bcond_with    vserver         # Support for Linux-VServer guests
 %bcond_without xenapi          # Xen API (Citrix XenServer) support
 %bcond_without xen             # Xen support
 %bcond_without static_libs     # static libraries build
+%bcond_without ldap            # don't require openldap-devel
 
 # qemu available only on x86 and ppc
 %ifnarch %{ix86} %{x8664} ppc
 %undefine      with_qemu
 %endif
+
 # Xen is available only on x86 and ia64
 %ifnarch %{ix86} %{x8664} ia64
 %undefine      with_xen
+%undefine      with_xenapi
+%undefine      with_libxl
 %endif
+
 Summary:       Toolkit to interact with virtualization capabilities
 Summary(pl.UTF-8):     Narzędzia współpracujące z funkcjami wirtualizacji
 Name:          libvirt
-Version:       1.0.6
+Version:       2.1.0
 Release:       1
 License:       LGPL v2.1+
 Group:         Libraries
-Source0:       ftp://ftp.libvirt.org/libvirt/%{name}-%{version}.tar.gz
-# Source0-md5: a4a09a981f902c4d6aa5138c753d64fd
+Source0:       http://libvirt.org/sources/libvirt-%{version}.tar.xz
+# Source0-md5: fd1c054a8b59235e877efb728de79386
 Source1:       %{name}.init
 Source2:       %{name}.tmpfiles
 Patch0:                %{name}-sasl.patch
 Patch1:                %{name}-lxc.patch
 Patch2:                %{name}-qemu-acl.patch
-Patch3:                %{name}-xend.patch
-Patch4:                virtlockd.init.patch
+Patch3:                virtlockd.init.patch
+Patch4:                %{name}-udevadm-settle.patch
+Patch5:                vserver.patch
+Patch6:                bashisms.patch
+Patch7:                %{name}-guests.init.patch
 URL:           http://www.libvirt.org/
 BuildRequires: audit-libs-devel
 BuildRequires: augeas-devel
@@ -57,7 +70,8 @@ BuildRequires:        cyrus-sasl-devel
 BuildRequires: dbus-devel >= 1.0.0
 BuildRequires: device-mapper-devel >= 1.0.0
 BuildRequires: gawk
-BuildRequires: gettext-devel >= 0.17
+BuildRequires: gettext-tools >= 0.17
+%{?with_glusterfs:BuildRequires:       glusterfs-devel >= 3.4.1}
 BuildRequires: gnutls-devel >= 1.0.25
 BuildRequires: libapparmor-devel
 BuildRequires: libblkid-devel >= 2.17
@@ -68,7 +82,6 @@ BuildRequires:        libnl-devel >= 3.2
 BuildRequires: libpcap-devel >= 1.0.0
 BuildRequires: libselinux-devel >= 2.0.82
 BuildRequires: libssh2-devel >= 1.3
-BuildRequires: libstdc++-devel
 BuildRequires: libtool
 %{?with_xenapi:BuildRequires:  libxenserver-devel}
 BuildRequires: libxml2-devel >= 1:2.6.0
@@ -76,18 +89,16 @@ BuildRequires:      libxslt-devel
 BuildRequires: ncurses-devel
 %{?with_netcf:BuildRequires:   netcf-devel >= 0.2.0}
 BuildRequires: numactl-devel
-BuildRequires: openldap-devel
-BuildRequires: openwsman-devel >= 2.2.3
+%{?with_ldap:BuildRequires:    openldap-devel}
+%{?with_hyperv:BuildRequires:  openwsman-devel >= 2.2.3}
 BuildRequires: parted-devel >= 1.8.0
-BuildRequires: perl-tools-pod
-%{?with_polkit:BuildRequires:  polkit >= 0.90}
 BuildRequires: pkgconfig
-BuildRequires: python
-BuildRequires: python-devel
+%{?with_polkit:BuildRequires:  polkit-devel >= 0.90}
 BuildRequires: readline-devel
-BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.627
 %{?with_sanlock:BuildRequires: sanlock-devel >= 0.8}
+BuildRequires: systemd-devel
+%{?with_systemtap:BuildRequires:       systemtap-sdt-devel}
 BuildRequires: udev-devel >= 1:145
 %{?with_xen:BuildRequires:     xen-devel >= 4.2}
 # For disk driver
@@ -101,7 +112,7 @@ Requires:   libpcap >= 1.0.0
 Requires:      libselinux >= 2.0.82
 Requires:      libssh2 >= 1.3
 Requires:      libxml2 >= 1:2.6.0
-Requires:      openwsman-libs >= 2.2.3
+%{?with_hyperv:Requires:       openwsman-libs >= 2.2.3}
 Obsoletes:     libvirt-daemon-esx
 Obsoletes:     libvirt-daemon-hyperv
 Obsoletes:     libvirt-daemon-openvz
@@ -155,8 +166,8 @@ Requires:   libpcap-devel >= 1.0.0
 Requires:      libselinux-devel >= 2.0.82
 Requires:      libxml2-devel >= 1:2.6.0
 Requires:      numactl-devel
-Requires:      openwsman-devel >= 2.2.3
-%{?with_xen:Requires: xen-devel >= 4.2}
+%{?with_hyperv:Requires:       openwsman-devel >= 2.2.3}
+%{?with_xen:Requires:  xen-devel >= 4.2}
 Requires:      yajl-devel
 
 %description devel
@@ -193,24 +204,6 @@ obecnych wersji Linuksa.
 Ten pakiet zawiera biblioteki statyczne do tworzenia programów
 wykorzystujących bibliotekę libvirt.
 
-%package -n python-%{name}
-Summary:       Python bindings to interact with virtualization capabilities
-Summary(pl.UTF-8):     Wiązania Pythona do współpracy z funkcjami wirtualizacji
-Group:         Development/Languages/Python
-Requires:      %{name} = %{version}-%{release}
-
-%description -n        python-%{name}
-Libvirt is a C toolkit to interact with the virtualization
-capabilities of recent versions of Linux.
-
-This package contains the Python bindings for the libvirt library.
-
-%description -n        python-%{name} -l pl.UTF-8
-Libvirt to zestaw narzędzi w C do współpracy z funkcjami wirtualizacji
-obecnych wersji Linuksa.
-
-Ten pakiet zawiera wiązania Pythona do biblioteki libvirt.
-
 %package lock-sanlock
 Summary:       Sanlock lock manager plugin for libvirt
 Summary(pl.UTF-8):     Zarządca blokad sanlock dla biblioteki libvirt
@@ -233,6 +226,7 @@ Requires:   iproute2
 Requires:      libblkid >= 2.17
 %{?with_netcf:Requires:        netcf >= 0.2.0}
 Requires:      parted-libs >= 1.8.0
+Requires:      rc-scripts
 # Needed for probing the power management features of the host.
 Requires:      pm-utils
 Requires:      systemd-units >= 37-0.10
@@ -240,10 +234,10 @@ Requires: udev-libs >= 1:145
 Requires:      util-linux
 Requires:      virtual(module-tools)
 Requires:      xorg-lib-libpciaccess >= 0.10.0
-Provides:      libvirt(hypervisor)
 Requires(post):        systemd-units
-Requires(preun):       systemd-units
+Requires(post,preun):  /sbin/chkconfig
 Requires(postun):      systemd-units
+Requires(preun):       systemd-units
 Suggests:      bridge-utils
 Suggests:      cyrus-sasl
 Suggests:      cyrus-sasl-digest-md5
@@ -263,6 +257,7 @@ Suggests:   polkit >= 0.93
 #Suggests:     radvd
 Suggests:      scrub
 #Suggests:     sheepdog
+Provides:      libvirt(hypervisor)
 
 %description daemon
 Server side daemon required to manage the virtualization capabilities
@@ -316,7 +311,7 @@ Requires:   /usr/bin/qemu-img
 Requires:      bzip2
 Requires:      gzip
 Requires:      lzop
-Requires:      qemu
+Requires:      qemu-system-x86
 Requires:      xz
 Provides:      libvirt(hypervisor)
 
@@ -350,7 +345,6 @@ Group:              Libraries
 Requires:      %{name}-daemon = %{version}-%{release}
 Requires:      /usr/sbin/qcow-create
 Requires:      xen
-Requires:      xen-xend
 Provides:      libvirt(hypervisor)
 
 %description daemon-xen
@@ -365,12 +359,15 @@ wirtualizacji XEN.
 Summary:       Client side utilities of the libvirt library
 Summary(pl.UTF-8):     Narzędzia klienckie do biblioteki libvirt
 Group:         Applications/System
+Requires:      %{name} = %{version}-%{release}
 Requires:      gettext >= 0.18.1.1-6
 Requires:      gnutls >= 1.0.25
 Requires:      netcat-openbsd
+Requires:      rc-scripts
 Requires(post):        systemd-units
-Requires(preun):       systemd-units
+Requires(post,preun):  /sbin/chkconfig
 Requires(postun):      systemd-units
+Requires(preun):       systemd-units
 
 %description client
 Client binaries needed to access to the virtualization capabilities of
@@ -405,24 +402,33 @@ obecnych wersji Linuksa.
 To jest metapakiet zbierający wszystkie narzędzia przeznaczone dla
 biblioteki libvirt.
 
+%package -n systemtap-libvirt
+Summary:       systemtap/dtrace probes for libvirt
+Summary(pl.UTF-8):     Sondy systemtap/dtrace dla libvirt
+Group:         Development/Tools
+Requires:      %{name} = %{version}-%{release}
+Requires:      systemtap-client
+
+%description -n systemtap-libvirt
+systemtap/dtrace probes for libvirt.
+
+%description -n systemtap-libvirt -l pl.UTF-8
+Sondy systemtap/dtrace dla libvirt.
+
 %prep
 %setup -q
 %patch0 -p1
-# TODO
-#patch1 -p1
+#%%patch1 -p1
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
-
-# weird translations
-%{__rm} po/{my,eu_ES}.{po,gmo}
-
-mv po/vi_VN.po po/vi.po
-mv po/vi_VN.gmo po/vi.gmo
+%{?with_vserver:%patch5 -p1}
+%patch6 -p1
+%patch7 -p1
 
 %build
 %{__libtoolize}
-%{__aclocal} -I gnulib/m4 -I m4
+%{__aclocal} -I m4
 %{__autoconf}
 %{__autoheader}
 %{__automake}
@@ -459,7 +465,7 @@ mv po/vi_VN.gmo po/vi.gmo
        SCRUB=/usr/bin/scrub \
        OVSVSCTL=/usr/bin/ovs-vsctl \
        NUMAD=/usr/bin/numad \
-       COLLIE=/usr/sbin/collie \
+       SHEEPDOGCLI=/usr/sbin/collie \
        --disable-silent-rules \
        %{?with_static_libs:--enable-static} \
        --with-html-dir=%{_gtkdocdir} \
@@ -467,48 +473,48 @@ mv po/vi_VN.gmo po/vi.gmo
        --with-init-script=systemd+redhat \
        --with-packager="PLD-Linux" \
        --with-packager-version="%{name}-%{version}-%{release}.%{_target_cpu}" \
+       --with-qemu-user=qemu \
+       --with-qemu-group=qemu \
        --with-storage-disk \
        --with-storage-fs \
+       --with-storage-gluster%{!?with_glusterfs:=no} \
        --with-storage-iscsi \
        --with-storage-lvm \
        --with-storage-mpath \
        --with-storage-rbd%{!?with_ceph:=no} \
        --with-storage-scsi \
        --with-storage-sheepdog \
-       --with-macvtap \
-       --with-virtualport \
-       --with-udev \
-       --with-libssh2 \
-       --with-avahi \
-       --with-audit \
-       --with-libblkid \
-       --with-macvtap \
-       --with-virtualport \
-       --with-numad \
-       --with-numactl \
-       --with-sasl \
-       --with-yajl \
-       --with-selinux \
        --with-apparmor \
-       --with-qemu-user=qemu \
-       --with-qemu-group=qemu \
-       --without-hal \
-       --with-driver-modules \
-       %{__with_without polkit} \
+       --with-audit \
+       --with-avahi \
+       %{__with_without systemtap dtrace} \
        %{__with_without esx} \
+       --with-driver-modules \
+       --without-hal \
        %{__with_without hyperv} \
+       --with-blkid \
+       --with-ssh2 \
        %{__with_without libxl} \
        %{__with_without lxc} \
+       --with-macvtap \
        %{__with_without netcf} \
+       --with-numactl \
+       --with-numad \
        %{__with_without openvz} \
        %{__with_without phyp} \
+       %{__with_without polkit} \
        %{__with_without qemu} \
        %{__with_without sanlock} \
+       --with-sasl \
+       --with-selinux \
+       --with-udev \
        %{__with_without uml} \
        %{__with_without vbox vbox %{_libdir}/VirtualBox} \
+       --with-virtualport \
        %{__with_without vmware} \
        %{__with_without xen} \
        %{__with_without xenapi} \
+       --with-yajl \
        --x-libraries=%{_libdir}
 
 %{__make} \
@@ -521,15 +527,11 @@ install -d $RPM_BUILD_ROOT/etc/{sysconfig,rc.d/init.d} \
 
 %{__make} install \
        DEVHELP_DIR=%{_gtkdocdir}/%{name}/devhelp \
+       SYSTEMD_UNIT_DIR=%{systemdunitdir} \
        DESTDIR=$RPM_BUILD_ROOT
 
-install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/libvirtd
-install %{SOURCE2} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
-
-%py_comp $RPM_BUILD_ROOT%{py_sitedir}
-%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
-%py_postclean
-%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/*.la
+install -p %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/libvirtd
+cp -p %{SOURCE2} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
 
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libvirt/connection-driver/*.la \
@@ -549,20 +551,32 @@ rm -rf $RPM_BUILD_ROOT
 %postun        -p /sbin/ldconfig
 
 %post daemon
+/sbin/chkconfig --add libvirtd
+%service libvirtd restart
 %systemd_post libvirtd.service
 
 %preun daemon
+if [ "$1" = "0" ]; then
+       %service -q libvirtd stop
+       /sbin/chkconfig --del libvirtd
+fi
 %systemd_preun libvirtd.service
 
 %postun daemon
 %systemd_reload
 
 %post client
+/sbin/chkconfig --add libvirt-guests
+%service -n libvirt-guests restart
 NORESTART=1
 %systemd_post libvirt-guests.service
 
 %preun client
 %systemd_preun libvirt-guests.service
+if [ "$1" = "0" ]; then
+       %service -q libvirt-guests stop
+       /sbin/chkconfig --del libvirt-guests
+fi
 
 %postun client
 %systemd_reload
@@ -574,14 +588,15 @@ NORESTART=1
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/libvirt.conf
 %attr(755,root,root) %{_libdir}/libvirt.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libvirt.so.0
+%attr(755,root,root) %{_libdir}/libvirt-admin.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libvirt-admin.so.0
 %if %{with lxc}
 %attr(755,root,root) %{_libdir}/libvirt-lxc.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libvirt-lxc.so.0
 %endif
-%if %{with qemu}
 %attr(755,root,root) %{_libdir}/libvirt-qemu.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/libvirt-qemu.so.0
-%endif
+%attr(755,root,root) %{_libdir}/libnss_libvirt.so.?
 
 %dir %{_libdir}/libvirt
 %dir %{_datadir}/libvirt
@@ -590,32 +605,23 @@ NORESTART=1
 %files devel
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libvirt.so
+%attr(755,root,root) %{_libdir}/libvirt-admin.so
 %{?with_lxc:%attr(755,root,root) %{_libdir}/libvirt-lxc.so}
-%{?with_qemu:%attr(755,root,root) %{_libdir}/libvirt-qemu.so}
+%attr(755,root,root) %{_libdir}/libvirt-qemu.so
 %{_datadir}/%{name}/api
 %{_gtkdocdir}/%{name}
 %{_includedir}/%{name}
-%{_pkgconfigdir}/%{name}.pc
+%{_pkgconfigdir}/libvirt.pc
+%{_pkgconfigdir}/libvirt-admin.pc
+%{?with_lxc:%{_pkgconfigdir}/libvirt-lxc.pc}
+%{_pkgconfigdir}/libvirt-qemu.pc
 
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/libvirt.a
+%{_libdir}/libvirt-admin.a
 %{?with_lxc:%{_libdir}/libvirt-lxc.a}
-%{?with_qemu:%{_libdir}/libvirt-qemu.a}
-
-%files -n python-%{name}
-%defattr(644,root,root,755)
-%doc %{_docdir}/%{name}-python-%{version}
-%attr(755,root,root) %{py_sitedir}/libvirtmod.so
-%{py_sitedir}/libvirt.py[co]
-%if %{with lxc}
-%attr(755,root,root) %{py_sitedir}/libvirtmod_lxc.so
-%{py_sitedir}/libvirt_lxc.py[co]
-%endif
-%if %{with qemu}
-%attr(755,root,root) %{py_sitedir}/libvirtmod_qemu.so
-%{py_sitedir}/libvirt_qemu.py[co]
-%endif
+%{_libdir}/libvirt-qemu.a
 
 %if %{with sanlock}
 %files lock-sanlock
@@ -627,7 +633,6 @@ NORESTART=1
 %{_datadir}/augeas/lenses/tests/test_libvirt_sanlock.aug
 %dir /var/lib/libvirt/sanlock
 %{_mandir}/man8/virt-sanlock-cleanup.8*
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/qemu-sanlock.conf
 %endif
 
 %files daemon
@@ -638,31 +643,48 @@ NORESTART=1
 %dir %attr(700,root,root) %{_sysconfdir}/libvirt/qemu/networks
 %dir %attr(700,root,root) %{_sysconfdir}/libvirt/qemu/networks/autostart
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/libvirtd.conf
-%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/qemu-lockd.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/virtlockd.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/libvirt-admin.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/virtlogd.conf
 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/qemu/networks/default.xml
 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/qemu/networks/autostart/default.xml
 %config(noreplace,missingok) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/nwfilter/*.xml
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/sasl/libvirt.conf
 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/libvirtd
 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/virtlockd
+%config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/virtlogd
 %attr(754,root,root) /etc/rc.d/init.d/libvirtd
 %attr(754,root,root) /etc/rc.d/init.d/virtlockd
+%attr(754,root,root) /etc/rc.d/init.d/virtlogd
 %{systemdunitdir}/libvirtd.service
 %{systemdunitdir}/virtlockd.service
 %{systemdunitdir}/virtlockd.socket
-%config(noreplace) %verify(not md5 mtime size) /usr/lib/sysctl.d/libvirtd.conf
+%{systemdunitdir}/virtlogd.service
+%{systemdunitdir}/virtlogd.socket
+%config(noreplace) %verify(not md5 mtime size) /usr/lib/sysctl.d/60-libvirtd.conf
 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/libvirtd
 %attr(755,root,root) %{_libdir}/libvirt_iohelper
 %attr(755,root,root) %{_libdir}/libvirt_parthelper
 %attr(755,root,root) %{_libdir}/virt-aa-helper
 %attr(755,root,root) %{_sbindir}/libvirtd
 %attr(755,root,root) %{_sbindir}/virtlockd
+%attr(755,root,root) %{_sbindir}/virtlogd
 %{_datadir}/augeas/lenses/libvirtd.aug
 %{_datadir}/augeas/lenses/libvirt_lockd.aug
+%{_datadir}/augeas/lenses/virtlockd.aug
+%{_datadir}/augeas/lenses/virtlogd.aug
 %{_datadir}/augeas/lenses/tests/test_libvirtd.aug
-%{_datadir}/augeas/lenses/tests/test_libvirt_lockd.aug
-%{?with_polkit:%{_datadir}/polkit-1/actions/org.libvirt.unix.policy}
+%{?with_qemu:%{_datadir}/augeas/lenses/tests/test_libvirt_lockd.aug}
+%{_datadir}/augeas/lenses/tests/test_virtlockd.aug
+%{_datadir}/augeas/lenses/tests/test_virtlogd.aug
+%if %{with polkit}
+%{_datadir}/polkit-1/actions/org.libvirt.api.policy
+%{_datadir}/polkit-1/actions/org.libvirt.unix.policy
+%{_datadir}/polkit-1/rules.d/50-libvirt.rules
+%endif
 %{_mandir}/man8/libvirtd.8*
+%{_mandir}/man8/virtlockd.8*
+%{_mandir}/man8/virtlogd.8*
 %dir /var/lib/libvirt
 %dir /var/lib/libvirt/dnsmasq
 %attr(711,root,root) %dir /var/lib/libvirt/boot
@@ -674,6 +696,7 @@ NORESTART=1
 %dir /var/run/libvirt
 %dir /var/run/libvirt/network
 %{systemdtmpfilesdir}/%{name}.conf
+%attr(755,root,root) %{_libexecdir}/libvirt_leaseshelper
 %dir %{_libdir}/libvirt/connection-driver
 %{_datadir}/libvirt/cpu_map.xml
 %{?with_netcf:%attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_interface.so}
@@ -682,14 +705,20 @@ NORESTART=1
 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_nwfilter.so
 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_secret.so
 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_storage.so
-%attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_vbox.so
+%{?with_vbox:%attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_vbox.so}
 %dir %{_libdir}/libvirt/lock-driver
 %attr(755,root,root) %{_libdir}/libvirt/lock-driver/lockd.so
 
 %if %{with libxl}
 %files daemon-libxl
 %defattr(644,root,root,755)
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/libxl.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/libxl-lockd.conf
+%{?with_sanlock:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/libxl-sanlock.conf}
+%config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/libvirtd.libxl
 %attr(755,root,root) %{_libdir}/libvirt/connection-driver/libvirt_driver_libxl.so
+%{_datadir}/augeas/lenses/libvirtd_libxl.aug
+%{_datadir}/augeas/lenses/tests/test_libvirtd_libxl.aug
 %attr(700,root,root) %dir /var/lib/libvirt/libxl
 %attr(700,root,root) %dir /var/run/libvirt/libxl
 %attr(700,root,root) %dir /var/log/libvirt/libxl
@@ -713,6 +742,8 @@ NORESTART=1
 %files daemon-qemu
 %defattr(644,root,root,755)
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/qemu.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/qemu-lockd.conf
+%{?with_sanlock:%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/qemu-sanlock.conf}
 %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/libvirtd.qemu
 %attr(750,qemu,qemu) %dir /var/cache/libvirt/qemu
 %attr(750,qemu,qemu) %dir /var/lib/libvirt/qemu
@@ -744,19 +775,25 @@ NORESTART=1
 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/libvirt-guests
 %attr(754,root,root) /etc/rc.d/init.d/libvirt-guests
 %{systemdunitdir}/libvirt-guests.service
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libvirt/virt-login-shell.conf
 %attr(755,root,root) %{_bindir}/virsh
+%attr(755,root,root) %{_bindir}/virt-admin
 %attr(755,root,root) %{_bindir}/virt-host-validate
+%attr(4755,root,root) %{_bindir}/virt-login-shell
 %attr(755,root,root) %{_bindir}/virt-xml-validate
 %attr(755,root,root) %{_bindir}/virt-pki-validate
 %attr(754,root,root) %{_libexecdir}/libvirt-guests.sh
 %{_mandir}/man1/virsh.1*
+%{_mandir}/man1/virt-admin.1*
 %{_mandir}/man1/virt-host-validate.1*
+%{_mandir}/man1/virt-login-shell.1*
 %{_mandir}/man1/virt-xml-validate.1*
 %{_mandir}/man1/virt-pki-validate.1*
 %dir %{_datadir}/libvirt/schemas
 %{_datadir}/libvirt/schemas/basictypes.rng
 %{_datadir}/libvirt/schemas/capability.rng
 %{_datadir}/libvirt/schemas/domain.rng
+%{_datadir}/libvirt/schemas/domaincaps.rng
 %{_datadir}/libvirt/schemas/domaincommon.rng
 %{_datadir}/libvirt/schemas/domainsnapshot.rng
 %{_datadir}/libvirt/schemas/interface.rng
@@ -765,9 +802,17 @@ NORESTART=1
 %{_datadir}/libvirt/schemas/nodedev.rng
 %{_datadir}/libvirt/schemas/nwfilter.rng
 %{_datadir}/libvirt/schemas/secret.rng
-%{_datadir}/libvirt/schemas/storageencryption.rng
+%{_datadir}/libvirt/schemas/storagecommon.rng
 %{_datadir}/libvirt/schemas/storagepool.rng
 %{_datadir}/libvirt/schemas/storagevol.rng
 
 %files utils
 %defattr(644,root,root,755)
+
+%if %{with systemtap}
+%files -n systemtap-libvirt
+%defattr(644,root,root,755)
+%{_datadir}/systemtap/tapset/libvirt_functions.stp
+%{_datadir}/systemtap/tapset/libvirt_probes.stp
+%{_datadir}/systemtap/tapset/libvirt_qemu_probes.stp
+%endif
This page took 0.084456 seconds and 4 git commands to generate.