]> git.pld-linux.org Git - packages/libvirt.git/blobdiff - libvirt.spec
- updated to 1.2.1
[packages/libvirt.git] / libvirt.spec
index 209962e8e8726c6181a7be62741d586a5a1ce0c0..6dcf59eee628f2958c5f506f281070cefe802382 100644 (file)
@@ -1,10 +1,13 @@
 #
-# TODO: - seems that lxc patch is not needed anymore, verify that before removing
+# TODO:
+# - kill CFLAGS from libvirt.pc:Libs
+# - seems that lxc patch is not needed anymore, verify that before removing
 # - pldize virtlockd.init
 #
 # Conditional build:
 %bcond_without ceph            # RADOS BD (Ceph) storage support
 %bcond_without esx             # VMware ESX support
+%bcond_without glusterfs       # GlusterFS storage support
 %bcond_without hyperv          # Hyper-V support
 %bcond_without libxl           # libxenlight support
 %bcond_without lxc             # LXC support
 Summary:       Toolkit to interact with virtualization capabilities
 Summary(pl.UTF-8):     Narzędzia współpracujące z funkcjami wirtualizacji
 Name:          libvirt
-Version:       1.1.3
+Version:       1.2.1
 Release:       1
 License:       LGPL v2.1+
 Group:         Libraries
 Source0:       ftp://ftp.libvirt.org/libvirt/%{name}-%{version}.tar.gz
-# Source0-md5: b0dfe373ebe0c588b42a28c14d36a3e6
+# Source0-md5: cce374220f67895afb6331bd2ddedbfd
 Source1:       %{name}.init
 Source2:       %{name}.tmpfiles
 Patch0:                %{name}-sasl.patch
@@ -62,6 +65,7 @@ BuildRequires:        dbus-devel >= 1.0.0
 BuildRequires: device-mapper-devel >= 1.0.0
 BuildRequires: gawk
 BuildRequires: gettext-devel >= 0.17
+%{?with_glusterfs:BuildRequires:       glusterfs-devel >= 3.4.1}
 BuildRequires: gnutls-devel >= 1.0.25
 BuildRequires: libapparmor-devel
 BuildRequires: libblkid-devel >= 2.17
@@ -84,12 +88,9 @@ BuildRequires:       openldap-devel
 BuildRequires: openwsman-devel >= 2.2.3
 BuildRequires: parted-devel >= 1.8.0
 BuildRequires: perl-tools-pod
-%{?with_polkit:BuildRequires:  polkit >= 0.90}
+%{?with_polkit:BuildRequires:  polkit-devel >= 0.90}
 BuildRequires: pkgconfig
-BuildRequires: python
-BuildRequires: python-devel
 BuildRequires: readline-devel
-BuildRequires: rpm-pythonprov
 BuildRequires: rpmbuild(macros) >= 1.627
 %{?with_sanlock:BuildRequires: sanlock-devel >= 0.8}
 %{?with_systemtap:BuildRequires:       systemtap-sdt-devel}
@@ -198,24 +199,6 @@ obecnych wersji Linuksa.
 Ten pakiet zawiera biblioteki statyczne do tworzenia programów
 wykorzystujących bibliotekę libvirt.
 
-%package -n python-%{name}
-Summary:       Python bindings to interact with virtualization capabilities
-Summary(pl.UTF-8):     Wiązania Pythona do współpracy z funkcjami wirtualizacji
-Group:         Development/Languages/Python
-Requires:      %{name} = %{version}-%{release}
-
-%description -n        python-%{name}
-Libvirt is a C toolkit to interact with the virtualization
-capabilities of recent versions of Linux.
-
-This package contains the Python bindings for the libvirt library.
-
-%description -n        python-%{name} -l pl.UTF-8
-Libvirt to zestaw narzędzi w C do współpracy z funkcjami wirtualizacji
-obecnych wersji Linuksa.
-
-Ten pakiet zawiera wiązania Pythona do biblioteki libvirt.
-
 %package lock-sanlock
 Summary:       Sanlock lock manager plugin for libvirt
 Summary(pl.UTF-8):     Zarządca blokad sanlock dla biblioteki libvirt
@@ -435,12 +418,6 @@ Sondy systemtap/dtrace dla libvirt.
 %patch5 -p1
 %{?with_vserver:%patch6 -p1}
 
-# weird translations
-%{__rm} po/{my,eu_ES}.{po,gmo}
-
-mv po/vi_VN.po po/vi.po
-mv po/vi_VN.gmo po/vi.gmo
-
 %build
 %{__libtoolize}
 %{__aclocal} -I gnulib/m4 -I m4
@@ -492,6 +469,7 @@ mv po/vi_VN.gmo po/vi.gmo
        --with-qemu-group=qemu \
        --with-storage-disk \
        --with-storage-fs \
+       --with-storage-gluster%{!?with_glusterfs:=no} \
        --with-storage-iscsi \
        --with-storage-lvm \
        --with-storage-mpath \
@@ -506,8 +484,8 @@ mv po/vi_VN.gmo po/vi.gmo
        --with-driver-modules \
        --without-hal \
        %{__with_without hyperv} \
-       --with-libblkid \
-       --with-libssh2 \
+       --with-blkid \
+       --with-ssh2 \
        %{__with_without libxl} \
        %{__with_without lxc} \
        --with-macvtap \
@@ -546,11 +524,6 @@ install -d $RPM_BUILD_ROOT/etc/{sysconfig,rc.d/init.d} \
 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/libvirtd
 install %{SOURCE2} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
 
-%py_comp $RPM_BUILD_ROOT%{py_sitedir}
-%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
-%py_postclean
-%{__rm} $RPM_BUILD_ROOT%{py_sitedir}/*.la
-
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/*.la
 %{__rm} $RPM_BUILD_ROOT%{_libdir}/libvirt/connection-driver/*.la \
        %{?with_static_libs:$RPM_BUILD_ROOT%{_libdir}/libvirt/connection-driver/*.a}
@@ -560,6 +533,10 @@ install %{SOURCE2} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
        %{?with_static_libs:$RPM_BUILD_ROOT%{_libdir}/libvirt/lock-driver/*.a}
 %endif
 
+%{__mv} $RPM_BUILD_ROOT%{_localedir}/{eu_ES,eu}
+# duplicate of vi, just one less message translated
+%{__rm} -r $RPM_BUILD_ROOT%{_localedir}/vi_VN
+
 %find_lang %{name}
 
 %clean
@@ -623,19 +600,6 @@ NORESTART=1
 %{?with_lxc:%{_libdir}/libvirt-lxc.a}
 %{?with_qemu:%{_libdir}/libvirt-qemu.a}
 
-%files -n python-%{name}
-%defattr(644,root,root,755)
-%attr(755,root,root) %{py_sitedir}/libvirtmod.so
-%{py_sitedir}/libvirt.py[co]
-%if %{with lxc}
-%attr(755,root,root) %{py_sitedir}/libvirtmod_lxc.so
-%{py_sitedir}/libvirt_lxc.py[co]
-%endif
-%if %{with qemu}
-%attr(755,root,root) %{py_sitedir}/libvirtmod_qemu.so
-%{py_sitedir}/libvirt_qemu.py[co]
-%endif
-
 %if %{with sanlock}
 %files lock-sanlock
 %defattr(644,root,root,755)
This page took 0.350621 seconds and 4 git commands to generate.