]> git.pld-linux.org Git - packages/libtorrent-rasterbar.git/blobdiff - libtorrent-rasterbar.spec
- release 3
[packages/libtorrent-rasterbar.git] / libtorrent-rasterbar.spec
index bf363375811a8ff7bb07ec59174e1a088cd78aa7..b7591f63c07ec66941c958a449050c0791919722 100644 (file)
@@ -2,27 +2,33 @@ Summary:      A C++ BitTorrent library
 Summary(hu.UTF-8):     C++ BitTorrent könyvtár
 Summary(pl.UTF-8):     Biblioteka BitTorrenta napisana w C++
 Name:          libtorrent-rasterbar
-Version:       0.13.1
+Version:       0.15.4
 Release:       3
+Epoch:         1
 License:       BSD
 Group:         Libraries
-Source0:       http://dl.sourceforge.net/libtorrent/%{name}-%{version}.tar.gz
-# Source0-md5: 9d6b112fedc5861402647ff72e95dba0
-Patch0:                %{name}-examples.patch
-## fix the build error with newest boost -- it will be fixed in the next libtorrent version
-Patch1:                %{name}-boost.patch
-Patch2:                %{name}-condition.patch
+Source0:       http://libtorrent.googlecode.com/files/%{name}-%{version}.tar.gz
+# Source0-md5: 58750b3a246d056335745f9e805bb949
 URL:           http://www.rasterbar.com/products/libtorrent/
+Patch0:                bashizm.patch
+Patch1:                py27.patch
+BuildRequires: GeoIP-devel
 BuildRequires: autoconf
 BuildRequires: automake
 BuildRequires: boost-devel >= 1.35.0
+BuildRequires: boost-python-devel
 BuildRequires: libstdc++-devel
 BuildRequires: libtool
 BuildRequires: openssl-devel
+BuildRequires: pkgconfig >= 1:0.20
+BuildRequires: python-devel
+BuildRequires: python-modules
+BuildRequires: rpm-pythonprov
 BuildRequires: sed >= 4.0
-BuildRequires: which
 BuildRequires: util-linux-ng
+BuildRequires: which
 BuildRequires: zlib-devel
+Obsoletes:     rb_libtorrent
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -44,9 +50,9 @@ A fő céljai, hogy nagyon hatékony legyen (CPU és memória-használat) és
 könnyű legyen használni mind a felhasználóknak, mind a fejlesztőknek.
 
 %description -l pl.UTF-8
-libtorrent-rasterbar jest biblioteką napisaną w C++ która aspiruje do
+libtorrent-rasterbar jest napisaną w C++ biblioteką, która aspiruje do
 bycia dobrą alternatywą dla wszystkich innych implementacji
-BitTorrenta. Jest to biblioteka a nie pełnoprawny klient, jakkolwiek
+BitTorrenta. Jest to biblioteka a nie pełnoprawny klient, aczkolwiek
 pakiet zawiera działającego przykładowego klienta.
 
 Główne cele biblioteki to bycie bardzo efektywną (w rozumieniu
@@ -58,9 +64,10 @@ Summary:     Header files for %{name} library
 Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki %{name}
 License:       BSD, zlib/libpng License, Boost Software License
 Group:         Development/Libraries
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 Requires:      boost-devel
 Requires:      openssl-devel
+Obsoletes:     rb_libtorrent-devel
 
 %description    devel
 The libtorrent-rasterbar-devel package contains libraries and header
@@ -79,14 +86,16 @@ alkalmazásokat fejleszthetsz.
 Pakiet libtorrent-rasterbar-devel zawiera biblioteki i nagłówki do
 rozwijania aplikacji używających libtorrent-rasterbar.
 
-Różne pliki źródłowe i nagłówki dostarcozne z tym pakietem są
-licencjonowane pod zmienioną licencją BSD, zlib/libpng i Boost Public.
+Różne pliki źródłowe i nagłówki dostarczone z tym pakietem są
+licencjonowane pod zmienioną licencją BSD, zlib/libpng i Boost Public
+License.
 
 %package static
 Summary:       Static %{name} library
 Summary(pl.UTF-8):     Statyczna biblioteka %{name}
 Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}-%{release}
+Requires:      %{name}-devel = %{epoch}:%{version}-%{release}
+Obsoletes:     rb_libtorrent-static
 
 %description static
 Static libtorrent-rasterbar library.
@@ -97,11 +106,20 @@ Statikus libtorrent-rasterbar könyvtár.
 %description static -l pl.UTF-8
 Statyczna biblioteka libtorrent-rasterbar.
 
+%package -n python-libtorrent-rasterbar
+Summary:       Python bindings for libtorrent-rasterbar
+Group:         Libraries/Python
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+
+%description -n python-libtorrent-rasterbar
+Python bindings for libtorrent-rasterbar.
+
 %prep
 %setup -q
-%patch0 -p1
-%patch1 -p1
-%patch2 -p1
+# %patch0 -p1
+# %patch1 -p1
+%{__sed} -i 's/ACLOCAL_AMFLAGS = -I m4/#ACLOCAL_AMFLAGS = -I m4/' Makefile.am
+
 ## Some of the sources and docs are executable, which makes rpmlint against
 ## the resulting -debuginfo and -devel packages, respectively, quite angry. :]
 find src docs -type f | xargs chmod a-x
@@ -111,21 +129,25 @@ find -type f -regex '.*\.[hc]pp' | xargs chmod a-x
 rm -f docs/*.rst
 
 %build
-%{__aclocal} -I m4
 %{__libtoolize}
+%{__aclocal} -I m4
 %{__autoconf}
 %{__automake}
 %configure \
+       LIBS="-lpthread -lrt" \
+       --enable-python-binding \
+       --with-boost-libdir=%{_libdir} \
        --with-boost-system=boost_system \
-       --with-boost-date-time=boost_date_time \
        --with-boost-filesystem=boost_filesystem \
        --with-boost-thread=boost_thread \
        --with-boost-regex=boost_regex \
        --with-boost-program-options=boost_program_options \
-       --with-{asio,zlib}=system \
-       --enable-ssl
+       --with-asio=system \
+       --with-zlib=system \
+       --with-libgeoip=system \
+       --with-ssl
 
-%{__make} LDFLAGS="-L%{_libdir}64 %{rpmldflags}"
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -160,3 +182,8 @@ rm -rf $RPM_BUILD_ROOT
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/libtorrent-rasterbar.a
+
+%files -n python-libtorrent-rasterbar
+%defattr(644,root,root,755)
+%{py_sitedir}/libtorrent.so
+%{py_sitedir}/python_libtorrent-*.egg-info
This page took 0.038949 seconds and 4 git commands to generate.