]> git.pld-linux.org Git - packages/libtorrent-rasterbar.git/blobdiff - libtorrent-rasterbar.spec
- added boost patch, release 3 (rebuild with boost 1.70)
[packages/libtorrent-rasterbar.git] / libtorrent-rasterbar.spec
index a73d4f5a84bee9e3f56d19d1f871046dfffeec1e..a11a55dddc89afc1f368652be6e39a222b4dfc2c 100644 (file)
@@ -1,27 +1,34 @@
+#
+# WARNING: Do not upgrade to 1.1.x, breaks qbittorrent
+#
+%define                tagver  %(echo %{version} | tr . _)
 Summary:       A C++ BitTorrent library
 Summary(hu.UTF-8):     C++ BitTorrent könyvtár
 Summary(pl.UTF-8):     Biblioteka BitTorrenta napisana w C++
 Name:          libtorrent-rasterbar
-Version:       0.14.7
-Release:       1
+Version:       1.0.11
+Release:       3
+Epoch:         2
 License:       BSD
 Group:         Libraries
-Source0:       http://downloads.sourceforge.net/libtorrent/%{name}-%{version}.tar.gz
-# Source0-md5: 6959f719245d82758235fd73d93373b2
+Source0:       https://github.com/arvidn/libtorrent/releases/download/libtorrent-%{tagver}/%{name}-%{version}.tar.gz
+# Source0-md5: f49e43286a64e8bbdef9ea59baa78b55
+Patch0:                %{name}-boost.patch
 URL:           http://www.rasterbar.com/products/libtorrent/
-Patch0:                bashizm.patch
 BuildRequires: GeoIP-devel
-BuildRequires: autoconf
-BuildRequires: automake
-BuildRequires: boost-devel >= 1.35.0
-BuildRequires: boost-python-devel
+BuildRequires: autoconf >= 2.63
+BuildRequires: automake >= 1:1.11
+BuildRequires: boost-devel >= 1.36
+BuildRequires: boost-python-devel >= 1.36
 BuildRequires: libstdc++-devel
-BuildRequires: libtool
+BuildRequires: libtool >= 2:2.2.6
 BuildRequires: openssl-devel
 BuildRequires: pkgconfig >= 1:0.20
-BuildRequires: python-devel
+BuildRequires: python-devel >= 1:2.4
+BuildRequires: python-modules >= 1:2.4
+BuildRequires: rpm-pythonprov
 BuildRequires: sed >= 4.0
-BuildRequires: util-linux-ng
+BuildRequires: util-linux
 BuildRequires: which
 BuildRequires: zlib-devel
 Obsoletes:     rb_libtorrent
@@ -60,7 +67,7 @@ Summary:      Header files for %{name} library
 Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki %{name}
 License:       BSD, zlib/libpng License, Boost Software License
 Group:         Development/Libraries
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 Requires:      boost-devel
 Requires:      openssl-devel
 Obsoletes:     rb_libtorrent-devel
@@ -90,7 +97,7 @@ License.
 Summary:       Static %{name} library
 Summary(pl.UTF-8):     Statyczna biblioteka %{name}
 Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}-%{release}
+Requires:      %{name}-devel = %{epoch}:%{version}-%{release}
 Obsoletes:     rb_libtorrent-static
 
 %description static
@@ -104,16 +111,19 @@ Statyczna biblioteka libtorrent-rasterbar.
 
 %package -n python-libtorrent-rasterbar
 Summary:       Python bindings for libtorrent-rasterbar
+Summary(pl.UTF-8):     Wiązania Pythona do biblioteki libtorrent-rasterbar
 Group:         Libraries/Python
-Requires:      %{name} = %{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 
 %description -n python-libtorrent-rasterbar
 Python bindings for libtorrent-rasterbar.
 
+%description -n python-libtorrent-rasterbar -l pl.UTF-8
+Wiązania Pythona do biblioteki libtorrent-rasterbar.
+
 %prep
 %setup -q
 %patch0 -p1
-%{__sed} -i 's/ACLOCAL_AMFLAGS = -I m4/#ACLOCAL_AMFLAGS = -I m4/' Makefile.am
 
 ## Some of the sources and docs are executable, which makes rpmlint against
 ## the resulting -debuginfo and -devel packages, respectively, quite angry. :]
@@ -121,7 +131,7 @@ find src docs -type f | xargs chmod a-x
 find -type f -regex '.*\.[hc]pp' | xargs chmod a-x
 ## The RST files are the sources used to create the final HTML files; and are
 ## not needed.
-rm -f docs/*.rst
+%{__rm} docs/*.rst
 
 %build
 %{__libtoolize}
@@ -129,7 +139,10 @@ rm -f docs/*.rst
 %{__autoconf}
 %{__automake}
 %configure \
+       LIBS="-lpthread -lrt" \
+       --disable-silent-rules \
        --enable-python-binding \
+       --with-boost-libdir=%{_libdir} \
        --with-boost-system=boost_system \
        --with-boost-filesystem=boost_filesystem \
        --with-boost-thread=boost_thread \
@@ -140,19 +153,14 @@ rm -f docs/*.rst
        --with-libgeoip=system \
        --with-ssl
 
-%{__make} LDFLAGS="-L%{_libdir}64 %{rpmldflags}"
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-## Ensure that we preserve our timestamps properly.
-#export CPPROG="%{__cp} -p"
-#make install DESTDIR=$RPM_BUILD_ROOT INSTALL="%{__install} -c -p"
+
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-## Do the renaming due to the somewhat limited %{_bindir} namespace.
-rename client torrent_client $RPM_BUILD_ROOT%{_bindir}/*
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -161,8 +169,9 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog COPYING README
-%attr(755,root,root) %{_libdir}/libtorrent-rasterbar.so*
+%doc AUTHORS ChangeLog COPYING
+%attr(755,root,root) %{_libdir}/libtorrent-rasterbar.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libtorrent-rasterbar.so.8
 
 %files devel
 %defattr(644,root,root,755)
@@ -178,5 +187,5 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -n python-libtorrent-rasterbar
 %defattr(644,root,root,755)
-%{py_sitedir}/libtorrent.so
+%attr(755,root,root) %{py_sitedir}/libtorrent.so
 %{py_sitedir}/python_libtorrent-*.egg-info
This page took 0.033266 seconds and 4 git commands to generate.