]> git.pld-linux.org Git - packages/libsigc++.git/blobdiff - libsigc++.spec
- updated to 2.2.8
[packages/libsigc++.git] / libsigc++.spec
index 618a35f0586e3b8b845b8c2d00381b0ae3bf7979..e3b8f1ba8110bf6915de7bb7f237f4f1d8b37b1b 100644 (file)
@@ -1,21 +1,26 @@
+#
+# Conditional build:
+%bcond_without static_libs     # don't build static library
+#
 Summary:       The Typesafe Signal Framework for C++
-Summary(pl):   ¦rodowisko sygna³ów z kontrol± typów dla C++
+Summary(pl.UTF-8):     Środowisko sygnałów z kontrolą typów dla C++
 Name:          libsigc++
-Version:       2.0.12
+Version:       2.2.8
 Release:       1
 Epoch:         1
-License:       LGPL
-Vendor:                Karl E. Nelson <kenelson@ece.ucdavis.edu>
+License:       LGPL v2.1+
 Group:         Libraries
-Source0:       http://ftp.gnome.org/pub/gnome/sources/libsigc++/2.0/%{name}-%{version}.tar.bz2
-# Source0-md5: edd1ad751057e82742edaa73ac5353f2
+Source0:       http://ftp.gnome.org/pub/GNOME/sources/libsigc++/2.2/%{name}-%{version}.tar.bz2
+# Source0-md5: 1198425eab9fd605721a278c651b8dd8
 URL:           http://libsigc.sourceforge.net/
 BuildRequires: autoconf >= 2.59
-BuildRequires: automake >= 1.9
+BuildRequires: automake >= 1:1.9
 BuildRequires: libstdc++-devel
 BuildRequires: libtool
 BuildRequires: m4
+BuildRequires: mm-common >= 0.7.2
 BuildRequires: perl-base
+BuildRequires: pkgconfig
 Obsoletes:     libsigc++-examples
 Conflicts:     libsigc++ < 1.1.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -30,63 +35,65 @@ method, function, or function object. It contains adaptor classes for
 connection of dissimilar callbacks and has an ease of use unmatched by
 other C++ callback libraries.
 
-%description -l pl
-Ta biblioteka jest implementacj± pe³nego systemu callbacków do
-u¿ywania w bibliotekach widgetów, interfejsach abstrakcyjnych i
-ogólnym programowaniu. Oryginalnie by³a to czê¶æ zestawu widgetów
-Gtk--, ale jest teraz oddzieln± bibliotek± ogólniejszego
-przeznaczenia. Jest to kompletna biblioteka tego typu z mo¿liwo¶ci±
-³±czenia abstrakcyjnych callbacków z metodami klas, funkcjami lub
-obiektami funkcji. Zawiera klasy adapterów do ³±czenia ró¿nych
-callbacków.
+%description -l pl.UTF-8
+Ta biblioteka jest implementacją pełnego systemu callbacków do
+używania w bibliotekach widgetów, interfejsach abstrakcyjnych i
+ogólnym programowaniu. Oryginalnie była to część zestawu widgetów
+Gtk--, ale jest teraz oddzielną biblioteką ogólniejszego
+przeznaczenia. Jest to kompletna biblioteka tego typu z możliwością
+łączenia abstrakcyjnych callbacków z metodami klas, funkcjami lub
+obiektami funkcji. Zawiera klasy adapterów do łączenia różnych
+callbacków.
 
 %package devel
 Summary:       Development tools for the Typesafe Signal Framework for C++
-Summary(pl):   Narzêdzia programistyczne do ¶rodowiska libsig++
+Summary(pl.UTF-8):     Narzędzia programistyczne do środowiska libsig++
 Group:         Development/Libraries
 Requires:      %{name} = %{epoch}:%{version}-%{release}
+Requires:      libstdc++-devel
 Requires:      m4
 
 %description devel
 Development tools for the Typesafe Signal Framework for C++.
 
-%description devel -l pl
-Narzêdzia programistyczne do ¶rodowiska libsigc++ - sygna³ów z
-kontrol± typów.
+%description devel -l pl.UTF-8
+Narzędzia programistyczne do środowiska libsigc++ - sygnałów z
+kontrolą typów.
 
 %package doc
 Summary:       Reference documentation for libsigc++
-Summary(pl):   Szczegó³owa dokumentacja dla libsigc++
+Summary(pl.UTF-8):     Szczegółowa dokumentacja dla libsigc++
 Group:         Documentation
 
 %description doc
 Reference documentation for libsigc++.
 
-%description doc -l pl
-Szczegó³owa dokumentacja dla libsigc++.
+%description doc -l pl.UTF-8
+Szczegółowa dokumentacja dla libsigc++.
 
 %package static
 Summary:       Static Typesafe Signal Framework for C++ libraries
-Summary(pl):   Statyczna biblioteka libsigc++
+Summary(pl.UTF-8):     Statyczna biblioteka libsigc++
 Group:         Development/Libraries
 Requires:      %{name}-devel = %{epoch}:%{version}-%{release}
 
 %description static
 Static Typesafe Signal Framework for C++ libraries.
 
-%description static -l pl
-Statyczna biblioteka libsigc++ - ¶rodowiska sygna³ów z kontrol± typów.
+%description static -l pl.UTF-8
+Statyczna biblioteka libsigc++ - środowiska sygnałów z kontrolą typów.
 
 %prep
 %setup -q
 
 %build
 %{__libtoolize}
-%{__aclocal} -I scripts
+%{__aclocal} -I build
 %{__autoconf}
 %{__automake}
-%configure
-%{__make}
+%configure \
+       %{?with_static_libs:--enable-static}
+%{__make} -j1 all check
 
 %install
 rm -rf $RPM_BUILD_ROOT
@@ -94,8 +101,6 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-mv $RPM_BUILD_ROOT%{_docdir}/libsigc-2.0/docs devel-docs
-
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -105,20 +110,24 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc AUTHORS ChangeLog NEWS README TODO
-%attr(755,root,root) %{_libdir}/lib*.so.*.*
+%attr(755,root,root) %{_libdir}/libsigc-2.0.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libsigc-2.0.so.0
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/lib*.so
-%{_libdir}/lib*.la
-%{_includedir}/sigc++-*
-%{_libdir}/sigc++*
-%{_pkgconfigdir}/*
+%attr(755,root,root) %{_libdir}/libsigc-2.0.so
+%{_libdir}/libsigc-2.0.la
+%{_includedir}/sigc++-2.0
+%{_libdir}/sigc++-2.0
+%{_pkgconfigdir}/sigc++-2.0.pc
 
-%files doc
+%if %{with static_libs}
+%files static
 %defattr(644,root,root,755)
-%doc devel-docs/*
+%{_libdir}/libsigc-2.0.a
+%endif
 
-%files static
+%files doc
 %defattr(644,root,root,755)
-%{_libdir}/lib*.a
+%{_datadir}/devhelp/books/libsigc++-2.0
+%{_docdir}/libsigc++-2.0
This page took 0.039411 seconds and 4 git commands to generate.