]> git.pld-linux.org Git - packages/libpng.git/blobdiff - libpng.spec
- obsolete
[packages/libpng.git] / libpng.spec
index 81afc175aee6e5d04e6f4a29b047572ce361c4d5..9c9074ea18e7cfe9933d676551c0ff65001f9ef4 100644 (file)
@@ -1,3 +1,6 @@
+#
+%define                _pre    rc1
+#
 Summary:       PNG library
 Summary(de):   PNG-Library
 Summary(es):   Biblioteca PNG
@@ -6,16 +9,27 @@ Summary(pl):  Biblioteka PNG
 Summary(pt_BR):        Biblioteca PNG
 Summary(tr):   PNG kitaplýðý
 Name:          libpng
-Version:       1.2.0
-Release:       2
+Version:       1.2.6
+Release:       0.%{_pre}.1
 Epoch:         2
 License:       distributable
 Group:         Libraries
-Source0:       http://download.sourceforge.net/libpng/%{name}-%{version}.tar.gz
+Source0:       http://heanet.dl.sourceforge.net/libpng/%{name}-%{version}%{_pre}.tar.bz2
+# Source0-md5: 346bd648912e31fd4ff900b25979f5f2
 Patch0:                %{name}-pngminus.patch
 Patch1:                %{name}-badchunks.patch
 Patch2:                %{name}-opt.patch
+Patch3:                %{name}-revert.patch
+Patch5:                %{name}-norpath.patch
+Patch6:                %{name}-libdirfix.patch
+Patch8:                %{name}-pngerror.patch
 URL:           http://www.libpng.org/pub/png/libpng.html
+BuildRequires: zlib-devel
+%ifarch amd64 ia64 ppc64 sparc64
+Provides:      libpng.so.3()(64bit)
+%else
+Provides:      libpng.so.3
+%endif
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -63,8 +77,9 @@ Summary(pl):  Pliki nag
 Summary(pt_BR):        Arquivos de inclusão e bibliotecas estáticas
 Summary(tr):   baþlýk dosyalarý ve statik kitaplýklar
 Group:         Development/Libraries
-Requires:      %{name} = %{version}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
 Requires:      zlib-devel
+Conflicts:     libpng < 1.0.15
 
 %description devel
 The header files are only needed for development of programs using the
@@ -97,11 +112,10 @@ kitapl
 %package static
 Summary:       Static PNG libraries
 Summary(de):   Statischen PNG Libraries
-Summary(es):   Static libraries for libpng development
 Summary(pl):   Biblioteki statyczne PNG
 Summary(pt_BR):        Bibliotecas estáticas para desenvolvimento com libpng
 Group:         Development/Libraries
-Requires:      %{name}-devel = %{version}
+Requires:      %{name}-devel = %{epoch}:%{version}-%{release}
 
 %description static
 Static PNG libraries.
@@ -109,9 +123,6 @@ Static PNG libraries.
 %description static -l de
 Statischen PNG Libraries.
 
-%description static -l es
-Static libraries for libpng development.
-
 %description static -l pl
 Biblioteki statyczne PNG.
 
@@ -124,54 +135,74 @@ Summary(pl):      Narz
 Group:         Applications/Graphics
 
 %description progs
-This package contains utility programs to convert png files to and
-from pnm files.
+This package contains utility programs to convert PNG files to and
+from PNM files.
 
 %description progs -l pl
-Narzêdzia do konwersji plików png z lub do plików pnm.
+Narzêdzia do konwersji plików PNG z lub do plików PNM.
 
 %prep
-%setup -q
+%setup -q -n %{name}-%{version}%{_pre}
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-
+%patch3 -p1
+%patch5 -p1
+%patch6 -p1
+#%patch8 -p1
+
+%ifarch %{ix86}
+ln -sf scripts/makefile.gcmmx ./Makefile
+%else
 ln -sf scripts/makefile.linux ./Makefile
+%endif
 
 %build
-%{__make} OPT_FLAGS="%{rpmcflags}"
-cd contrib/pngminus
-%{__make} -f makefile.std \
-       OPT_FLAGS="%{rpmcflags} -I../../"
+%{__make} \
+       prefix=%{_prefix} \
+       LIBPATH=%{_libdir} \
+       CC="%{__cc}" \
+       OPT_FLAGS="%{rpmcflags}"
+%{__make} -C contrib/pngminus -f makefile.std \
+       LIBPATH=%{_libdir} \
+       CC="%{__cc}" \
+       OPT_FLAGS="%{rpmcflags}"
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_mandir}/man{3,5}}
+install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir},%{_mandir}/man{3,5}} \
+       $RPM_BUILD_ROOT{%{_pkgconfigdir},%{_examplesdir}/%{name}-%{version}}
 
-%{__make} prefix=$RPM_BUILD_ROOT%{_prefix} install
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT \
+       prefix=%{_prefix} \
+       LIBPATH=%{_libdir} \
+       MANPATH=%{_mandir}
 
-install png.5 $RPM_BUILD_ROOT%{_mandir}/man5/
-install {libpngpf,libpng}.3 $RPM_BUILD_ROOT%{_mandir}/man3/
 install contrib/pngminus/{png2pnm,pnm2png} $RPM_BUILD_ROOT%{_bindir}
+install example.c $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
 
-gzip -9nf *.txt ANNOUNCE CHANGES KNOWNBUG README
+%clean
+rm -rf $RPM_BUILD_ROOT
 
 %post   -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
 
-%clean
-rm -rf $RPM_BUILD_ROOT
-
 %files
 %defattr(644,root,root,755)
+%doc ANNOUNCE CHANGES KNOWNBUG README LICENSE
 %attr(755,root,root) %{_libdir}/*.so.*.*
+%{_libdir}/libpng.so.3
 
 %files devel
 %defattr(644,root,root,755)
-%doc *.gz
+%doc *.txt
+%attr(755,root,root) %{_bindir}/libpng*-config
 %attr(755,root,root) %{_libdir}/lib*.so
+%{_pkgconfigdir}/*
 %{_includedir}/*
 %{_mandir}/man?/*
+%{_examplesdir}/%{name}-%{version}
 
 %files static
 %defattr(644,root,root,755)
@@ -179,4 +210,4 @@ rm -rf $RPM_BUILD_ROOT
 
 %files progs
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/*
+%attr(755,root,root) %{_bindir}/p*
This page took 0.061543 seconds and 4 git commands to generate.