]> git.pld-linux.org Git - packages/libidn.git/blobdiff - libidn.spec
add static_libs bcond
[packages/libidn.git] / libidn.spec
index d4b3db584de3293272583331b84e28570f72a998..11a56c429891648e57d42209ead11296ad378b41 100644 (file)
@@ -1,17 +1,18 @@
 # TODO:
-# - prepare package with web-files and java from contrib
+# - prepare package with web-files from contrib and JNI (contrib/java, needs move to jdk)
 #
 # Conditional build:
 %if "%{pld_release}" == "ac"
-%bcond_with            dotnet  # don't build C# binding
-%bcond_with            java    # don't build Java implementation
+%bcond_with    dotnet          # don't build C# binding
+%bcond_with    java            # don't build Java implementation
 %else
-%bcond_without dotnet  # don't build C# binding
-%bcond_without java    # don't build Java implementation
+%bcond_without dotnet          # don't build C# binding
+%bcond_without java            # don't build Java implementation
 %endif
-%bcond_without python  # don't build python interface
+%bcond_without python          # don't build python interface
+%bcond_without static_libs     # static library
 #
-%ifnarch %{ix86} %{x8664} alpha arm hppa ppc s390 s390x sparc sparcv9 sparc64
+%ifnarch %{ix86} %{x8664} alpha %{arm} hppa ppc s390 s390x sparc sparcv9 sparc64
 %undefine      with_dotnet
 %endif
 %ifarch i386
 Summary:       Internationalized string processing library
 Summary(pl.UTF-8):     Biblioteka do przetwarzania umiędzynarodowionych łańcuchów
 Name:          libidn
-Version:       1.23
+Version:       1.42
 Release:       1
-License:       LGPL v2.1+ (library), GPL v3+ (utilities)
+License:       GPL v2+ or LGPL v3+ (library), GPL v3+ (utilities)
 Group:         Libraries
-Source0:       http://ftp.gnu.org/gnu/libidn/%{name}-%{version}.tar.gz
-# Source0-md5: f9a417270cc9b6bf763ae1f88e60191c
+Source0:       https://ftp.gnu.org/gnu/libidn/%{name}-%{version}.tar.gz
+# Source0-md5: fe061a95ae23979150a692d102dce4ad
 Patch0:                %{name}-info.patch
 Patch1:                %{name}-python.patch
 URL:           http://www.gnu.org/software/libidn/
 BuildRequires: autoconf >= 2.61
 BuildRequires: automake >= 1:1.10
-%{?with_java:BuildRequires:    gcc-java}
-BuildRequires: gettext-devel >= 0.18.1
-%{?with_java:BuildRequires:    gjdoc}
+BuildRequires: gettext-tools >= 0.21
 BuildRequires: gtk-doc >= 1.1
 BuildRequires: help2man
 %{?with_java:BuildRequires:    jdk}
-BuildRequires: libtool >= 2:1.5
+BuildRequires: libtool >= 2:2
 %{?with_dotnet:BuildRequires:  mono}
 %{?with_dotnet:BuildRequires:  mono-csharp}
 BuildRequires: perl-base
@@ -45,7 +44,7 @@ BuildRequires:        pkgconfig
 %{?with_python:BuildRequires:  python-devel >= 1:2.3}
 BuildRequires: rpm >= 4.4.9-56
 %{?with_python:BuildRequires:  rpm-pythonprov}
-BuildRequires: rpmbuild(macros) >= 1.384
+BuildRequires: rpmbuild(macros) >= 1.527
 BuildRequires: texinfo >= 4.7
 Requires(post,postun): /sbin/ldconfig
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -154,10 +153,14 @@ domen).
 
 # avoid different builds having different timestamps
 # see http://lists.pld-linux.org/mailman/pipermail/pld-devel-en/2008-August/020363.html
-d='$Date: 2011-11-28 18:04:48 $'
+d='$Date: 2012-05-24 11:40:06 $'
 d=${d#?Date: }; d=${d%%%% *}; d=$(date -d "$d" '+%d %B %Y')
 %{__sed} -i -e "s,@value{UPDATED},$d,g" doc/libidn.texi
 
+# remove it when "linking libtool libraries using a non-POSIX archiver ..." warning is gone
+# (after libidn or libtool change)
+%{__sed} -i -e '/AM_INIT_AUTOMAKE/s/-Werror//' configure.ac
+
 %build
 %{__gettextize}
 %{__libtoolize}
@@ -165,9 +168,9 @@ d=${d#?Date: }; d=${d%%%% *}; d=$(date -d "$d" '+%d %B %Y')
 %{__autoconf}
 %{__autoheader}
 %{__automake}
-JAR=%{_bindir}/fastjar \
 %configure \
        --disable-silent-rules \
+       %{__enable_disable static_libs static} \
        %{?with_dotnet:--enable-csharp=mono}%{!?with_dotnet:--disable-csharp} \
        %{?with_java:--enable-java} \
        --with-lispdir=%{_emacs_lispdir}
@@ -177,7 +180,7 @@ JAR=%{_bindir}/fastjar \
 %if %{with python}
 %{__make} -C contrib/idn-python \
        INCLUDE="%{py_incdir} %{rpmcflags} -I../../lib -L../../lib/.libs"
-mv contrib/idn-python/idn.so python-idn.so
+%{__mv} contrib/idn-python/idn.so python-idn.so
 %endif
 
 %install
@@ -207,10 +210,10 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog FAQ NEWS README* THANKS TODO doc/libidn.html contrib
+%doc AUTHORS ChangeLog FAQ NEWS README* THANKS doc/libidn-components.pdf contrib/web
 %attr(755,root,root) %{_bindir}/idn
 %attr(755,root,root) %{_libdir}/libidn.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libidn.so.11
+%attr(755,root,root) %ghost %{_libdir}/libidn.so.12
 %{_mandir}/man1/idn.1*
 %{_infodir}/libidn.info*
 %{_infodir}/libidn-*.png
@@ -233,9 +236,11 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man3/stringprep*.3*
 %{_mandir}/man3/tld_*.3*
 
+%if %{with static_libs}
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/libidn.a
+%endif
 
 %if %{with dotnet}
 %files -n dotnet-libidn
This page took 0.03305 seconds and 4 git commands to generate.