]> git.pld-linux.org Git - packages/libguestfs.git/blobdiff - libguestfs.spec
- updated to 1.22.4
[packages/libguestfs.git] / libguestfs.spec
index a65814e2d198393e94cdeee5a4b0ef4eec81c97a..9583a4a5ec565fa3ae38e2d9ee2e9d42a9275eb2 100644 (file)
@@ -5,6 +5,7 @@
 #
 # Conditional build:
 %bcond_with    static_libs     # build static libraries
+%bcond_with    appliance       # appliance build (no PLD support)
 %bcond_without erlang          # Erlang binding
 %bcond_with    haskell         # Haskell (GHC) binding [incomplete, nothing is installed]
 %bcond_without java            # Java binding
 %bcond_without php             # PHP binding
 %bcond_without python          # Python binding
 %bcond_without ruby            # Ruby binding
-#
 
 %include       /usr/lib/rpm/macros.perl
 %include       /usr/lib/rpm/macros.java
 Summary:       Library and tools for accessing and modifying virtual machine disk images
 Summary(pl.UTF-8):     Biblioteka i narzędzia do dostępu i modyfikacji obrazów dysków maszyn wirtualnych
 Name:          libguestfs
-Version:       1.20.3
+Version:       1.22.4
 Release:       1
 License:       LGPL v2+
 Group:         Libraries
-Source0:       http://libguestfs.org/download/1.20-stable/%{name}-%{version}.tar.gz
-# Source0-md5: a5717d7d3975a141c553dd8a8633d5dd
+Source0:       http://libguestfs.org/download/1.22-stable/%{name}-%{version}.tar.gz
+# Source0-md5: 8317fd78d47afb05d11200a3e747bef1
 Patch0:                ncurses.patch
 Patch1:                augeas-libxml2.patch
 Patch2:                %{name}-link.patch
 Patch3:                %{name}-am.patch
+Patch4:                %{name}-completionsdir.patch
 URL:           http://libguestfs.org/
 BuildRequires: acl-devel
 BuildRequires: attr-devel
@@ -39,11 +40,14 @@ BuildRequires:      augeas-devel >= 0.5.0
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
 BuildRequires: cdrkit-mkisofs
-BuildRequires: cpio
 BuildRequires: db-utils
 # erl_interface package
 %{?with_erlang:BuildRequires:  erlang}
+%if %{with appliance}
 #BuildRequires:        febootstrap >= 3.20
+# or
+#BuildRequires:        supermin >= 4.1.0
+%endif
 BuildRequires: gettext-devel
 %{?with_haskell:BuildRequires: ghc}
 BuildRequires: glib2-devel >= 1:2.26.0
@@ -61,6 +65,7 @@ BuildRequires:        libtool
 BuildRequires: libvirt-devel >= 0.10.2
 BuildRequires: libxml2-devel >= 2.0
 BuildRequires: libxml2-progs
+%{?with_java:BuildRequires:    rpm-javaprov}
 %if %{with lua}
 # use 5.2 as 5.1 packaging in PLD was incompatible with what's expected by configure
 BuildRequires: lua52
@@ -69,6 +74,8 @@ BuildRequires:        lua52-devel
 BuildRequires: ncurses-devel
 %if %{with ocaml}
 BuildRequires: ocaml
+BuildRequires: ocaml-camlp4
+BuildRequires: ocaml-fileutils
 BuildRequires: ocaml-findlib
 BuildRequires: ocaml-gettext-devel
 BuildRequires: ocaml-pcre-devel
@@ -79,33 +86,39 @@ BuildRequires:      perl-tools-pod
 %if %{with perl}
 BuildRequires: perl-ExtUtils-MakeMaker
 BuildRequires: perl-Test-Simple
+BuildRequires: rpm-perlprov
 %endif
 %if %{with perltools}
-BuildRequires: perl-String-ShellQuote
-BuildRequires: perl-Sys-Virt
-BuildRequires: perl-hivex >= 1.2.7
-BuildRequires: perl-libintl
-BuildRequires: perl-modules
 BuildRequires: perl(Data::Dumper)
 BuildRequires: perl(Getopt::Long)
 BuildRequires: perl(Locale::TextDomain)
 BuildRequires: perl(Pod::Man)
 BuildRequires: perl(Pod::Simple)
 BuildRequires: perl(Pod::Usage)
+BuildRequires: perl-String-ShellQuote
+BuildRequires: perl-Sys-Virt
+BuildRequires: perl-hivex >= 1.2.7
+BuildRequires: perl-libintl
+BuildRequires: perl-modules
 %endif
+%{?with_php:BuildRequires:     /usr/bin/php}
 %{?with_php:BuildRequires:     php-devel}
 BuildRequires: pkgconfig
 BuildRequires: po4a
 %if %{with python}
 BuildRequires: python
 BuildRequires: python-devel
+BuildRequires: rpm-pythonprov
 %endif
 BuildRequires: readline-devel
-BuildRequires: rpmbuild(macros) >= 1.322
+BuildRequires: rpmbuild(macros) >= 1.656
 %if %{with ruby}
+BuildRequires: rpm-rubyprov
 BuildRequires: ruby
 BuildRequires: ruby-devel
 BuildRequires: ruby-rake
+BuildRequires: ruby-rdoc
+BuildRequires: ruby-rubygems
 %endif
 BuildRequires: yajl-devel >= 2
 Requires:      qemu-common >= 1.1.0
@@ -353,7 +366,7 @@ Wiązania języka Ruby do libguestfs.
 Summary:       bash-completion for libguestfs tools
 Summary(pl.UTF-8):     Bashowe uzupełnianie argumentów dla narzędzi libguestfs
 Group:         Applications/Shells
-Requires:      bash-completion
+Requires:      bash-completion >= 2.0
 
 %description -n bash-completion-libguestfs
 bash-completion for guestfish tool.
@@ -367,6 +380,7 @@ Bashowe uzupełnianie argumentów dla narzędzi libguestfs.
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 %build
 %{__libtoolize}
@@ -383,11 +397,12 @@ Bashowe uzupełnianie argumentów dla narzędzi libguestfs.
        PAMCUT=/usr/bin/pamcut \
        WRESTOOL=/usr/bin/wrestool \
        QEMU=%{_bindir}/qemu \
+       --with-completionsdir=%{_datadir}/bash-completion/completions \
        --with-html-dir=%{_gtkdocdir} \
        --with-java=%{?with_java:%{java_home}}%{!?with_java:no} \
        --with-qemu=qemu \
        --enable-install-daemon \
-       --disable-appliance \
+       %{!?with_appliance:--disable-appliance} \
        %{!?with_erlang:--disable-erlang} \
        %{!?with_haskell:--disable-haskell} \
        %{!?with_lua:--disable-lua} \
@@ -492,6 +507,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/guestfish
 %attr(755,root,root) %{_bindir}/guestmount
+%attr(755,root,root) %{_bindir}/guestunmount
 %attr(755,root,root) %{_bindir}/libguestfs-test-tool
 %attr(755,root,root) %{_bindir}/virt-alignment-scan
 %attr(755,root,root) %{_bindir}/virt-cat
@@ -507,13 +523,26 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/virt-tar-in
 %attr(755,root,root) %{_bindir}/virt-tar-out
 %attr(755,root,root) %{_sbindir}/guestfsd
+%attr(755,root,root) %{_sbindir}/libguestfs-make-fixed-appliance
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/libguestfs-tools.conf
+/lib/udev/rules.d/99-guestfs-serial.rules
+%dir %{_libdir}/guestfs
+%dir %{_libdir}/guestfs/supermin.d
+%{_libdir}/guestfs/supermin.d/daemon.img
+%{_libdir}/guestfs/supermin.d/init.img
+%{_libdir}/guestfs/supermin.d/udev-rules.img
+%if %{with appliance}
+%{_libdir}/guestfs/supermin.d/base.img
+%{_libdir}/guestfs/supermin.d/hostfiles
+%endif
 %{_mandir}/man1/guestfish.1*
 %{_mandir}/man1/guestfs-faq.1*
 %{_mandir}/man1/guestfs-performance.1*
 %{_mandir}/man1/guestfs-recipes.1*
 %{_mandir}/man1/guestfs-testing.1*
 %{_mandir}/man1/guestmount.1*
+%{_mandir}/man1/guestunmount.1*
+%{_mandir}/man1/libguestfs-make-fixed-appliance.1*
 %{_mandir}/man1/libguestfs-test-tool.1*
 %{_mandir}/man1/virt-alignment-scan.1*
 %{_mandir}/man1/virt-cat.1*
@@ -535,7 +564,8 @@ rm -rf $RPM_BUILD_ROOT
 %lang(ja) %{_mandir}/ja/man1/guestfs-recipes.1*
 %lang(ja) %{_mandir}/ja/man1/guestfs-testing.1*
 %lang(ja) %{_mandir}/ja/man1/guestmount.1*
-#%lang(ja) %{_mandir}/ja/man1/libguestfs-make-fixed-appliance.1*
+%lang(ja) %{_mandir}/ja/man1/guestunmount.1*
+%lang(ja) %{_mandir}/ja/man1/libguestfs-make-fixed-appliance.1*
 %lang(ja) %{_mandir}/ja/man1/libguestfs-test-tool.1*
 %lang(ja) %{_mandir}/ja/man1/virt-alignment-scan.1*
 %lang(ja) %{_mandir}/ja/man1/virt-cat.1*
@@ -556,7 +586,8 @@ rm -rf $RPM_BUILD_ROOT
 %lang(uk) %{_mandir}/uk/man1/guestfs-recipes.1*
 %lang(uk) %{_mandir}/uk/man1/guestfs-testing.1*
 %lang(uk) %{_mandir}/uk/man1/guestmount.1*
-#%lang(uk) %{_mandir}/uk/man1/libguestfs-make-fixed-appliance.1*
+%lang(uk) %{_mandir}/uk/man1/guestunmount.1*
+%lang(uk) %{_mandir}/uk/man1/libguestfs-make-fixed-appliance.1*
 %lang(uk) %{_mandir}/uk/man1/libguestfs-test-tool.1*
 %lang(uk) %{_mandir}/uk/man1/virt-alignment-scan.1*
 %lang(uk) %{_mandir}/uk/man1/virt-cat.1*
@@ -608,6 +639,7 @@ rm -rf $RPM_BUILD_ROOT
 %lang(uk) %{_mandir}/uk/man1/virt-win-reg.1*
 %endif
 
+
 %if %{with erlang}
 %files -n erlang-libguestfs
 %defattr(644,root,root,755)
@@ -669,15 +701,12 @@ rm -rf $RPM_BUILD_ROOT
 %files -n perl-libguestfs
 %defattr(644,root,root,755)
 %{perl_vendorarch}/Sys/Guestfs.pm
-%dir %{perl_vendorarch}/Sys/Guestfs
-%{perl_vendorarch}/Sys/Guestfs/Lib.pm
 %{perl_vendorarch}/Sys/bindtests.pl
 %dir %{perl_vendorarch}/auto/Sys/Guestfs
 %{perl_vendorarch}/auto/Sys/Guestfs/Guestfs.bs
 %attr(755,root,root) %{perl_vendorarch}/auto/Sys/Guestfs/Guestfs.so
 %{_mandir}/man3/guestfs-perl.3*
 %{_mandir}/man3/Sys::Guestfs.3pm*
-%{_mandir}/man3/Sys::Guestfs::Lib.3pm*
 %lang(ja) %{_mandir}/ja/man3/guestfs-perl.3*
 %lang(uk) %{_mandir}/uk/man3/guestfs-perl.3*
 %endif
@@ -702,8 +731,8 @@ rm -rf $RPM_BUILD_ROOT
 %if %{with ruby}
 %files -n ruby-libguestfs
 %defattr(644,root,root,755)
-%attr(755,root,root) %{ruby_sitearchdir}/_guestfs.so
-%{ruby_sitelibdir}/guestfs.rb
+%attr(755,root,root) %{ruby_vendorarchdir}/_guestfs.so
+%{ruby_vendorlibdir}/guestfs.rb
 %{_mandir}/man3/guestfs-ruby.3*
 %lang(ja) %{_mandir}/ja/man3/guestfs-ruby.3*
 %lang(uk) %{_mandir}/uk/man3/guestfs-ruby.3*
@@ -711,4 +740,6 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -n bash-completion-libguestfs
 %defattr(644,root,root,755)
-%attr(755,root,root) /etc/bash_completion.d/guestfish-bash-completion.sh
+%{_datadir}/bash-completion/completions/guestfish
+%{_datadir}/bash-completion/completions/guestmount
+%{_datadir}/bash-completion/completions/virt-*
This page took 0.084073 seconds and 4 git commands to generate.