]> git.pld-linux.org Git - packages/libgit2.git/blobdiff - libgit2.spec
up to 1.4.4 (security fixes)
[packages/libgit2.git] / libgit2.spec
index 831115f99f8e87117228b4d10a8883ac57f927aa..d3152054409bc3aa8f775d406bfba0c24870e187 100644 (file)
@@ -1,22 +1,31 @@
 #
 # Conditional build:
-%bcond_without tests           # build without tests
+%bcond_without kerberos5       # GSSAPI for SPNEGO auth
+%bcond_without libssh          # SSH support via libssh2
+%bcond_with    tests           # build without tests
 
-Summary:       C git library
-Summary(pl.UTF-8):     Biblioteka git dla C
+Summary:       C Git library
+Summary(pl.UTF-8):     Biblioteka Git dla C
 Name:          libgit2
-Version:       0.18.0
+Version:       1.4.4
 Release:       1
 License:       GPL v2 with linking exception
 Group:         Libraries
-Source0:       https://github.com/libgit2/libgit2/archive/v%{version}.tar.gz?/%{name}-version.tgz
-# Source0-md5: ce6845df0dd084ef2633a69dba64929c
-Patch0:                %{name}-http-parser.patch
+#Source0Download: https://github.com/libgit2/libgit2/releases
+Source0:       https://github.com/libgit2/libgit2/archive/v%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: ec27f13cc0cb2b5b512f2b3854d896fa
+Patch0:                %{name}-no-libgit2-test.patch
+Patch1:                pcre2-detect.ptch
 URL:           http://libgit2.github.com/
-BuildRequires: cmake >= 2.6
-BuildRequires: http-parser-devel
+BuildRequires: cmake >= 3.5.1
+%{?with_kerberos5:BuildRequires:       heimdal-devel}
+BuildRequires: http-parser-devel >= 2
+%{?with_libssh:BuildRequires:  libssh2-devel}
 BuildRequires: openssl-devel
+BuildRequires: pcre2-8-devel
+BuildRequires: pkgconfig
 %{?with_tests:BuildRequires:   python}
+BuildRequires: rpmbuild(macros) >= 1.742
 BuildRequires: zlib-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -37,6 +46,8 @@ Summary:      Header files for libgit2 library
 Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki libgit2
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
+Requires:      http-parser-devel
+Requires:      libssh2-devel
 Requires:      openssl-devel
 Requires:      zlib-devel
 
@@ -49,17 +60,31 @@ Pliki nagłówkowe biblioteki libgit2.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
+
+# Don't test network
+sed -i '/ADD_TEST(online/s/^/#/' tests/CMakeLists.txt
 
 %build
 install -d build
 cd build
-%cmake ..
+# CMakeLists.txt supports only relative LIB_INSTALL_DIR and INCLUDE_INSTALL_DIR
+# (otherwise .pc file is generated incorrectly).
+# Type (:PATH or :STRING) must be specified explicitly to avoid expansion
+# relative to cwd.
+%cmake .. \
+       %{cmake_on_off tests BUILD_TESTS} \
+       -DREGEX_BACKEND=pcre2 \
+       %{cmake_on_off kerberos5 USE_GSSAPI} \
+       -DUSE_HTTP_PARSER=system \
+       %{cmake_on_off libssh USE_SSH}
 %{__make}
 
 %{?with_tests:%{__make} test ARGS="-V"}
 
 %install
 rm -rf $RPM_BUILD_ROOT
+
 %{__make} -C build install \
        DESTDIR=$RPM_BUILD_ROOT
 
@@ -71,9 +96,9 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS CONTRIBUTING.md COPYING README.md
+%doc AUTHORS docs/contributing.md COPYING README.md
 %attr(755,root,root) %{_libdir}/libgit2.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libgit2.so.0
+%attr(755,root,root) %ghost %{_libdir}/libgit2.so.1.4
 
 %files devel
 %defattr(644,root,root,755)
This page took 0.09586 seconds and 4 git commands to generate.