]> git.pld-linux.org Git - packages/libgit2.git/blobdiff - libgit2.spec
up to 0.24.0, SONAME change
[packages/libgit2.git] / libgit2.spec
index 85da836b9c87f6ef09db78e74ca9f8fd10405dd2..461f55f399a8160c4005bb1d5dfbb4ecfbd65611 100644 (file)
@@ -1,23 +1,28 @@
 #
 # Conditional build:
+%bcond_without kerberos5       # GSSAPI for SPNEGO auth
 %bcond_without tests           # build without tests
 %bcond_with    tests_online    # build with tests reqiuring online access
 
-Summary:       C git library
-Summary(pl.UTF-8):     Biblioteka git dla C
+Summary:       C Git library
+Summary(pl.UTF-8):     Biblioteka Git dla C
 Name:          libgit2
-Version:       0.19.0
+Version:       0.24.0
 Release:       1
 License:       GPL v2 with linking exception
 Group:         Libraries
-Source0:       https://github.com/libgit2/libgit2/archive/v%{version}.tar.gz?/%{name}-%{version}.tar.gz
-# Source0-md5: d682d9424d95f697bf3f89b358fe8e1a
+Source0:       https://github.com/libgit2/libgit2/archive/v%{version}/%{name}-%{version}.tar.gz
+# Source0-md5: 8cabf04502d7203793b32f47ca410ae3
 Patch0:                %{name}-test-online.patch
+Patch1:                %{name}-no-libgit2-test.patch
 URL:           http://libgit2.github.com/
-BuildRequires: cmake >= 2.6
-BuildRequires: http-parser-devel
+BuildRequires: cmake >= 2.8
+BuildRequires: curl-devel
+%{?with_kerberos5:BuildRequires:       heimdal-devel}
+BuildRequires: http-parser-devel >= 2
 BuildRequires: libssh2-devel
 BuildRequires: openssl-devel
+BuildRequires: pkgconfig
 %{?with_tests:BuildRequires:   python}
 BuildRequires: zlib-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
@@ -39,6 +44,8 @@ Summary:      Header files for libgit2 library
 Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki libgit2
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
+Requires:      http-parser-devel
+Requires:      libssh2-devel
 Requires:      openssl-devel
 Requires:      zlib-devel
 
@@ -51,12 +58,21 @@ Pliki nagłówkowe biblioteki libgit2.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
 
 %build
 install -d build
 cd build
+# CMakeLists.txt supports only relative LIB_INSTALL_DIR and INCLUDE_INSTALL_DIR
+# (otherwise .pc file is generated incorrectly).
+# Type (:PATH or :STRING) must be specified explicitly to avoid expansion
+# relative to cwd.
 %cmake .. \
-       %{?with_tests_online:-DONLINE_TESTS=1}
+       -DINCLUDE_INSTALL_DIR:PATH=include \
+       -DLIB_INSTALL_DIR:PATH=%{_lib} \
+       %{?with_tests_online:-DONLINE_TESTS:BOOL=ON} \
+       -DTHREADSAFE:BOOL=ON \
+       %{?with_kerberos5:-DUSE_GSSAPI:BOOL=ON}
 %{__make}
 
 %{?with_tests:%{__make} test ARGS="-V"}
@@ -76,7 +92,7 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc AUTHORS CONTRIBUTING.md COPYING README.md
 %attr(755,root,root) %{_libdir}/libgit2.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libgit2.so.0
+%attr(755,root,root) %ghost %{_libdir}/libgit2.so.24
 
 %files devel
 %defattr(644,root,root,755)
This page took 0.067261 seconds and 4 git commands to generate.