]> git.pld-linux.org Git - packages/libgee.git/blobdiff - libgee.spec
- updated to 0.20.6
[packages/libgee.git] / libgee.spec
index 5a08394d0be595debb99194c625f8b708ffefb09..7028f1913a4f00fb4b38a67a543c50c357679d0b 100644 (file)
@@ -1,17 +1,35 @@
 #
 # Conditional build:
-%bcond_without apidocs         # do not build and package API docs
-#
+%bcond_without apidocs         # API documentation (valadoc)
+%bcond_without static_libs     # static library
+%bcond_with    bootstrap       # bootstrap without apidocs subpackage (alias for without_apidocs)
+
+%if %{with bootstrap}
+%undefine      with_apidocs
+%endif
 Summary:       libgee - GObject collection library
-Summary(pl.UTF-8):     libgee - GObject collection library
+Summary(pl.UTF-8):     libgee - biblioteka kolekcji oparta na GObject
 Name:          libgee
-Version:       0.1.5
-Release:       0.1
-License:       LGPL
+Version:       0.20.6
+Release:       1
+License:       LGPL v2+
 Group:         Libraries
-Source0:       http://ftp.gnome.org/pub/GNOME/sources/libgee/0.1/%{name}-%{version}.tar.bz2
-# Source0-md5: 80102073421e4d7fb18a6aa9622f4de2
-BuildRequires: xulrunner-devel
+Source0:       https://download.gnome.org/sources/libgee/0.20/%{name}-%{version}.tar.xz
+# Source0-md5: 8b9001f47e15ef7a1776ac1f5bb015a0
+Patch0:                %{name}-doc.patch
+URL:           https://wiki.gnome.org/Projects/Libgee
+BuildRequires: autoconf >= 2.50
+BuildRequires: automake >= 1:1.11
+BuildRequires: glib2-devel >= 1:2.36.0
+BuildRequires: gobject-introspection-devel >= 0.9.0
+BuildRequires: libtool
+BuildRequires: pkgconfig
+BuildRequires: tar >= 1:1.22
+%{?with_apidocs:BuildRequires: valadoc}
+BuildRequires: xz
+# not required for stable releases (all generated files are included)
+#BuildRequires:        vala >= 2:0.25.1
+Requires:      glib2 >= 1:2.36.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -19,14 +37,15 @@ libgee is a collection library providing GObject-based interfaces and
 classes for commonly used data structures.
 
 %description -l pl.UTF-8
-libgee jest zbiorem bibliotek dostarczających interfejs GObject i
-klasy powszechnie używanych struktur danych.
+libgee jest biblioteką udostępniajacą oparte na bibliotece GObject
+interfejsy oraz klasy powszechnie używanych struktur danych.
 
 %package devel
 Summary:       Header files for libgee library
 Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki libgee
 Group:         Development/Libraries
 Requires:      %{name} = %{version}-%{release}
+Requires:      glib2-devel >= 1:2.36.0
 
 %description devel
 Header files for libgee library.
@@ -34,11 +53,58 @@ Header files for libgee library.
 %description devel -l pl.UTF-8
 Pliki nagłówkowe biblioteki libgee.
 
+%package static
+Summary:       Static libgee library
+Summary(pl.UTF-8):     Statyczna biblioteka libgee
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
+
+%description static
+Static libgee library.
+
+%description static -l pl.UTF-8
+Statyczna biblioteka libgee.
+
+%package -n vala-libgee
+Summary:       libgee API for Vala language
+Summary(pl.UTF-8):     API libgee dla języka Vala
+Group:         Development/Libraries
+Requires:      %{name}-devel = %{version}-%{release}
+Requires:      vala >= 2:0.25.1
+BuildArch:     noarch
+
+%description -n vala-libgee
+libgee API for Vala language.
+
+%description -n vala-libgee -l pl.UTF-8
+API libgee dla języka Vala.
+
+%package apidocs
+Summary:       API documentation for libgee library
+Summary(pl.UTF-8):     Dokumentacja API biblioteki libgee
+Group:         Documentation
+BuildArch:     noarch
+
+%description apidocs
+API documentation for libgee library.
+
+%description apidocs -l pl.UTF-8
+Dokumentacja API biblioteki libgee.
+
 %prep
 %setup -q
+%patch0 -p1
 
 %build
-%configure
+%{__libtoolize}
+%{__aclocal}
+%{__autoconf}
+%{__autoheader}
+%{__automake}
+%configure \
+       %{?with_apidocs:--enable-doc} \
+       --disable-silent-rules \
+       %{?with_static_libs:--enable-static}
 %{__make}
 
 %install
@@ -47,6 +113,8 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/libgee-0.8.la
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -55,14 +123,30 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc AUTHORS ChangeLog NEWS README
-%attr(755,root,root) %{_libdir}/libgee.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libgee.so.0
+%doc AUTHORS ChangeLog MAINTAINERS NEWS README
+%attr(755,root,root) %{_libdir}/libgee-0.8.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libgee-0.8.so.2
+%{_libdir}/girepository-1.0/Gee-0.8.typelib
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libgee.so
-%{_libdir}/libgee.la
-%{_pkgconfigdir}/gee-1.0.pc
-%{_includedir}/gee-1.0
-%{_datadir}/vala/vapi/gee-1.0.vapi
+%attr(755,root,root) %{_libdir}/libgee-0.8.so
+%{_pkgconfigdir}/gee-0.8.pc
+%{_includedir}/gee-0.8
+%{_datadir}/gir-1.0/Gee-0.8.gir
+
+%if %{with static_libs}
+%files static
+%defattr(644,root,root,755)
+%{_libdir}/libgee-0.8.a
+%endif
+
+%files -n vala-libgee
+%defattr(644,root,root,755)
+%{_datadir}/vala/vapi/gee-0.8.vapi
+
+%if %{with apidocs}
+%files apidocs
+%defattr(644,root,root,755)
+%{_datadir}/devhelp/references/gee-0.8
+%endif
This page took 0.031432 seconds and 4 git commands to generate.