]> git.pld-linux.org Git - packages/libfuse.git/blobdiff - libfuse.spec
- up to 2.8.5
[packages/libfuse.git] / libfuse.spec
index da8723f99c3011aa64474814830be53375ec39c4..7eb37abfe4b07d573f89839a8f36041c68e6350b 100644 (file)
@@ -1,35 +1,47 @@
+# TODO:
+# - unpackaged:
+#   /etc/init.d/fuse
+#   /etc/udev/rules.d/99-fuse.rules
 #
 # Condtional build:
 %bcond_without dist_kernel     # without distribution kernel
 %bcond_with    kernel          # build kernel modules
 %bcond_without userspace       # don't build userspace tools
 %bcond_with    verbose         # verbose build (V=1)
-%bcond_with    grsec_kernel    # build for kernel-grsecurity
 %bcond_without selinux         # build without SELinux support
-#
-%if %{with kernel} && %{with dist_kernel} && %{with grsec_kernel}
-%define        alt_kernel      grsecurity
+
+%ifarch sparc
+%undefine      with_smp
 %endif
-#
-%define                _rel    3
+
+%if %{without kernel}
+%undefine with_dist_kernel
+%endif
+%if "%{_alt_kernel}" != "%{nil}"
+%undefine      with_userspace
+%endif
+
+%define                pname   libfuse
+%define                rel     1
 Summary:       Filesystem in Userspace
 Summary(pl.UTF-8):     System plików w przestrzeni użytkownika
-Name:          libfuse
-Version:       2.6.5
-Release:       %{_rel}
+Name:          %{pname}%{_alt_kernel}
+Version:       2.8.5
+Release:       %{rel}
 Epoch:         0
 License:       GPL v2
 Group:         Applications/System
 Source0:       http://dl.sourceforge.net/fuse/fuse-%{version}.tar.gz
-# Source0-md5: 66bd30503df55a87b9868835ca5a45bc
+# Source0-md5: 8aa2fd689de00b73963620483084ae3b
 Source1:       fuse.conf
 Patch0:                kernel-misc-fuse-Makefile.am.patch
-Patch1:                %{name}-link.patch
+Patch1:                %{pname}-link.patch
 URL:           http://fuse.sourceforge.net/
 BuildRequires: autoconf
 BuildRequires: automake
-BuildRequires: libtool
 BuildRequires: cpp
+BuildRequires: gettext-devel
+BuildRequires: libtool
 BuildRequires: sed >= 4.0
 %if %{with kernel}
 %{?with_dist_kernel:BuildRequires:     kernel%{_alt_kernel}-module-build >= 3:2.6.20.2}
@@ -38,15 +50,10 @@ BuildRequires:      rpmbuild(macros) >= 1.379
 %if %{with userspace}
 %{?with_selinux:BuildRequires: libselinux-devel}
 %endif
-Requires(postun):      /sbin/ldconfig
-Requires(postun):      /usr/sbin/groupdel
 Requires(pre): /usr/bin/getgid
 Requires(pre): /usr/sbin/groupadd
-Buildroot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
-
-%if !%{with kernel}
-%undefine with_dist_kernel
-%endif
+Provides:      group(fuse)
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 FUSE (Filesystem in Userspace) is a simple interface for userspace
@@ -69,7 +76,7 @@ Ten pakiet zawiera bibliotekę współdzieloną.
 Summary:       Filesytem in Userspace - Development header files
 Summary(pl.UTF-8):     System plików w przestrzeni użytkownika - pliki nagłówkowe
 Group:         Development/Libraries
-Requires:      %{name} = %{epoch}:%{version}-%{_rel}
+Requires:      %{pname} = %{epoch}:%{version}-%{rel}
 
 %description devel
 Libfuse library header files.
@@ -81,7 +88,7 @@ Pliki nagłówkowe biblioteki libfuse.
 Summary:       Filesytem in Userspace - static library
 Summary(pl.UTF-8):     System plików w przestrzeni użytkownika - biblioteka statyczna
 Group:         Development/Libraries
-Requires:      libfuse-devel = %{epoch}:%{version}-%{_rel}
+Requires:      libfuse-devel = %{epoch}:%{version}-%{rel}
 
 %description static
 Static libfuse libraries.
@@ -92,7 +99,7 @@ Statyczna biblioteka libfuse.
 %package -n kernel%{_alt_kernel}-misc-fuse
 Summary:       Filesystem in Userspace
 Summary(pl.UTF-8):     System plików w przestrzeni użytkownika
-Release:       %{_rel}@%{_kernel_ver_str}
+Release:       %{rel}@%{_kernel_ver_str}
 License:       GPL v2
 Group:         Base/Kernel
 Requires(post,postun): /sbin/depmod
@@ -138,7 +145,6 @@ sed -i '/FUSERMOUNT_PROG/s,fusermount,%{_bindir}/fusermount,' lib/mount.c
        %{?with_kernel:--with-kernel=%{_kernelsrcdir}}
 
 %if %{with userspace}
-cp kernel/fuse_kernel.h include/
 for DIR in include lib util; do
 %{__make} -C $DIR
 done
@@ -173,11 +179,7 @@ rm -rf $RPM_BUILD_ROOT
 %groupadd -g 84 fuse
 
 %post  -p /sbin/ldconfig
-%postun
-/sbin/ldconfig
-if [ "$1" = "0" ] ; then
-       %groupremove fuse
-fi
+%postun        -p /sbin/ldconfig
 
 %post -n kernel%{_alt_kernel}-misc-fuse
 %depmod %{_kernel_ver}
@@ -193,19 +195,26 @@ fi
 %attr(4754,root,fuse) %{_bindir}/fusermount
 %attr(755,root,root) %{_bindir}/ulockmgr_server
 %attr(755,root,root) /sbin/mount.fuse
-%attr(755,root,root) %{_libdir}/lib*.so.*.*.*
+%attr(755,root,root) %{_libdir}/libfuse.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libfuse.so.2
+%attr(755,root,root) %{_libdir}/libulockmgr.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libulockmgr.so.1
 
 %files devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/lib*.so
-%{_libdir}/lib*.la
-%{_includedir}/fuse*
+%attr(755,root,root) %{_libdir}/libfuse.so
+%attr(755,root,root) %{_libdir}/libulockmgr.so
+%{_libdir}/libfuse.la
+%{_libdir}/libulockmgr.la
+%{_includedir}/fuse
+%{_includedir}/fuse.h
 %{_includedir}/ulockmgr.h
 %{_pkgconfigdir}/fuse.pc
 
 %files static
 %defattr(644,root,root,755)
-%{_libdir}/lib*.a
+%{_libdir}/libfuse.a
+%{_libdir}/libulockmgr.a
 %endif
 
 %if %{with kernel}
This page took 0.033727 seconds and 4 git commands to generate.