]> git.pld-linux.org Git - packages/lftp.git/blobdiff - lftp.spec
- moved .desktop file to %%{_desktopdir}
[packages/lftp.git] / lftp.spec
index 641ef222f0edc45f196f0718f8b985a62c073f45..fca58580a35ee290e79e9ee436dde10cd965b9b3 100644 (file)
--- a/lftp.spec
+++ b/lftp.spec
-Summary:       Commandline ftp client
-Summary(pl):   Zaawansowany klient ftp
+#
+# Conditional build:
+# _without_ssl - do not use SSL
+#
+Summary:       Sophisticated command line ftp/http client
+Summary(ko):   ¸í·ÉÁÙ¿¡¼­ µ¹¾Æ°¡´Â ftp/http Å¬¶óÀ̾ðÆ®
+Summary(pl):   Zaawansowany klient ftp/http
+Summary(pt_BR):        Sofisticado programa de transferência de arquivos (cliente ftp/http)
+Summary(zh_CN):        lftp ¿Í»§¶Ë³ÌÐò
 Name:          lftp
-Version:       2.2.4
-Release:       1
+Version:       2.6.9
+Release:       2
 License:       GPL
 Group:         Applications/Networking
-Group(pl):     Aplikacje/Sieciowe
 Source0:       ftp://ftp.yars.free.net/pub/software/unix/net/ftp/client/lftp/%{name}-%{version}.tar.bz2
-Patch0:                lftp-passive.patch
+# Source0-md5: 34ae6b74b003e99ccae4dd82122192ed
+Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
+# Source1-md5: cdad8fb5342eebd9916eccefc98a855b
+Source2:       %{name}.desktop
+Patch0:                %{name}-amfix.patch
+Patch1:                %{name}-pl.po-update.patch
+Patch2:                %{name}-no_pkgverlibdir.patch
+Patch3:                %{name}-home_etc.patch
+Patch4:                %{name}-acfix.patch
 Icon:          ftp.gif
-URL:           http://ftp.yars.free.net/projects/lftp/
-BuildRequires: ncurses-devel >= 5.0
-BuildRequires: readline-devel >= 4.1
+URL:           http://lftp.yar.ru/
+BuildRequires: autoconf
+BuildRequires: automake
 BuildRequires: gettext-devel
+BuildRequires: libstdc++-devel
+BuildRequires: libtool >= 1:1.4.2-9
+BuildRequires: ncurses-devel >= 5.2
+%{!?_without_ssl:BuildRequires:        openssl-devel >= 0.9.7c}
+BuildRequires: readline-devel >= 4.2
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _sysconfdir     /etc
+%define                _gcc_ver        %(%{__cc} -dumpversion | cut -b 1)
+%if %{_gcc_ver} == 2
+%define                __cxx           "%{__cc}"
+%endif
 
 %description
-LFTP is a shell-like command line ftp client. The main two advantages over
-other ftp clients are reliability and ability to perform tasks in
-background. It will reconnect and reget the file being transferred if the
-connection broke. You can start a transfer in background and continue
-browsing on the ftp site. It does this all in one process. When you have
-started background jobs and feel you are done, you can just exit lftp and
-it automatically moves to nohup mode and completes the transfers. It has
-also such nice features as reput and mirror.
+LFTP is a shell-like command line ftp/http client. The main two
+advantages over other ftp clients are reliability and ability to
+perform tasks in background. It will reconnect and reget the file
+being transferred if the connection broke. You can start a transfer in
+background and continue browsing on the ftp site. It does this all in
+one process. When you have started background jobs and feel you are
+done, you can just exit lftp and it automatically moves to nohup mode
+and completes the transfers. It has also such nice features as reput
+and mirror.
 
 %description -l pl
-Lftp jest zaawansowanym klientem ftp. Potrafi automatycznie po³±czyæ siê z
-serwerem ftp po zerwanym po³±czeniu i dokoñczyæ ¶ci±ganie archiwów. Lftp
-mo¿e pracowaæ w tle i nie zrywa przy tym po³±czenia po tym jak siê
-wylogujesz. Program ten honoruje komendy pow³oki podczas sesji, np. `ls
--al | less` itp. Doskonale siê spisuje jako aplikacja do mirrorowania
-serwerów FTP.
+Lftp jest zaawansowanym klientem ftp/http. Potrafi automatycznie
+po³±czyæ siê z serwerem ftp po zerwanym po³±czeniu i dokoñczyæ
+¶ci±ganie archiwów. Lftp mo¿e pracowaæ w tle i nie zrywa przy tym
+po³±czenia po tym jak siê wylogujesz. Program ten honoruje komendy
+pow³oki podczas sesji, np. `ls -al | less` itp. Doskonale siê spisuje
+jako aplikacja do mirrorowania serwerów FTP.
+
+%description -l pt_BR
+O lftp é um programa de transferência de arquivos por linha de
+comando. Ele suporta os protocolos ftp/http. Suporta: proxy ftp, proxy
+http, ftp sobre http, opie/skey, transferências fxp, repetição de
+tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
+o arquivo FEATURES para uma lista mais detalhada.
 
 %prep
 %setup -q
-%patch -p1
+%patch0 -p1
+%patch1 -p1
+%patch2 -p1
+%patch3 -p1
+%patch4 -p1
 
 %build
-gettextize --copy --force
-LDFLAGS="-s"; export LDFLAGS
-CXXFLAGS="$RPM_OPT_FLAGS -fno-rtti -fno-exceptions -fno-implicit-templates"; export CXXFLAGS
+%{__libtoolize}
+%{__gettextize}
+%{__aclocal} -I m4
+%{__autoconf}
+%{__automake}
+CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions -fno-implicit-templates"
 %configure \
-       --with-modules
+       --with-modules \
+       --with%{?_without_ssl:out}-ssl
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_sysconfdir}
+install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}}
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
 install lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
+install contrib/lftp-icon.png $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
+install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
 
-chmod +x $RPM_BUILD_ROOT%{_libdir}/lftp/*
-
-gzip -9nf $RPM_BUILD_ROOT%{_mandir}/man1/* \
-       README NEWS
+bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
 
 %find_lang %{name}
 
@@ -67,12 +105,19 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc {README,NEWS}.gz
-
+%doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
 %config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/lftp.conf
 %attr(755,root,root) %{_bindir}/*
-%{_mandir}/man1/*
-%attr(755,root,root) %{_datadir}/lftp
-
 %dir %{_libdir}/lftp
-%attr(755,root,root) %{_libdir}/lftp/*.so
+%attr(755,root,root) %{_libdir}/lftp/cmd-mirror.so
+%attr(755,root,root) %{_libdir}/lftp/cmd-sleep.so
+%attr(755,root,root) %{_libdir}/lftp/libnetwork.so
+%attr(755,root,root) %{_libdir}/lftp/proto-file.so
+%attr(755,root,root) %{_libdir}/lftp/proto-fish.so
+%attr(755,root,root) %{_libdir}/lftp/proto-ftp.so
+%attr(755,root,root) %{_libdir}/lftp/proto-http.so
+%attr(755,root,root) %{_datadir}/lftp
+%{_mandir}/man1/*
+%lang(pl) %{_mandir}/pl/man1/*
+%{_desktopdir}/lftp.desktop
+%{_pixmapsdir}/lftp.png
This page took 0.135913 seconds and 4 git commands to generate.