]> git.pld-linux.org Git - packages/lftp.git/blobdiff - lftp.spec
- Up to 4.1.1
[packages/lftp.git] / lftp.spec
index 6e4ac418601ae7935f7adcef7fe01b07f9776dcb..b1f9fb7784c6770d89fc54e7165b99fca8438d8c 100644 (file)
--- a/lftp.spec
+++ b/lftp.spec
@@ -2,8 +2,8 @@
 # - package itself defaults to GNUTLS (prefferring over openssl) should we too?
 #
 # Conditional build:
-%bcond_without ssl             # do not use SSL
-%bcond_with            gnutls  # use gnutls, otherwise openssl is used when ssl is on
+%bcond_without ssl     # do not use SSL
+%bcond_with    gnutls  # use gnutls, otherwise openssl is used when ssl is on
 
 %if %{with ssl}
 %define with_openssl 1
 %endif
 
 Summary:       Sophisticated command line FTP/HTTP client
-Summary(ko):   ¸í·ÉÁÙ¿¡¼­ µ¹¾Æ°¡´Â FTP/HTTP Å¬¶óÀ̾ðÆ®
-Summary(pl):   Zaawansowany klient FTP/HTTP
-Summary(pt_BR):        Sofisticado programa de transferência de arquivos (cliente FTP/HTTP)
-Summary(zh_CN):        lftp ¿Í»§¶Ë³ÌÐò
+Summary(ko.UTF-8):     명령줄에서 돌아가는 FTP/HTTP 클라이언트
+Summary(pl.UTF-8):     Zaawansowany klient FTP/HTTP
+Summary(pt_BR.UTF-8):  Sofisticado programa de transferência de arquivos (cliente FTP/HTTP)
+Summary(zh_CN.UTF-8):  lftp 客户端程序
 Name:          lftp
-Version:       3.3.0
+Version:       4.1.1
 Release:       1
-License:       GPL
+License:       GPL v3+
 Group:         Applications/Networking
-Source0:       ftp://ftp.yars.free.net/pub/software/unix/net/ftp/client/lftp/%{name}-%{version}.tar.bz2
-# Source0-md5: 5f06462c88618ecd61db8e46ef494bc3
+Source0:       http://ftp.yars.free.net/pub/source/lftp/%{name}-%{version}.tar.xz
+# Source0-md5: ab8b4533d15f5ab4bda721c2be1130ce
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
 # Source1-md5: cdad8fb5342eebd9916eccefc98a855b
 Source2:       %{name}.desktop
+Source3:       %{name}-icon.png
+# outdated and nobody cared for 8+ years... will be dropped
 Patch0:                %{name}-home_etc.patch
-Icon:          ftp.gif
+Patch1:                %{name}-makefile.patch
+# ALWAYS send updated patch to lftp mailing lists
+Patch2:                %{name}-pl.po-update.patch
+Patch3:                %{name}-m4.patch
 URL:           http://lftp.yar.ru/
-BuildRequires: autoconf
+BuildRequires: autoconf >= 2.60
 BuildRequires: automake
 BuildRequires: gettext-devel >= 0.14.2
+%{?with_gnutls:BuildRequires:  gnutls-devel >= 1.2.5}
 BuildRequires: libstdc++-devel
 BuildRequires: libtool >= 1:1.4.2-9
 BuildRequires: ncurses-devel >= 5.2
 %{?with_openssl:BuildRequires: openssl-devel >= 0.9.7d}
-%{?with_gnutls:BuildRequires:  gnutls-devel >= 1.2.5}
+BuildRequires: pkgconfig
 BuildRequires: readline-devel >= 4.2
-BuildRequires: sed >= 4.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _gcc_ver        %(%{__cc} -dumpversion | cut -b 1)
@@ -59,28 +64,31 @@ done, you can just exit lftp and it automatically moves to nohup mode
 and completes the transfers. It has also such nice features as reput
 and mirror.
 
-%description -l pl
+%description -l pl.UTF-8
 Lftp jest zaawansowanym klientem FTP/HTTP. Potrafi automatycznie
-po³±czyæ siê z serwerem FTP po zerwanym po³±czeniu i dokoñczyæ
-¶ci±ganie archiwów. Lftp mo¿e pracowaæ w tle i nie zrywa przy tym
-po³±czenia po tym jak siê wylogujesz. Program ten honoruje komendy
-pow³oki podczas sesji, np. `ls -al | less` itp. Doskonale siê spisuje
-jako aplikacja do mirrorowania serwerów FTP.
-
-%description -l pt_BR
-O lftp é um programa de transferência de arquivos por linha de
+połączyć się z serwerem FTP po zerwanym połączeniu i dokończyć
+ściąganie archiwów. Lftp może pracować w tle i nie zrywa przy tym
+połączenia po tym jak się wylogujesz. Program ten honoruje komendy
+powłoki podczas sesji, np. `ls -al | less` itp. Doskonale się spisuje
+jako aplikacja do mirrorowania serwerów FTP.
+
+%description -l pt_BR.UTF-8
+O lftp é um programa de transferência de arquivos por linha de
 comando. Ele suporta os protocolos FTP/HTTP. Suporta: proxy FTP, proxy
-HTTP, FTP sobre HTTP, opie/skey, transferências fxp, repetição de
-tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
+HTTP, FTP sobre HTTP, opie/skey, transferências fxp, repetição de
+tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
 o arquivo FEATURES para uma lista mais detalhada.
 
 %prep
 %setup -q
-#%patch0 -p1
+#%%patch0 -p1
+%patch1 -p1
+%patch2 -p1
+%patch3 -p1
 
-sed -i -e 's#pkgverlibdir.*=.*#pkgverlibdir = $(pkglibdir)#g' src/Makefile*
-# for gettext >= 0.14.2
-sed -i -e 's/jm_AC/gl_AC/' m4/human.m4
+%{__rm} po/stamp-po
+
+%{!?with_gnutls:echo 'AC_DEFUN([AM_PATH_LIBGNUTLS],[/bin/true])' > m4/gnutls.m4}
 
 %build
 %{__libtoolize}
@@ -88,10 +96,9 @@ sed -i -e 's/jm_AC/gl_AC/' m4/human.m4
 %{__aclocal} -I m4
 %{__autoconf}
 %{__automake}
-CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions -fno-implicit-templates"
+CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions"
 %configure \
        --with-modules \
-       --with%{!?with_ssl:out}-ssl \
        --with%{!?with_openssl:out}-openssl \
        --with%{!?with_gnutls:out}-gnutls
 
@@ -105,25 +112,35 @@ install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_pixmapsdir},%{_desktopdir}}
        DESTDIR=$RPM_BUILD_ROOT
 
 install lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
-install contrib/lftp-icon.png $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
+install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}/lftp.png
 
 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/{README.lftp-man-pages,lftpget.diff}
+%{__rm} $RPM_BUILD_ROOT%{_libdir}/*.{la,so}
 
 %find_lang %{name}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
+
 %files -f %{name}.lang
 %defattr(644,root,root,755)
 %doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lftp.conf
-%attr(755,root,root) %{_bindir}/*
+%attr(755,root,root) %{_bindir}/lftp
+%attr(755,root,root) %{_bindir}/lftpget
+%attr(755,root,root) %{_libdir}/liblftp*.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/liblftp*.so.0
 %dir %{_libdir}/lftp
 %attr(755,root,root) %{_libdir}/lftp/*.so
 %attr(755,root,root) %{_datadir}/lftp
-%{_mandir}/man1/*
-%lang(pl) %{_mandir}/pl/man1/*
+%{_mandir}/man1/lftp.1*
+%{_mandir}/man1/lftpget.1*
+%lang(pl) %{_mandir}/pl/man1/lftpget.1*
+%{_mandir}/man5/lftp.conf.5*
 %{_desktopdir}/lftp.desktop
 %{_pixmapsdir}/lftp.png
This page took 0.073873 seconds and 4 git commands to generate.