]> git.pld-linux.org Git - packages/lftp.git/blobdiff - lftp.spec
- 2.4.0
[packages/lftp.git] / lftp.spec
index 2de6fc2bfd4f09f7f7a426c336a7a8bd77a0f431..2a5f92eec748df6821d08b9f61dd82e41e5a44e0 100644 (file)
--- a/lftp.spec
+++ b/lftp.spec
@@ -1,62 +1,76 @@
+#
+# Conditional build:
+# _without_ssl - do not use SSL
+#
 Summary:       Commandline ftp client
 Summary(pl):   Zaawansowany klient ftp
 Name:          lftp
-Version:       2.1.1
+Version:       2.4.0
 Release:       1
-Group:         Networking/Utilities
-Group(pl):     Sieciowe/Narzêdzia
-Copyright:     GPL
-Source:                ftp://ftp.yars.free.net:/pub/software/unix/net/ftp/client/lftp/%{name}-%{version}.tar.gz
-Patch:         lftp-passive.patch
+License:       GPL
+Group:         Applications/Networking
+Group(de):     Applikationen/Netzwerkwesen
+Group(pl):     Aplikacje/Sieciowe
+Source0:       ftp://ftp.yars.free.net/pub/software/unix/net/ftp/client/lftp/%{name}-%{version}.tar.bz2
+Patch0:                %{name}-OMIT.patch
+Patch1:                %{name}-readline.patch
 Icon:          ftp.gif
-BuildRequires: ncurses-devel
-BuildRequires: readline-devel
+URL:           http://ftp.yars.free.net/projects/lftp/
+BuildRequires: ncurses-devel >= 5.2
+BuildRequires: readline-devel >= 4.2
 BuildRequires: gettext-devel
-Buildroot:     /tmp/%{name}-%{version}-root
-
-%define                _sysconfdir     /etc
+BuildRequires: gcc-c++
+BuildRequires: libstdc++-devel
+%{!??_without_ssl:BuildRequires:       openssl-devel >= 0.9.6a}
+BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-LFTP is a shell-like command line ftp client. The main two advantages over
-other ftp clients are reliability and ability to perform tasks in
-background. It will reconnect and reget the file being transferred if the
-connection broke. You can start a transfer in background and continue
-browsing on the ftp site. It does this all in one process. When you have
-started background jobs and feel you are done, you can just exit lftp and it
-automatically moves to nohup mode and completes the transfers. It has also
-such nice features as reput and mirror.
+LFTP is a shell-like command line ftp client. The main two advantages
+over other ftp clients are reliability and ability to perform tasks in
+background. It will reconnect and reget the file being transferred if
+the connection broke. You can start a transfer in background and
+continue browsing on the ftp site. It does this all in one process.
+When you have started background jobs and feel you are done, you can
+just exit lftp and it automatically moves to nohup mode and completes
+the transfers. It has also such nice features as reput and mirror.
 
 %description -l pl
-Lftp jest zaawansowanym klientem ftp. Potrafi automatycznie po³±czyæ siê z 
-serwerem ftp po zerwanym po³±czeniu i dokoñczyæ ¶ci±ganie archiwów. Lftp mo¿e 
-pracowaæ w tle i nie zrywa przy tym po³±czenia po tym jak siê wylogujesz. 
-Program ten honoruje komendy shellowe podczas sesji, np. `ls -al | less` itp. 
-Doskonale siê spisuje jako aplikacja do mirrorowania serwerów FTP.
+Lftp jest zaawansowanym klientem ftp. Potrafi automatycznie po³±czyæ
+siê z serwerem ftp po zerwanym po³±czeniu i dokoñczyæ ¶ci±ganie
+archiwów. Lftp mo¿e pracowaæ w tle i nie zrywa przy tym po³±czenia po
+tym jak siê wylogujesz. Program ten honoruje komendy pow³oki podczas
+sesji, np. `ls -al | less` itp. Doskonale siê spisuje jako aplikacja
+do mirrorowania serwerów FTP.
 
 %prep
 %setup -q
-%patch -p1
+%patch0 -p1
+%patch1 -p1
 
 %build
+rm missing
+libtoolize --copy --force
 gettextize --copy --force
-LDFLAGS="-s"; export LDFLAGS
-CXXFLAGS="$RPM_OPT_FLAGS"; export CXXFLAGS
+aclocal -I m4
+autoconf
+automake -a -c
+CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions -fno-implicit-templates"
 %configure \
-       --with-modules
-make
+       --with-modules \
+       --with%{?_without_ssl:out}-ssl
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT%{_sysconfdir}
 
-make install DESTDIR=$RPM_BUILD_ROOT
+%{__make} install DESTDIR=$RPM_BUILD_ROOT
 
 install lftp.conf $RPM_BUILD_ROOT%{_sysconfdir}
+install src/.libs/proto-ftp.so[A-Z] $RPM_BUILD_ROOT%{_libdir}/lftp/%{version}/proto-ftp.so
+install src/.libs/proto-http.so[A-Z] $RPM_BUILD_ROOT%{_libdir}/lftp/%{version}/proto-http.so
 
-chmod +x $RPM_BUILD_ROOT%{_libdir}/lftp/*
-
-gzip -9fn $RPM_BUILD_ROOT%{_mandir}/man1/* \
-       README NEWS 
+gzip -9nf README NEWS FAQ FEATURES BUGS ChangeLog TODO
 
 %find_lang %{name}
 
@@ -65,12 +79,11 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc {README,NEWS}.gz
-
-%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/lftp.conf
 %attr(755,root,root) %{_bindir}/*
-%{_mandir}/man1/*
+%attr(755,root,root) %{_libdir}/lftp/%{version}/*.so
 %attr(755,root,root) %{_datadir}/lftp
-
 %dir %{_libdir}/lftp
-%attr(755,root,root) %{_libdir}/lftp/*.so
+%dir %{_libdir}/lftp/%{version}
+%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/lftp.conf
+%{_mandir}/man1/*
+%doc *.gz
This page took 0.078375 seconds and 4 git commands to generate.