]> git.pld-linux.org Git - packages/lftp.git/blobdiff - lftp.spec
- added pl.po-update patch
[packages/lftp.git] / lftp.spec
index 7ce7efbdbb875c9ad3430940623cb65a983e4df6..0c94473b580323f2df47da0e4dc5fc4b07747425 100644 (file)
--- a/lftp.spec
+++ b/lftp.spec
@@ -1,35 +1,47 @@
+# TODO
+# - package itself defaults to GNUTLS (prefferring over openssl) should we too?
 #
 # Conditional build:
-%bcond_without ssl     # do not use SSL
-#
-Summary:       Sophisticated command line ftp/http client
-Summary(ko):   ¸í·ÉÁÙ¿¡¼­ µ¹¾Æ°¡´Â ftp/http Å¬¶óÀ̾ðÆ®
-Summary(pl):   Zaawansowany klient ftp/http
-Summary(pt_BR):        Sofisticado programa de transferência de arquivos (cliente ftp/http)
+%bcond_without ssl             # do not use SSL
+%bcond_with            gnutls  # use gnutls, otherwise openssl is used when ssl is on
+
+%if %{with ssl}
+%define with_openssl 1
+%endif
+
+%if %{with gnutls} && %{with ssl}
+%undefine with_openssl
+%endif
+
+Summary:       Sophisticated command line FTP/HTTP client
+Summary(ko):   ¸í·ÉÁÙ¿¡¼­ µ¹¾Æ°¡´Â FTP/HTTP Å¬¶óÀ̾ðÆ®
+Summary(pl):   Zaawansowany klient FTP/HTTP
+Summary(pt_BR):        Sofisticado programa de transferência de arquivos (cliente FTP/HTTP)
 Summary(zh_CN):        lftp ¿Í»§¶Ë³ÌÐò
 Name:          lftp
-Version:       2.6.11
+Version:       3.4.0
 Release:       1
 License:       GPL
 Group:         Applications/Networking
-Source0:       ftp://ftp.yars.free.net/pub/software/unix/net/ftp/client/lftp/%{name}-%{version}.tar.bz2
-# Source0-md5: 58e67606046174175e8cdee4c74fdaf7
+Source0:       ftp://ftp.yars.free.net/pub/source/lftp/%{name}-%{version}.tar.bz2
+# Source0-md5: 5d39a8b250691a693470b1773b5c6bd4
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
 # Source1-md5: cdad8fb5342eebd9916eccefc98a855b
 Source2:       %{name}.desktop
-Patch0:                %{name}-amfix.patch
-Patch1:                %{name}-no_pkgverlibdir.patch
-Patch2:                %{name}-home_etc.patch
+Patch0:                %{name}-home_etc.patch
+Patch1:                %{name}-pl.po-update.patch
 Icon:          ftp.gif
 URL:           http://lftp.yar.ru/
 BuildRequires: autoconf
 BuildRequires: automake
-BuildRequires: gettext-devel
+BuildRequires: gettext-devel >= 0.14.2
 BuildRequires: libstdc++-devel
 BuildRequires: libtool >= 1:1.4.2-9
 BuildRequires: ncurses-devel >= 5.2
-%{?with_ssl:BuildRequires:     openssl-devel >= 0.9.7c}
+%{?with_openssl:BuildRequires: openssl-devel >= 0.9.7d}
+%{?with_gnutls:BuildRequires:  gnutls-devel >= 1.2.5}
 BuildRequires: readline-devel >= 4.2
+BuildRequires: sed >= 4.0
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _gcc_ver        %(%{__cc} -dumpversion | cut -b 1)
@@ -38,19 +50,19 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %endif
 
 %description
-LFTP is a shell-like command line ftp/http client. The main two
-advantages over other ftp clients are reliability and ability to
+LFTP is a shell-like command line FTP/HTTP client. The main two
+advantages over other FTP clients are reliability and ability to
 perform tasks in background. It will reconnect and reget the file
 being transferred if the connection broke. You can start a transfer in
-background and continue browsing on the ftp site. It does this all in
+background and continue browsing on the FTP site. It does this all in
 one process. When you have started background jobs and feel you are
 done, you can just exit lftp and it automatically moves to nohup mode
 and completes the transfers. It has also such nice features as reput
 and mirror.
 
 %description -l pl
-Lftp jest zaawansowanym klientem ftp/http. Potrafi automatycznie
-po³±czyæ siê z serwerem ftp po zerwanym po³±czeniu i dokoñczyæ
+Lftp jest zaawansowanym klientem FTP/HTTP. Potrafi automatycznie
+po³±czyæ siê z serwerem FTP po zerwanym po³±czeniu i dokoñczyæ
 ¶ci±ganie archiwów. Lftp mo¿e pracowaæ w tle i nie zrywa przy tym
 po³±czenia po tym jak siê wylogujesz. Program ten honoruje komendy
 pow³oki podczas sesji, np. `ls -al | less` itp. Doskonale siê spisuje
@@ -58,16 +70,22 @@ jako aplikacja do mirrorowania serwer
 
 %description -l pt_BR
 O lftp é um programa de transferência de arquivos por linha de
-comando. Ele suporta os protocolos ftp/http. Suporta: proxy ftp, proxy
-http, ftp sobre http, opie/skey, transferências fxp, repetição de
+comando. Ele suporta os protocolos FTP/HTTP. Suporta: proxy FTP, proxy
+HTTP, FTP sobre HTTP, opie/skey, transferências fxp, repetição de
 tentativa automática em erros não-fatais e timeouts, ipv6, socks. Veja
 o arquivo FEATURES para uma lista mais detalhada.
 
 %prep
 %setup -q
-%patch0 -p1
+#%patch0 -p1
 %patch1 -p1
-%patch2 -p1
+rm -f po/stamp-po
+
+sed -i -e 's#pkgverlibdir.*=.*#pkgverlibdir = $(pkglibdir)#g' src/Makefile*
+# for gettext >= 0.14.2
+sed -i -e 's/jm_AC/gl_AC/' m4/human.m4
+
+%{!?with_gnutls:echo 'AC_DEFUN([AM_PATH_LIBGNUTLS],[/bin/true])' > m4/gnutls.m4}
 
 %build
 %{__libtoolize}
@@ -78,7 +96,10 @@ o arquivo FEATURES para uma lista mais detalhada.
 CXXFLAGS="%{rpmcflags} -fno-rtti -fno-exceptions -fno-implicit-templates"
 %configure \
        --with-modules \
-       --with%{!?with_ssl:out}-ssl
+       --with%{!?with_ssl:out}-ssl \
+       --with%{!?with_openssl:out}-openssl \
+       --with%{!?with_gnutls:out}-gnutls
+
 %{__make}
 
 %install
@@ -99,19 +120,17 @@ bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
+
 %files -f %{name}.lang
 %defattr(644,root,root,755)
 %doc README NEWS FAQ FEATURES BUGS ChangeLog TODO
-%config(noreplace) %verify(not size mtime md5) %{_sysconfdir}/lftp.conf
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/lftp.conf
 %attr(755,root,root) %{_bindir}/*
 %dir %{_libdir}/lftp
-%attr(755,root,root) %{_libdir}/lftp/cmd-mirror.so
-%attr(755,root,root) %{_libdir}/lftp/cmd-sleep.so
-%attr(755,root,root) %{_libdir}/lftp/libnetwork.so
-%attr(755,root,root) %{_libdir}/lftp/proto-file.so
-%attr(755,root,root) %{_libdir}/lftp/proto-fish.so
-%attr(755,root,root) %{_libdir}/lftp/proto-ftp.so
-%attr(755,root,root) %{_libdir}/lftp/proto-http.so
+%attr(755,root,root) %{_libdir}/liblftp*.so.*.*.*
+%attr(755,root,root) %{_libdir}/lftp/*.so
 %attr(755,root,root) %{_datadir}/lftp
 %{_mandir}/man1/*
 %lang(pl) %{_mandir}/pl/man1/*
This page took 0.04881 seconds and 4 git commands to generate.