]> git.pld-linux.org Git - packages/ldb.git/blobdiff - ldb.spec
BR: docbook-style-xsl-nons for manpages
[packages/ldb.git] / ldb.spec
index 5d63e2ba76fe6535478398b4bf78bb2b6fafda7e..343b106f922c857216d1942c93a878c912359ec7 100644 (file)
--- a/ldb.spec
+++ b/ldb.spec
@@ -1,59 +1,52 @@
-# TODO
-# - expect python3 as default in 1.5.x line (see e.g. tevent.spec for handling differences)
 #
 # Conditional build:
 %bcond_without lmdb    # LMDB module (64-bit only)
-%bcond_without python3 # CPython 3.x interface
 #
 %ifnarch %{x8664} aarch64 alpha mips64 ppc64 s390x sparc64
 # lmdb support requires 64-bit size_t
 %undefine      with_lmdb
 %endif
-%define                talloc_version  2:2.1.14
-%define                tdb_version     2:1.3.16
-%define                tevent_version  0.9.37
+%define                talloc_version  2:2.3.3
+%define                tdb_version     2:1.4.4
+%define                tevent_version  0.11.0
 Summary:       LDAP-like embedded database
 Summary(pl.UTF-8):     Wbudowana baza danych podobna do LDAP
 Name:          ldb
-Version:       1.4.6
-Release:       2
+Version:       2.5.2
+Release:       1
 License:       LGPL v3+
 Group:         Libraries
-Source0:       https://www.samba.org/ftp/ldb/%{name}-%{version}.tar.gz
-# Source0-md5: 3951773a4fed1b3ae27af24972c2ac50
+Source0:       https://download.samba.org/pub/ldb/%{name}-%{version}.tar.gz
+# Source0-md5: c7fc9d1d43b801d3932484b1de7442fe
 URL:           https://ldb.samba.org/
-BuildRequires: cmocka-devel >= 1.1.1
+BuildRequires: cmocka-devel >= 1.1.3
 BuildRequires: docbook-style-xsl
+BuildRequires: docbook-style-xsl-nons
+BuildRequires: libbsd-devel
 BuildRequires: libxslt-progs
 %{?with_lmdb:BuildRequires:    lmdb-devel >= 0.9.16}
 BuildRequires: openldap-devel
 BuildRequires: popt-devel >= 1.6
-BuildRequires: python-devel >= 1:2.4.2
-BuildRequires: python-talloc-devel >= %{talloc_version}
-BuildRequires: python-tdb >= %{tdb_version}
-BuildRequires: python-tevent >= %{tevent_version}
-%if %{with python3}
 BuildRequires: python3-devel >= 1:3.2
 BuildRequires: python3-talloc-devel >= %{talloc_version}
 BuildRequires: python3-tdb >= %{tdb_version}
 BuildRequires: python3-tevent >= %{tevent_version}
-%endif
-BuildRequires: rpmbuild(macros) >= 1.507
+BuildRequires: rpmbuild(macros) >= 1.704
 BuildRequires: talloc-devel >= %{talloc_version}
 BuildRequires: tdb-devel >= %{tdb_version}
 BuildRequires: tevent-devel >= %{tevent_version}
-%{?with_lmdb:Requires: lmdb >= 0.9.16}
+%{?with_lmdb:Requires: lmdb-libs >= 0.9.16}
 Requires:      talloc >= %{talloc_version}
 Requires:      tdb >= %{tdb_version}
 Requires:      tevent >= %{tevent_version}
 Requires:      popt >= 1.6
 Provides:      libldb = %{version}-%{release}
 Obsoletes:     libldb < 1.1.0-3
+# ldb 1.6+ dropped python2 support
+Obsoletes:     python-ldb < 1.6
+Obsoletes:     python-ldb-devel < 1.6
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-# %{_includedir}/pyldb.h shared between python*-ldb-devel
-%define                _duplicate_files_terminate_build        0
-
 %description
 An extensible library that implements an LDAP like API to access
 remote LDAP servers, or use local tdb databases.
@@ -94,40 +87,13 @@ library.
 Pliki nagłówkowe potrzebne do tworzenia programów wykorzystujących
 bibliotekę LDB.
 
-%package -n python-ldb
-Summary:       Python 2 bindings for the LDB library
-Summary(pl.UTF-8):     Wiązania Pythona 2 do biblioteki LDB
-Group:         Libraries/Python
-Requires:      %{name} = %{version}-%{release}
-Requires:      python-libs >= 1:2.4.2
-Requires:      python-tdb >= %{tdb_version}
-Obsoletes:     pyldb
-
-%description -n python-ldb
-Python 2 bindings for the LDB library.
-
-%description -n python-ldb -l pl.UTF-8
-Wiązania Pythona 2 do biblioteki LDB.
-
-%package -n python-ldb-devel
-Summary:       Development files for the Python 2 bindings for the LDB library
-Summary(pl.UTF-8):     Pliki programistyczne wiązań Pythona 2 do biblioteki LDB
-Group:         Development/Libraries
-Requires:      python-ldb = %{version}-%{release}
-
-%description -n python-ldb-devel
-Development files for the Python 2 bindings for the LDB library.
-
-%description -n python-ldb-devel -l pl.UTF-8
-Pliki programistyczne wiązań Pythona 2 do biblioteki LDB.
-
 %package -n python3-ldb
 Summary:       Python 3 bindings for the LDB library
 Summary(pl.UTF-8):     Wiązania Pythona 3 do biblioteki LDB
 Group:         Libraries/Python
 Requires:      %{name} = %{version}-%{release}
 Requires:      python3-tdb >= %{tdb_version}
-Obsoletes:     pyldb
+Obsoletes:     pyldb < 1.1.0-1
 
 %description -n python3-ldb
 Python 3 bindings for the LDB library.
@@ -160,8 +126,7 @@ CFLAGS="%{rpmcflags}" \
        --with-privatelibdir=%{_libdir}/ldb \
        --bundled-libraries=NONE \
        --disable-rpath \
-       --disable-rpath-install \
-       %{?with_python3:--extra-python=%{__python3}}
+       --disable-rpath-install
 
 %{__make} \
        V=1
@@ -171,14 +136,8 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-%py_comp $RPM_BUILD_ROOT%{py_sitedir}
-%py_ocomp $RPM_BUILD_ROOT%{py_sitedir}
-%py_postclean
-
-%if %{with python3}
 %py3_comp $RPM_BUILD_ROOT%{py3_sitedir}
 %py3_ocomp $RPM_BUILD_ROOT%{py3_sitedir}
-%endif
 
 # Shared libraries need to be marked executable for
 # rpmbuild to strip them and include them in debuginfo
@@ -190,18 +149,17 @@ rm -rf $RPM_BUILD_ROOT
 %post  -p /sbin/ldconfig
 %postun        -p /sbin/ldconfig
 
-%post  -n python-ldb -p /sbin/ldconfig
-%postun        -n python-ldb -p /sbin/ldconfig
-
 %post  -n python3-ldb -p /sbin/ldconfig
 %postun        -n python3-ldb -p /sbin/ldconfig
 
 %files
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libldb.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libldb.so.1
+%attr(755,root,root) %ghost %{_libdir}/libldb.so.2
 %dir %{_libdir}/ldb
 %attr(755,root,root) %{_libdir}/ldb/libldb-key-value.so
+%attr(755,root,root) %{_libdir}/ldb/libldb-tdb-err-map.so
+%attr(755,root,root) %{_libdir}/ldb/libldb-tdb-int.so
 %{?with_lmdb:%attr(755,root,root) %{_libdir}/ldb/libldb-mdb-int.so}
 %dir %{_libdir}/ldb/modules
 %dir %{_libdir}/ldb/modules/ldb
@@ -234,24 +192,10 @@ rm -rf $RPM_BUILD_ROOT
 %{_pkgconfigdir}/ldb.pc
 %{_mandir}/man3/ldb.3*
 
-%files -n python-ldb
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libpyldb-util.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libpyldb-util.so.1
-%attr(755,root,root) %{py_sitedir}/ldb.so
-%{py_sitedir}/_ldb_text.py[co]
-
-%files -n python-ldb-devel
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/libpyldb-util.so
-%{_includedir}/pyldb.h
-%{_pkgconfigdir}/pyldb-util.pc
-
-%if %{with python3}
 %files -n python3-ldb
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_libdir}/libpyldb-util.cpython-3*.so.*.*.*
-%attr(755,root,root) %ghost %{_libdir}/libpyldb-util.cpython-3*.so.1
+%attr(755,root,root) %ghost %{_libdir}/libpyldb-util.cpython-3*.so.2
 %attr(755,root,root) %{py3_sitedir}/ldb.cpython-*.so
 %{py3_sitedir}/_ldb_text.py
 %{py3_sitedir}/__pycache__/_ldb_text.cpython-*.py[co]
@@ -261,4 +205,3 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/libpyldb-util.cpython-3*.so
 %{_includedir}/pyldb.h
 %{_pkgconfigdir}/pyldb-util.cpython-3*.pc
-%endif
This page took 0.136082 seconds and 4 git commands to generate.