]> git.pld-linux.org Git - packages/kp5-systemsettings.git/blobdiff - kp5-systemsettings.spec
- updated to 5.25.2
[packages/kp5-systemsettings.git] / kp5-systemsettings.spec
index 031537050bc7685e91dc4340ddbdc691671185a8..ca2eba4e91a1635f399afd9ed55dc58b5a7e538c 100644 (file)
@@ -1,15 +1,18 @@
-%define                kdeplasmaver    5.21.2
+#
+# Conditional build:
+%bcond_with    tests           # build with tests
+%define                kdeplasmaver    5.25.2
 %define                qtver           5.9.0
 %define                kpname          systemsettings
 Summary:       KDE system settings
 Name:          kp5-%{kpname}
-Version:       5.21.2
+Version:       5.25.2
 Release:       1
 License:       GPL v2+/LGPL v2.1+
 Group:         X11/Libraries
-Source0:       http://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
-# Source0-md5: 7ffc96d3050ccac979fbbaa60653969c
-URL:           http://www.kde.org/
+Source0:       https://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
+# Source0-md5: 433953923faca876382db496b0b50d6e
+URL:           https://www.kde.org/
 BuildRequires: Qt5Core-devel >= %{qtver}
 BuildRequires: cmake >= 2.8.12
 BuildRequires: kf5-extra-cmake-modules >= 1.4.0
@@ -30,6 +33,7 @@ BuildRequires:        kf5-kparts-devel
 BuildRequires: kf5-kservice-devel
 BuildRequires: kf5-kwindowsystem-devel
 BuildRequires: kf5-kxmlgui-devel
+BuildRequires: kp5-plasma-workspace-devel >= %{kdeplasmaver}
 BuildRequires: ninja
 BuildRequires: qt5-build >= %{qtver}
 BuildRequires: rpmbuild(macros) >= 1.164
@@ -60,11 +64,16 @@ install -d build
 rm -rf po/id
 cd build
 %cmake -G Ninja \
+       %{!?with_tests:-DBUILD_TESTING=OFF} \
        -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
        -DHTML_INSTALL_DIR=%{_kdedocdir} \
        ..
 %ninja_build
 
+%if %{with tests}
+ctest
+%endif
+
 %install
 rm -rf $RPM_BUILD_ROOT
 %ninja_install -C build
@@ -82,7 +91,6 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/systemsettings5
 %{_desktopdir}/kdesystemsettings.desktop
 %{_desktopdir}/systemsettings.desktop
-%{_datadir}/kservices5/settings-*.desktop
 %{_datadir}/kservicetypes5/systemsettings*.desktop
 %{_datadir}/kxmlgui5/systemsettings
 %{_datadir}/systemsettings
@@ -93,3 +101,7 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/qt5/plugins/systemsettingsview/icon_mode.so
 %attr(755,root,root) %{_libdir}/qt5/plugins/systemsettingsview/systemsettings_sidebar_mode.so
 %{_datadir}/kglobalaccel/systemsettings.desktop
+%attr(755,root,root) %{_libdir}/libsystemsettingsview.so.3
+%{_libdir}/qt5/plugins/kf5/krunner/krunner_systemsettings.so
+%attr(755,root,root) %{_bindir}/systemsettings
+%{_datadir}/kservicetypes5/infocenterexternalapp.desktop
This page took 0.188634 seconds and 4 git commands to generate.