]> git.pld-linux.org Git - packages/kp5-kde-cli-tools.git/blobdiff - kp5-kde-cli-tools.spec
- updated to 5.25.1
[packages/kp5-kde-cli-tools.git] / kp5-kde-cli-tools.spec
index 9d9a554883443e15f10cb1b5c99bbe58fe6fc690..a4d8e48e0fae39ac4e7fac048a1ae5b623390b81 100644 (file)
@@ -1,15 +1,18 @@
-%define                kdeplasmaver    5.21.3
+#
+# Conditional build:
+%bcond_with    tests           # build with tests
+%define                kdeplasmaver    5.25.1
 %define                qtver           5.9.0
 %define                kpname          kde-cli-tools
 Summary:       Tools based on KDE Frameworks 5 to better interact with the system
 Name:          kp5-%{kpname}
-Version:       5.21.3
+Version:       5.25.1
 Release:       1
 License:       GPL v2+/LGPL v2.1+
 Group:         X11/Libraries
-Source0:       http://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
-# Source0-md5: bc6079261f86ef9258e621938a70f6bb
-URL:           http://www.kde.org/
+Source0:       https://download.kde.org/stable/plasma/%{kdeplasmaver}/%{kpname}-%{version}.tar.xz
+# Source0-md5: 1e14f199a916eb9efc26af2c30dd7b93
+URL:           https://www.kde.org/
 BuildRequires: Qt5Core-devel >= %{qtver}
 BuildRequires: cmake >= 2.8.12
 BuildRequires: kf5-extra-cmake-modules >= 1.4.0
@@ -40,11 +43,16 @@ Tools based on KDE Frameworks 5 to better interact with the system.
 install -d build
 cd build
 %cmake -G Ninja \
+       %{!?with_tests:-DBUILD_TESTING=OFF} \
        -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
        -DHTML_INSTALL_DIR=%{_kdedocdir} \
        ..
 %ninja_build
 
+%if %{with tests}
+ctest
+%endif
+
 %install
 rm -rf $RPM_BUILD_ROOT
 %ninja_install -C build
@@ -55,9 +63,6 @@ rm -rf $RPM_BUILD_ROOT%{_kdedocdir}/{sr,sr@latin}
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post  -p /sbin/ldconfig
-%postun        -p /sbin/ldconfig
-
 %files -f kde-cli-tools.lang
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/kbroadcastnotification
@@ -71,10 +76,18 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/kstart5
 %attr(755,root,root) %{_bindir}/ksvgtopng5
 %attr(755,root,root) %{_bindir}/ktraderclient5
+%attr(755,root,root) %{_bindir}/kde-open
+%attr(755,root,root) %{_bindir}/kdecp
+%attr(755,root,root) %{_bindir}/kdemv
+%attr(755,root,root) %{_bindir}/keditfiletype
+%attr(755,root,root) %{_bindir}/kioclient
+%attr(755,root,root) %{_bindir}/kmimetypefinder
+%attr(755,root,root) %{_bindir}/kstart
+%attr(755,root,root) %{_bindir}/ksvgtopng
 %attr(755,root,root) %{_libexecdir}/kf5/kdeeject
 %attr(755,root,root) %{_libexecdir}/kf5/kdesu
-%attr(755,root,root) %{_libdir}/qt5/plugins/kcm_filetypes.so
-%{_datadir}/kservices5/filetypes.desktop
+%attr(755,root,root) %{_bindir}/plasma-open-settings
+%{_desktopdir}/org.kde.plasma.settings.open.desktop
 %{_mandir}/man1/kdesu.1*
 %lang(ca) %{_mandir}/ca/man1/kdesu.1*
 %lang(de) %{_mandir}/de/man1/kdesu.1*
@@ -92,3 +105,5 @@ rm -rf $RPM_BUILD_ROOT
 %{_desktopdir}/org.kde.keditfiletype.desktop
 %attr(755,root,root) %{_bindir}/kde-inhibit
 %lang(fr) %{_mandir}/fr/man1/kdesu.1*
+%{_libdir}/qt5/plugins/plasma/kcms/systemsettings_qwidgets/kcm_filetypes.so
+%{_desktopdir}/kcm_filetypes.desktop
This page took 0.030068 seconds and 4 git commands to generate.