]> git.pld-linux.org Git - packages/kf5-sonnet.git/blobdiff - kf5-sonnet.spec
- Up to 5.67.0.
[packages/kf5-sonnet.git] / kf5-sonnet.spec
index e150d5ee117b09276e099414c9c5fb9179e66c2d..26271141008087d4eca84d7351657adc0e685ea0 100644 (file)
@@ -1,35 +1,37 @@
 # TODO:
-# - dir /usr/include/KF5 not packaged
-# /usr/lib/qt5/qml/org/kde not packaged
-# /usr/lib/qt5/plugins/kf5
-# /usr/share/kf5
-
-%define         _state          stable
-%define                orgname         sonnet
+# - fix build with aspell
+%define                kdeframever     5.67
+%define                qtver           5.10.0
+%define                kfname          sonnet
 
 Summary:       Multi-language spell checker
-Name:          kf5-%{orgname}
-Version:       5.0.0
-Release:       0.1
+Summary(pl.UTF-8):     Wielojęzyczne narzędzie do sprawdzania pisowni
+Name:          kf5-%{kfname}
+Version:       5.67.0
+Release:       1
 License:       LGPL v2.1+
 Group:         X11/Libraries
-Source0:       ftp://ftp.kde.org/pub/kde/%{_state}/frameworks/%{version}/%{orgname}-%{version}.tar.xz
-# Source0-md5: b5608009ca1d34e6fdfd4f89c9752eef
+Source0:       http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
+# Source0-md5: 37f09137396721abad617571464b9d9a
 URL:           http://www.kde.org/
-BuildRequires: Qt5Core-devel
-BuildRequires: Qt5Gui-devel >= 5.3.1
-BuildRequires: Qt5Test-devel
-BuildRequires: Qt5Widgets-devel
+BuildRequires: Qt5Core-devel >= %{qtver}
+BuildRequires: Qt5Gui-devel >= %{qtver}
+BuildRequires: Qt5Test-devel >= %{qtver}
+BuildRequires: Qt5Widgets-devel >= %{qtver}
+BuildRequires: aspell
 BuildRequires: aspell-devel
-BuildRequires: cmake >= 2.8.12
+BuildRequires: cmake >= 3.5
 BuildRequires: hspell-devel
 BuildRequires: hunspell-devel
-BuildRequires: kf5-extra-cmake-modules >= 1.0.0
-BuildRequires: qt5-linguist
+BuildRequires: kf5-extra-cmake-modules >= 5.56
+BuildRequires: libvoikko-devel
+BuildRequires: ninja
+BuildRequires: qt5-linguist >= %{qtver}
 BuildRequires: rpmbuild(macros) >= 1.164
 BuildRequires: tar >= 1:1.22
 BuildRequires: xz
 BuildRequires: zlib-devel
+Requires:      kf5-dirs
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                qt5dir          %{_libdir}/qt5
@@ -37,7 +39,7 @@ BuildRoot:    %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %description
 Sonnet is a plugin-based spell checking library for Qt-based
 applications. It supports several different plugins, including HSpell,
-Enchant, ASpell and HUNSPELL.
+ASpell and HUNSPELL.
 
 It also supports automated language detection, based on a combination
 of different algorithms.
@@ -45,66 +47,68 @@ of different algorithms.
 The simplest way to use Sonnet in your application is to use the
 SpellCheckDecorator class on your QTextEdit.
 
+%description -l pl.UTF-8
+Sonnet to oparta na wtyczkach biblioteka do sprawdzania pisowni dla
+aplikacji opartych na Qt. Obsługuje kilka różnych wtyzek, w tym
+HSpell, ASpell i HUNSPELL.
+
+Pozwala automatycznie wykrywać język w oparciu o połączenie różnych
+algorytmów.
+
+Najprostszy sposób użycia Sonneta w aplikacji to użycie klasy
+SpellCheckDecorator w obiekcie QTextEdit.
+
 %package devel
-Summary:       Header files for %{orgname} development
-Summary(pl.UTF-8):     Pliki nagłówkowe dla programistów używających %{orgname}
+Summary:       Header files for %{kfname} development
+Summary(pl.UTF-8):     Pliki nagłówkowe dla programistów używających %{kfname}
 Group:         X11/Development/Libraries
 Requires:      %{name} = %{version}-%{release}
 
 %description devel
-Header files for %{orgname} development.
+Header files for %{kfname} development.
 
 %description devel -l pl.UTF-8
-Pliki nagłówkowe dla programistów używających %{orgname}.
+Pliki nagłówkowe dla programistów używających %{kfname}.
 
 %prep
-%setup -q -n %{orgname}-%{version}
+%setup -q -n %{kfname}-%{version}
 
 %build
 install -d build
 cd build
-%cmake \
-       -DBIN_INSTALL_DIR=%{_bindir} \
-       -DKCFG_INSTALL_DIR=%{_datadir}/config.kcfg \
-       -DPLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
-       -DQT_PLUGIN_INSTALL_DIR=%{qt5dir}/plugins \
-       -DQML_INSTALL_DIR=%{qt5dir}/qml \
-       -DIMPORTS_INSTALL_DIR=%{qt5dirs}/imports \
-       -DSYSCONF_INSTALL_DIR=%{_sysconfdir} \
-       -DLIBEXEC_INSTALL_DIR=%{_libexecdir} \
-       -DKF5_LIBEXEC_INSTALL_DIR=%{_libexecdir} \
-       -DKF5_INCLUDE_INSTALL_DIR=%{_includedir} \
-       -DECM_MKSPECS_INSTALL_DIR=%{qt5dir}/mkspecs/modules \
+%cmake -G Ninja \
+       -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
        ../
-%{__make}
+%ninja_build
 
 %install
 rm -rf $RPM_BUILD_ROOT
+%ninja_install -C build
 
-%{__make} -C build/ install \
-        DESTDIR=$RPM_BUILD_ROOT
-
-%find_lang %{orgname}5_qt --with-qm
+%find_lang %{kfname}5_qt --with-qm --all-name --with-kde
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%post -p /sbin/ldconfig
-%postun -p /sbin/ldconfig
+%post  -p /sbin/ldconfig
+%postun        -p /sbin/ldconfig
 
-%files -f %{orgname}5_qt.lang
+%files -f %{kfname}5_qt.lang
 %defattr(644,root,root,755)
 %doc README.md
+%attr(755,root,root) %{_bindir}/gentrigrams
+%attr(755,root,root) %{_bindir}/parsetrigrams
 %attr(755,root,root) %ghost %{_libdir}/libKF5SonnetCore.so.5
-%attr(755,root,root) %{_libdir}/libKF5SonnetCore.so.5.0.0
+%attr(755,root,root) %{_libdir}/libKF5SonnetCore.so.*.*
 %attr(755,root,root) %ghost %{_libdir}/libKF5SonnetUi.so.5
-%attr(755,root,root) %{_libdir}/libKF5SonnetUi.so.5.0.0
+%attr(755,root,root) %{_libdir}/libKF5SonnetUi.so.*.*
 %dir %{qt5dir}/plugins/kf5/sonnet
-%attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/aspell.so
-%attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/hspell.so
-%attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/hunspell.so
-%dir %{_datadir}/kf5/sonnet
-%{_datadir}/kf5/sonnet/trigrams.map
+%attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/sonnet_aspell.so
+%attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/sonnet_hspell.so
+%attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/sonnet_hunspell.so
+%attr(755,root,root) %{qt5dir}/plugins/kf5/sonnet/sonnet_voikko.so
+%attr(755,root,root) %{qt5dir}/plugins/designer/sonnetui5widgets.so
+%{_datadir}/qlogging-categories5/sonnet.categories
 
 %files devel
 %defattr(644,root,root,755)
This page took 0.033677 seconds and 4 git commands to generate.