]> git.pld-linux.org Git - packages/kf5-qqc2-desktop-style.git/blobdiff - kf5-qqc2-desktop-style.spec
- updated to 5.98.0
[packages/kf5-qqc2-desktop-style.git] / kf5-qqc2-desktop-style.spec
index b564a7c715e090110f6b297f169a4f9ad19749fc..aed7b9ddd99a0c9ec304448a7edcc71266108cfe 100644 (file)
@@ -1,22 +1,28 @@
-%define                kdeframever     5.39
-%define                qtver           5.8.0
+#
+# Conditional build:
+%bcond_with    tests           # build with tests
+%define                kdeframever     5.98
+%define                qtver           5.15.2
 %define                kfname          qqc2-desktop-style
 
 Summary:       QQC2StyleBridge
 Name:          kf5-%{kfname}
-Version:       5.39.0
+Version:       5.98.0
 Release:       1
 License:       LGPL v2.1+
 Group:         X11/Libraries
-Source0:       http://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
-# Source0-md5: 0520bc56ae94b6d7b29c40c334efc806
+Source0:       https://download.kde.org/stable/frameworks/%{kdeframever}/%{kfname}-%{version}.tar.xz
+# Source0-md5: 74e03c261837061fc77d8125f412f640
 URL:           http://www.kde.org/
 BuildRequires: Qt5Core-devel >= %{qtver}
 BuildRequires: Qt5Quick-controls2-devel >= %{qtver}
 BuildRequires: Qt5Test-devel >= %{qtver}
 BuildRequires: Qt5Widgets-devel >= %{qtver}
 BuildRequires: cmake >= 2.8.12
-BuildRequires: kf5-extra-cmake-modules >= 1.4.0
+BuildRequires: kf5-extra-cmake-modules >= %{version}
+BuildRequires: kf5-kconfig-devel >= %{version}
+BuildRequires: kf5-kirigami2-devel >= %{version}
+BuildRequires: ninja
 BuildRequires: rpmbuild(macros) >= 1.164
 BuildRequires: tar >= 1:1.22
 BuildRequires: xz
@@ -51,22 +57,27 @@ Pliki nagłówkowe dla programistów używających %{kfname}.
 %build
 install -d build
 cd build
-%cmake \
+%cmake -G Ninja \
+       %{!?with_tests:-DBUILD_TESTING=OFF} \
        -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
        ../
-%{__make}
+%ninja_build
+
+%if %{with tests}
+ctest
+%endif
+
 
 %install
 rm -rf $RPM_BUILD_ROOT
-
-%{__make} -C build/ install \
-        DESTDIR=$RPM_BUILD_ROOT
+%ninja_install -C build
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
+%dir %{_libdir}/qt5/plugins/kf5/kirigami
 %{_libdir}/qt5/plugins/kf5/kirigami/org.kde.desktop.so
 %{_libdir}/qt5/qml/QtQuick/Controls.2/org.kde.desktop
 %{_libdir}/qt5/qml/org/kde/qqc2desktopstyle
@@ -74,3 +85,4 @@ rm -rf $RPM_BUILD_ROOT
 %files devel
 %defattr(644,root,root,755)
 %{_libdir}/cmake/KF5QQC2DeskopStyle
+%{_libdir}/cmake/KF5QQC2DesktopStyle
This page took 0.03072 seconds and 4 git commands to generate.