]> git.pld-linux.org Git - packages/kernel.git/blobdiff - kernel.spec
- rel 2
[packages/kernel.git] / kernel.spec
index b4d636cb1cb793e9cf9195e51c17284ad68511c2..6c680172b610f54567ce871646e07ba0268cd6fb 100644 (file)
@@ -68,9 +68,9 @@
 %define                have_pcmcia     0
 %endif
 
-%define                rel             1
-%define                basever         3.17
-%define                postver         .4
+%define                rel             2
+%define                basever         3.18
+%define                postver         .3
 
 # define this to '-%{basever}' for longterm branch
 %define                versuffix       %{nil}
@@ -113,10 +113,10 @@ Epoch:            3
 License:       GPL v2
 Group:         Base/Kernel
 Source0:       http://www.kernel.org/pub/linux/kernel/v3.x/linux-%{basever}.tar.xz
-# Source0-md5: fb30d0f29214d75cddd2faa94f73d5cf
+# Source0-md5: 9e854df51ca3fef8bfe566dbd7b89241
 %if "%{postver}" != ".0"
 Patch0:                http://www.kernel.org/pub/linux/kernel/v3.x/patch-%{version}.xz
-# Patch0-md5:  df86f9de60a651ce3312af09729f7b1e
+# Patch0-md5:  0d4f5406f6fbe34a53e1c5e1d2037e8b
 %endif
 Source1:       kernel.sysconfig
 
@@ -191,18 +191,6 @@ Patch85:   kernel-hostap.patch
 Patch100:      kernel-vserver-2.3.patch
 Patch101:      kernel-vserver-fixes.patch
 
-# git clone git://kernel.opensuse.org/kernel-source.git
-# patches.suse/ovl*
-Patch110:      ovl01-vfs-add-i_op-dentry_open.patch
-Patch111:      ovl02-vfs-export-do_splice_direct-to-modules.patch
-Patch112:      ovl03-vfs-export-inode_permission-to-modules.patch
-Patch113:      ovl04-vfs-introduce-clone_private_mount.patch
-Patch114:      ovl05-overlay-filesystem.patch
-Patch115:      ovl06-overlayfs-add-statfs-support.patch
-Patch116:      ovl07-overlayfs-implement-show_options.patch
-Patch117:      ovl08-overlay-overlay-filesystem-documentation.patch
-Patch118:      ovl09-fs-limit-filesystem-stacking-depth.patch
-
 # git://aufs.git.sourceforge.net/gitroot/aufs/aufs3-standalone.git, read README
 # Patch creation:
 # git clone git://aufs.git.sourceforge.net/gitroot/aufs/aufs3-standalone.git
@@ -262,16 +250,16 @@ BuildRequires:    gcc >= 5:3.2
 BuildRequires: xz >= 1:4.999.7
 AutoReqProv:   no
 BuildRequires: hostname
-BuildRequires: kmod
+BuildRequires: kmod >= 12-2
 BuildRequires: perl-base
 BuildRequires: rpm-build >= 4.5-24
-BuildRequires: rpmbuild(macros) >= 1.652
+BuildRequires: rpmbuild(macros) >= 1.707
 Requires(post):        coreutils
-Requires(post):        geninitrd >= 10000-3
+Requires(post):        geninitrd >= 10000.32
 Requires(post):        kmod >= 12-2
 Requires:      /sbin/depmod
 Requires:      coreutils
-Requires:      geninitrd >= 10000-3
+Requires:      geninitrd >= 10000.32
 Requires:      kmod >= 12-2
 %if %{with pae}
 %ifarch i686 athlon pentium3 pentium4
@@ -320,11 +308,13 @@ Conflicts:        udev < 1:081
 Conflicts:     util-linux < 2.10o
 Conflicts:     util-vserver < 0.30.216
 Conflicts:     xfsprogs < 2.6.0
-ExclusiveArch: i486 i586 i686 pentium3 pentium4 athlon %{x8664} alpha arm ia64 ppc ppc64 sparc sparc64
+ExclusiveArch: i486 i586 i686 pentium3 pentium4 athlon %{x8664} x32 alpha arm ia64 ppc ppc64 sparc sparc64
 ExclusiveOS:   Linux
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%ifarch %{ix86} %{x8664}
+%define                kmod_compress_cmd       %{__xz}
+
+%ifarch %{ix86} %{x8664} x32
 %define                target_arch_dir         x86
 %endif
 %ifarch ppc ppc64
@@ -333,7 +323,7 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %ifarch sparc sparc64
 %define                target_arch_dir         sparc
 %endif
-%ifnarch %{ix86} %{x8664} ppc ppc64 sparc sparc64
+%ifnarch %{ix86} %{x8664} x32 ppc ppc64 sparc sparc64
 %define                target_arch_dir         %{_target_base_arch}
 %endif
 
@@ -570,7 +560,7 @@ Summary(pl.UTF-8):  Pliki służące do budowania modułów jądra
 Group:         Development/Building
 Requires:      %{name}-headers = %{epoch}:%{version}-%{release}
 Requires:      make
-Conflicts:     rpmbuild(macros) < 1.652
+Conflicts:     rpmbuild(macros) < 1.704
 AutoReqProv:   no
 
 %description module-build
@@ -702,16 +692,6 @@ cd linux-%{basever}
 %patch101 -p1
 %endif
 
-%patch110 -p1
-%patch111 -p1
-%patch112 -p1
-%patch113 -p1
-%patch114 -p1
-%patch115 -p1
-%patch116 -p1
-%patch117 -p1
-%patch118 -p1
-
 # aufs3
 %patch145 -p1
 %if %{with vserver}
@@ -760,12 +740,12 @@ find '(' -name '*~' -o -name '*.orig' -o -name '.gitignore' ')' -print0 | xargs
 install -d %{objdir}
 cat > %{targetobj}.mk <<'EOF'
 # generated by %{name}.spec
-KERNELSRC              := %{srcdir}
+KERNELSRC      := %{srcdir}
 KERNELOUTPUT   := %{objdir}
 
 SRCARCH                := %{target_arch_dir}
 ARCH           := %{_target_base_arch}
-Q                      := %{!?with_verbose:@}
+Q              := %{!?with_verbose:@}
 MAKE_OPTS      := %{MakeOpts}
 DEFCONFIG      := %{defconfig}
 EOF
@@ -969,6 +949,7 @@ rm -rf $RPM_BUILD_ROOT
        -C %{objdir} \
        %{?with_verbose:V=1} \
        DEPMOD=%{DepMod} \
+       mod_compress_cmd=true \
        INSTALL_MOD_PATH=$RPM_BUILD_ROOT \
        INSTALL_FW_PATH=$RPM_BUILD_ROOT/lib/firmware/%{kernel_release} \
        KERNELRELEASE=%{kernel_release}
@@ -998,7 +979,7 @@ done
 install -d $RPM_BUILD_ROOT/boot
 cp -a %{objdir}/System.map $RPM_BUILD_ROOT/boot/System.map-%{kernel_release}
 cp -aL %{objdir}/.config $RPM_BUILD_ROOT/boot/config-%{kernel_release}
-%ifarch %{ix86} %{x8664}
+%ifarch %{ix86} %{x8664} x32
        cp -a %{objdir}/arch/%{target_arch_dir}/boot/bzImage $RPM_BUILD_ROOT/boot/vmlinuz-%{kernel_release}
        install -p %{objdir}/vmlinux $RPM_BUILD_ROOT/boot/vmlinux-%{kernel_release}
 %endif
@@ -1334,7 +1315,7 @@ fi
 %ghost /lib/modules/%{kernel_release}/build
 %ghost /lib/modules/%{kernel_release}/source
 
-%ifarch alpha %{ix86} %{x8664} ppc ppc64 sparc sparc64
+%ifarch alpha %{ix86} %{x8664} x32 ppc ppc64 sparc sparc64
 %files vmlinux
 %defattr(644,root,root,755)
 /boot/vmlinux-%{kernel_release}
This page took 0.031092 seconds and 4 git commands to generate.