]> git.pld-linux.org Git - packages/kernel.git/blobdiff - kernel.spec
- fix brokeness in raid0 code
[packages/kernel.git] / kernel.spec
index 8bdff060e785c821ddf32b90185edae61000811d..30d53e8441055b617dea6dccb78d0e11a7ec00ea 100644 (file)
@@ -25,6 +25,7 @@
 %bcond_with    fbcondecor      # build fbcondecor (disable FB_TILEBLITTING and affected fb modules)
 %bcond_without pae             # build PAE (HIGHMEM64G) support on 32bit i686 athlon pentium3 pentium4
 %bcond_with    nfsroot         # build with root on NFS support
+%bcond_with    uksm            # build with UKSM patch, http://kerneldedup.org/projects/uksm/
 
 %bcond_without imq             # imq support
 %bcond_without esfq            # esfq support
@@ -69,9 +70,9 @@
 %define                have_pcmcia     0
 %endif
 
-%define                rel             1
-%define                basever         3.18
-%define                postver         .6
+%define                rel             2
+%define                basever         4.0
+%define                postver         .4
 
 # define this to '-%{basever}' for longterm branch
 %define                versuffix       %{nil}
@@ -116,11 +117,11 @@ Release:  %{rel}
 Epoch:         3
 License:       GPL v2
 Group:         Base/Kernel
-Source0:       http://www.kernel.org/pub/linux/kernel/v3.x/linux-%{basever}.tar.xz
-# Source0-md5: 9e854df51ca3fef8bfe566dbd7b89241
+Source0:       http://www.kernel.org/pub/linux/kernel/v4.x/linux-%{basever}.tar.xz
+# Source0-md5: a86916bd12798220da9eb4a1eec3616d
 %if "%{postver}" != ".0"
-Patch0:                http://www.kernel.org/pub/linux/kernel/v3.x/patch-%{version}.xz
-# Patch0-md5:  30aa769974e64fd17a01724d1577a913
+Patch0:                http://www.kernel.org/pub/linux/kernel/v4.x/patch-%{version}.xz
+# Patch0-md5:  30de8c55237264deee4d4fc60eee78fd
 %endif
 Source1:       kernel.sysconfig
 
@@ -144,6 +145,7 @@ Source41:   kernel-patches.config
 Source43:      kernel-vserver.config
 
 Source55:      kernel-imq.config
+Source56:      kernel-uksm.config
 
 Source58:      kernel-inittmpfs.config
 
@@ -187,8 +189,8 @@ Patch59:    kernel-rndis_host-wm5.patch
 # http://patches.aircrack-ng.org/hostap-kernel-2.6.18.patch
 Patch85:       kernel-hostap.patch
 
-%define        vserver_patch 3.10.9-vs2.3.6.6
-# http://vserver.13thfloor.at/Experimental/patch-3.13.6-vs2.3.6.11.diff
+%define        vserver_patch 3.18.5-vs2.3.7.3
+# http://vserver.13thfloor.at/Experimental/patch-3.18.5-vs2.3.7.3.diff
 # note there are additional patches from above url:
 # - *fix* are real fixes (we want these)
 # - *feat* are new features/tests (we don't want these)
@@ -199,7 +201,7 @@ Patch101:   kernel-vserver-fixes.patch
 # Patch creation:
 # git clone git://aufs.git.sourceforge.net/gitroot/aufs/aufs3-standalone.git
 # cd aufs3-standalone
-# git checkout -b aufs3.15 origin/aufs3.15
+# git checkout -b aufs4.0 origin/aufs4.0
 # cat aufs3-kbuild.patch aufs3-base.patch aufs3-mmap.patch aufs3-standalone.patch > ~/rpm/packages/kernel/kernel-aufs3.patch
 # mkdir linux
 # cp -a Documentation fs include linux
@@ -210,6 +212,11 @@ Patch101:  kernel-vserver-fixes.patch
 Patch145:      kernel-aufs3.patch
 Patch146:      kernel-aufs3+vserver.patch
 
+%define uksm_major_version 0.1.2.3
+%define uksm_version %{uksm_major_version}-for-v3.18
+Patch150:      http://kerneldedup.org/download/uksm/%{uksm_major_version}/uksm-%{uksm_version}.patch
+# Patch150-md5:        b6a2b2aae9c2844d0c74690632d7019e
+
 # Show normal colors in menuconfig with ncurses ABI 6
 Patch250:      kernel-fix_256colors_menuconfig.patch
 
@@ -227,6 +234,7 @@ Patch505:   dm-crypt-sort-requests.patch
 Patch2000:     kernel-small_fixes.patch
 Patch2001:     kernel-pwc-uncompress.patch
 Patch2003:     kernel-regressions.patch
+Patch2004:     kernel-libata-ahci-pm.patch
 
 # bzr co lp:apparmor
 # ls apparmor/kernel-patches/3.12
@@ -710,6 +718,11 @@ cd linux-%{basever}
 %patch146 -p1
 %endif
 
+# UKSM
+%if %{with uksm}
+%patch150 -p1
+%endif
+
 %if %{with rescuecd}
 %patch7000 -p1
 %endif
@@ -738,6 +751,7 @@ cd linux-%{basever}
 %patch2000 -p1
 %patch2001 -p1
 #%patch2003 -p1
+%patch2004 -p1
 
 # Do not remove this, please!
 #%%patch50000 -p1
@@ -927,6 +941,9 @@ EOCONFIG
 %if %{with imq}
                %{SOURCE55} \
 %endif
+%if %{with uksm}
+               %{SOURCE56} \
+%endif
 %if %{with vserver}
                %{SOURCE43} \
 %endif
@@ -1475,7 +1492,6 @@ fi
 %{_kernelsrcdir}/arch/m68k/install.sh
 %{_kernelsrcdir}/arch/parisc/install.sh
 %{_kernelsrcdir}/arch/x86/ia32/[!M]*
-%{_kernelsrcdir}/arch/ia64/kvm
 %{_kernelsrcdir}/arch/powerpc/kvm
 %ifarch ppc ppc64
 %exclude %{_kernelsrcdir}/arch/powerpc/lib/crtsavres.*
This page took 0.045737 seconds and 4 git commands to generate.