]> git.pld-linux.org Git - packages/kernel.git/blobdiff - kernel.spec
- disable vserver
[packages/kernel.git] / kernel.spec
index b513bd918bfbb36f68be20d41c1097e4ea61c21b..1ed31fb8280011186f5fe7c13be4d9d447db7a93 100644 (file)
@@ -30,7 +30,7 @@
 %bcond_without ipv6            # ipv6 support
 %bcond_with    padmcrypt       # parallel dm-crypt
 
-%bcond_without vserver         # support for VServer
+%bcond_with    vserver         # support for VServer
 
 %bcond_with    vanilla         # don't include any patches
 %bcond_with    rescuecd        # build kernel for our rescue
@@ -39,6 +39,7 @@
 %{?debug:%define with_verbose 1}
 
 %define                have_drm        1
+%define                have_ide        1
 %define                have_oss        1
 %define                have_sound      1
 %define                have_pcmcia     1
@@ -51,6 +52,7 @@
 
 %if %{with myown}
 %define                have_drm        0
+%define                have_ide        0
 %define                have_oss        0
 %define                have_sound      0
 %define                have_pcmcia     0
@@ -66,9 +68,9 @@
 %define                have_pcmcia     0
 %endif
 
-%define                rel             1
-%define                basever         3.13
-%define                postver         .6
+%define                rel             0.2
+%define                basever         3.15
+%define                postver         .1
 
 # define this to '-%{basever}' for longterm branch
 %define                versuffix       %{nil}
@@ -111,10 +113,10 @@ Epoch:            3
 License:       GPL v2
 Group:         Base/Kernel
 Source0:       http://www.kernel.org/pub/linux/kernel/v3.x/linux-%{basever}.tar.xz
-# Source0-md5: 0ecbaf65c00374eb4a826c2f9f37606f
+# Source0-md5: 97ca1625bb40368dc41b9a7971549071
 %if "%{postver}" != ".0"
 Patch0:                http://www.kernel.org/pub/linux/kernel/v3.x/patch-%{version}.xz
-# Patch0-md5:  a9b131a589a176b4c437b8ca4557b85e
+# Patch0-md5:  78a944411af297b9e5e9aa430056de4c
 %endif
 Source1:       kernel.sysconfig
 
@@ -144,7 +146,6 @@ Source58:   kernel-inittmpfs.config
 # http://dev.gentoo.org/~spock/projects/fbcondecor/archive/fbcondecor-0.9.4-2.6.25-rc6.patch
 Patch3:                kernel-fbcondecor.patch
 Patch4:                kernel-fbcon-margins.patch
-Patch5:                linux-wistron-amilo8210.patch
 Patch6:                linux-wistron-nx.patch
 
 # netfilter related stuff mostly based on patch-o-matic-ng
@@ -183,10 +184,7 @@ Patch59:   kernel-rndis_host-wm5.patch
 # http://patches.aircrack-ng.org/hostap-kernel-2.6.18.patch
 Patch85:       kernel-hostap.patch
 
-# http://www.linuxtv.org/wiki/index.php/TechniSat_CableStar_Combo_HD_CI#Patch
-Patch90:       kernel-technisat-combo-hd-ci.patch
-
-# http://vserver.13thfloor.at/Experimental/patch-3.13.1-vs2.3.6.10.diff
+# http://vserver.13thfloor.at/Experimental/patch-3.13.6-vs2.3.6.11.diff
 # note there are additional patches from above url:
 # - *fix* are real fixes (we want these)
 # - *feat* are new features/tests (we don't want these)
@@ -209,12 +207,13 @@ Patch118: ovl09-fs-limit-filesystem-stacking-depth.patch
 # Patch creation:
 # git clone git://aufs.git.sourceforge.net/gitroot/aufs/aufs3-standalone.git
 # cd aufs3-standalone
-# git checkout -b aufs3.13 origin/aufs3.13
-# cat aufs3-kbuild.patch aufs3-base.patch aufs3-standalone.patch > ~/rpm/packages/kernel/kernel-aufs3.patch
+# git checkout -b aufs3.15 origin/aufs3.15
+# cat aufs3-kbuild.patch aufs3-base.patch aufs3-mmap.patch aufs3-standalone.patch > ~/rpm/packages/kernel/kernel-aufs3.patch
 # mkdir linux
 # cp -a Documentation fs include linux
 # diff -urN /usr/share/empty linux >> ~/rpm/packages/kernel/kernel-aufs3.patch
 # drop hunk at the end of patch (hunk is patching include/linux/Kbuild with single line change)
+# cat aufs3-loopback.patch >> ~/rpm/packages/kernel/kernel-aufs3.patch
 #
 Patch145:      kernel-aufs3.patch
 Patch146:      kernel-aufs3+vserver.patch
@@ -227,11 +226,14 @@ Patch400: kernel-virtio-gl-accel.patch
 
 # http://people.redhat.com/mpatocka/patches/kernel/dm-crypt-paralelizace/current/series.html
 Patch500:      dm-crypt-remove-percpu.patch
-Patch501:      dm-crypt-unbound-workqueue.patch
-Patch502:      dm-crypt-dont-allocate-partial-pages.patch
-Patch503:      dm-crypt-fix-allocation-deadlock.patch
-Patch504:      dm-crypt-offload-writes-to-thread.patch
-Patch505:      dm-crypt-sort-requests.patch
+Patch501:      bio-kmalloc-align.patch
+Patch502:      dm-crypt-per_bio_data.patch
+Patch503:      dm-crypt-unbound-workqueue.patch
+Patch504:      dm-crypt-dont-allocate-partial-pages.patch
+Patch505:      dm-crypt-fix-allocation-deadlock.patch
+Patch506:      dm-crypt-remove-io-pool.patch
+Patch507:      dm-crypt-offload-writes-to-thread.patch
+Patch508:      dm-crypt-sort-requests.patch
 
 Patch2000:     kernel-small_fixes.patch
 Patch2001:     kernel-pwc-uncompress.patch
@@ -282,6 +284,7 @@ Requires:   cpuinfo(pae)
 Suggests:      crda
 Suggests:      dracut
 Suggests:      keyutils
+Suggests:      kernel-ide = %{epoch}:%{version}-%{release}
 Suggests:      linux-firmware
 Provides:      %{name}(netfilter) = 20070806
 Provides:      %{name}(vermagic) = %{kernel_release}
@@ -463,6 +466,24 @@ DRM Kernel Treiber.
 %description drm -l pl.UTF-8
 Sterowniki DRM.
 
+%package ide
+Summary:       IDE kernel modules
+Summary(de.UTF-8):     IDE Kernel Treiber
+Summary(pl.UTF-8):     Sterowniki IDE
+Group:         Base/Kernel
+Requires(postun):      %{name} = %{epoch}:%{version}-%{release}
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+AutoReqProv:   no
+
+%description ide
+IDE kernel modules.
+
+%description ide -l de.UTF-8
+IDE Kernel Treiber.
+
+%description ide -l pl.UTF-8
+Sterowniki IDE.
+
 %package pcmcia
 Summary:       PCMCIA modules
 Summary(de.UTF-8):     PCMCIA Module
@@ -638,7 +659,6 @@ cd linux-%{basever}
 %patch3 -p1
 %endif
 %patch4 -p1
-%patch5 -p1
 %patch6 -p1
 
 ## netfilter
@@ -679,9 +699,6 @@ cd linux-%{basever}
 # hostap enhancements from/for aircrack-ng
 %patch85 -p1
 
-# TechniSat_CableStar_Combo_HD_CI
-%patch90 -p1
-
 # vserver
 %if %{with vserver}
 %patch100 -p1
@@ -724,6 +741,9 @@ cd linux-%{basever}
 %patch503 -p1
 %patch504 -p1
 %patch505 -p1
+%patch506 -p1
+%patch507 -p1
+%patch508 -p1
 %endif
 
 %endif # vanilla
@@ -1187,6 +1207,12 @@ fi
 %postun drm
 %depmod %{kernel_release}
 
+%post ide
+%depmod %{kernel_release}
+
+%postun ide
+%depmod %{kernel_release}
+
 %post pcmcia
 %depmod %{kernel_release}
 
@@ -1250,6 +1276,9 @@ fi
 %if %{have_drm}
 %exclude /lib/modules/%{kernel_release}/kernel/drivers/gpu
 %endif
+%if %{have_ide}
+%exclude /lib/modules/%{kernel_release}/kernel/drivers/ide/*
+%endif
 /lib/modules/%{kernel_release}/kernel/fs
 /lib/modules/%{kernel_release}/kernel/kernel
 /lib/modules/%{kernel_release}/kernel/lib
@@ -1323,6 +1352,15 @@ fi
 /lib/modules/%{kernel_release}/kernel/drivers/gpu
 %endif
 
+%if %{have_ide}
+%files ide
+%defattr(644,root,root,755)
+/lib/modules/%{kernel_release}/kernel/drivers/ide/*
+%if %{have_pcmcia}
+%exclude /lib/modules/%{kernel_release}/kernel/drivers/ide/ide-cs.ko*
+%endif
+%endif
+
 %if %{have_pcmcia}
 %files pcmcia
 %defattr(644,root,root,755)
This page took 0.043908 seconds and 4 git commands to generate.