]> git.pld-linux.org Git - projects/template-specs.git/blobdiff - kernel-module.spec
- alt kernel stuff
[projects/template-specs.git] / kernel-module.spec
index 6f83c8582f1b9abadbc5b0c22da0d3a17bcca8f9..bc7039a975faa6d5ef177bdacd185b5f440b814d 100644 (file)
@@ -1,6 +1,8 @@
 #
-# Replace MODULE_NAME with real module name and MODULE_DIR
-# with required directory name.
+# Replace:
+# MODULE_NAME with real module name
+# MODULE_DIR with required directory name
+# PACKAGE_NAME with package name
 #
 # Conditional build:
 %bcond_without dist_kernel     # allow non-distribution kernel
 %if %{without kernel}
 %undefine      with_dist_kernel
 %endif
+%if "%{_alt_kernel}" != "%{nil}"
+%undefine      with_userspace
+%endif
+%if %{without userspace}
+# nothing to be placed to debuginfo package
+%define                _enable_debug_packages  0
+%endif
 
 #
 # main package.
 #
 %define                rel     0.1
+%define                pname   PACKAGE_NAME
 Summary:       -
 Summary(pl.UTF-8):     -
 Name:          -
@@ -24,11 +34,11 @@ Release:    %{rel}
 Epoch:         0
 #License:      - (enter GPL/LGPL/BSD/BSD-like/other license name here)
 Group:         -
-Source0:       %{name}-%{version}.tar.gz
+Source0:       %{pname}-%{version}.tar.gz
 # Source0-md5: -
 #Source1:      -
 # Source1-md5: -
-#Patch0:       %{name}-what.patch
+#Patch0:       %{pname}-what.patch
 #URL:          -
 %if %{with kernel}
 %{?with_dist_kernel:BuildRequires:     kernel%{_alt_kernel}-module-build >= 3:2.6.20.2}
@@ -72,6 +82,8 @@ Sterownik dla Linuksa do MODULE_NAME.
 Ten pakiet zawiera moduł jądra Linuksa.
 
 %prep
+%setup -q -n %{pname}-%{version}
+
 # prepare makefile:
 cat > path/to/dir/Makefile << EOF
 
This page took 0.077565 seconds and 4 git commands to generate.