]> git.pld-linux.org Git - packages/kde4-kdeplasma-addons.git/blobdiff - kde4-kdeplasma-addons.spec
- up to 4.7.0 but fails to build
[packages/kde4-kdeplasma-addons.git] / kde4-kdeplasma-addons.spec
index 56329953c49250122b270d228f3d156b6b4314f8..f0b9db779c976ce68406e7f717a5d7be8524b1d4 100644 (file)
@@ -7,43 +7,43 @@
 
 %define                orgname     kdeplasma-addons
 %define                _state      stable
-%define                qtver       4.7.0
+%define                qtver       4.7.3
 
 Summary:       KDE4 Plasmoids
 Summary(pl.UTF-8):     Plazmoidy dla KDE4
 Name:          kde4-kdeplasma-addons
-Version:       4.5.3
-Release:       1
+Version:       4.7.0
+Release:       0.1
 License:       GPL v2
 Group:         X11/Applications
 Source0:       ftp://ftp.kde.org/pub/kde/%{_state}/%{version}/src/%{orgname}-%{version}.tar.bz2
-# Source0-md5: f23d0d5d465e314c05c5282cddfa6ab6
+# Source0-md5: f7152ffd214d96b01fab0b112ce4def6
 Patch100:      %{name}-branch.diff
 Patch0:                %{name}-pastebinpld.patch
 URL:           http://www.kde.org/
 BuildRequires: OpenGL-GLU-devel
 BuildRequires: OpenGL-devel
-BuildRequires: QtCore-devel >= %{qtver}
 BuildRequires: QtNetwork-devel >= %{qtver}
-BuildRequires: QtOpenGL-devel >= %{qtver}
-BuildRequires: QtScript-devel >= %{qtver}
-BuildRequires: QtSvg-devel >= %{qtver}
-BuildRequires: QtWebKit-devel >= %{qtver}
 BuildRequires: automoc4 >= 0.9.88
 BuildRequires: cmake >= 2.8.0
 BuildRequires: eigen >= 1:2.0.12-3
 BuildRequires: kde4-kdebase-workspace-devel >= %{version}
-%{?with_marble:BuildRequires:  kde4-kdeedu-devel >= %{version}}
-BuildRequires: kde4-kdegraphics-devel >= %{version}
 BuildRequires: kde4-kdelibs-devel >= %{version}
 BuildRequires: kde4-kdepimlibs-devel >= %{version}
+%{?with_marble:BuildRequires:  libkdeedu-devel >= %{version}}
+BuildRequires: libkexiv2-devel >= %{version}
+BuildRequires: marble-devel >= 4.7.0
 BuildRequires: phonon-devel >= 4.4.1
 BuildRequires: pkgconfig
 BuildRequires: python
+BuildRequires: qca-devel >= 2.0.2
+BuildRequires: qimageblitz-devel
 BuildRequires: qimageblitz-devel >= 0.0.6
 BuildRequires: qt4-build >= %{qtver}
 BuildRequires: qt4-qmake >= %{qtver}
-BuildRequires: rpmbuild(macros) >= 1.293
+BuildRequires: qwt-devel
+BuildRequires: rpmbuild(macros) >= 1.600
+BuildRequires: scim-devel
 BuildRequires: shared-desktop-ontologies-devel >= 0.5
 BuildRequires: soprano-devel >= 2.4.64
 BuildRequires: strigi-devel >= 0.7.2
@@ -93,18 +93,12 @@ opartych na plazmoidach dla KDE4.
 %prep
 %setup -q -n %{orgname}-%{version}
 #%patch100 -p0
-%patch0 -p1
+#%patch0 -p1
 
 %build
 install -d build
 cd build
 %cmake \
-       -DCMAKE_INSTALL_PREFIX=%{_prefix} \
-       -DLIB_INSTALL_DIR=%{_libdir} \
-       -DCMAKE_BUILD_TYPE=%{!?debug:Release}%{?debug:Debug} \
-%if "%{_lib}" != "lib"
-       -DLIB_SUFFIX=64 \
-%endif
        ../
 
 %{__make}
@@ -126,6 +120,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/kimpanel
 %attr(755,root,root) %{_libdir}/kde4/krunner_*.so
 %attr(755,root,root) %{_libdir}/kde4/kcm_krunner_*.so
 %attr(755,root,root) %{_libdir}/kde4/plasma_applet_bball.so
@@ -143,6 +138,8 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/kde4/plasma_applet_frame.so
 %attr(755,root,root) %{_libdir}/kde4/plasma_applet_fuzzy_clock.so
 %attr(755,root,root) %{_libdir}/kde4/plasma_applet_incomingmsg.so
+%attr(755,root,root) %{_libdir}/kde4/plasma_applet_kdeobservatory.so
+%attr(755,root,root) %{_libdir}/kde4/plasma_applet_kimpanel.so
 %attr(755,root,root) %{_libdir}/kde4/plasma_applet_knowledgebase.so
 %attr(755,root,root) %{_libdir}/kde4/plasma_applet_kolourpicker.so
 %attr(755,root,root) %{_libdir}/kde4/plasma_applet_konqprofiles.so
@@ -186,12 +183,18 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/kde4/plasma_potd_wcpotdprovider.so
 %attr(755,root,root) %{_libdir}/kde4/plasma_runner_datetime.so
 %attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_mandelbrot.so
+%attr(755,root,root) %{_libdir}/kde4/kcm_plasma_runner_events.so
+%attr(755,root,root) %{_libdir}/kde4/plasma_containment_griddesktop.so
+%attr(755,root,root) %{_libdir}/kde4/plasma_containment_groupingdesktop.so
+%attr(755,root,root) %{_libdir}/kde4/plasma_containment_groupingpanel.so
+%attr(755,root,root) %{_libdir}/kde4/plasma_runner_events.so
 %if %{with marble}
 %attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_marble.so
 %endif
 %attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_pattern.so
 %attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_virus.so
 %attr(755,root,root) %{_libdir}/kde4/plasma_wallpaper_weather.so
+%attr(755,root,root) %{_libdir}/libkimpanelruntime.so.?
 %attr(755,root,root) %{_libdir}/libplasmacomicprovidercore.so
 %attr(755,root,root) %ghost %{_libdir}/libplasmapotdprovidercore.so.?
 %attr(755,root,root) %{_libdir}/libplasmapotdprovidercore.so.*.*.*
@@ -199,9 +202,14 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_libdir}/libplasmaweather.so.*.*.*
 %attr(755,root,root) %ghost %{_libdir}/librtm.so.?
 %attr(755,root,root) %{_libdir}/librtm.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libplasma_groupingcontainment.so.?
+%attr(755,root,root) %{_libdir}/libplasma_groupingcontainment.so.*.*.*
+%attr(755,root,root) %{_libdir}/scim-*/scim-panel-dbus
+%{_datadir}/config.kcfg/kimpanelconfig.kcfg
+%{_datadir}/dbus-1/interfaces/org.kde.impanel.xml
 %{_datadir}/apps/desktoptheme/Aya
-%{_datadir}/apps/desktoptheme/Elegance
-%{_datadir}/apps/desktoptheme/Silicon
+#%{_datadir}/apps/desktoptheme/Elegance
+#%{_datadir}/apps/desktoptheme/Silicon
 %dir %{_datadir}/apps/desktoptheme/default/stylesheets
 %{_datadir}/apps/desktoptheme/default/stylesheets/*
 %dir %{_datadir}/apps/desktoptheme/default/weatherstation
@@ -209,7 +217,7 @@ rm -rf $RPM_BUILD_ROOT
 %dir %{_datadir}/apps/desktoptheme/default/weather/
 %{_datadir}/apps/desktoptheme/default/weather/wind-arrows.svgz
 %{_datadir}/apps/desktoptheme/default/widgets/*
-%{_datadir}/apps/desktoptheme/heron
+#%{_datadir}/apps/desktoptheme/heron
 %{_datadir}/apps/desktoptheme/slim-glow
 %{_datadir}/kde4/services/CharRunner_config.desktop
 %{_datadir}/kde4/services/CharacterRunner.desktop
@@ -231,6 +239,8 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/kde4/services/plasma-applet-eyes.desktop
 %{_datadir}/kde4/services/plasma-applet-fifteenPuzzle.desktop
 %{_datadir}/kde4/services/plasma-applet-incomingmsg.desktop
+%{_datadir}/kde4/services/plasma-applet-kdeobservatory.desktop
+%{_datadir}/kde4/services/plasma-applet-kimpanel.desktop
 %{_datadir}/kde4/services/plasma-applet-knowledgebase.desktop
 %{_datadir}/kde4/services/plasma-applet-konqprofiles.desktop
 %{_datadir}/kde4/services/plasma-applet-konsoleprofiles.desktop
@@ -267,7 +277,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/kde4/services/plasma-dataengine-potd.desktop
 %{_datadir}/kde4/services/plasma-dict-default.desktop
 %{_datadir}/kde4/services/plasma-engine-kdeobservatory.desktop
-%{_datadir}/kde4/services/plasma-engine-pastebin.desktop
+#%{_datadir}/kde4/services/plasma-engine-pastebin.desktop
 %{_datadir}/kde4/services/plasma-engine-rtm.desktop
 %{_datadir}/kde4/services/plasma-fileWatcher-default.desktop
 %{_datadir}/kde4/services/plasma-frame-default.desktop
@@ -311,7 +321,11 @@ rm -rf $RPM_BUILD_ROOT
 %{_iconsdir}/hicolor/scalable/apps/bball.svgz
 %{_iconsdir}/hicolor/*x*/apps/qalculate-applet.png
 %{_iconsdir}/hicolor/*x*/apps/plasmaapplet-shelf.png
-
+%{_iconsdir}/hicolor/*x*/apps/eyes.png
+%{_iconsdir}/hicolor/*x*/apps/kdeobservatory.png
+%{_iconsdir}/hicolor/*x*/apps/lifegame.png
+%{_iconsdir}/hicolor/*x*/apps/luna.png
+%{_datadir}/config/pastebin.knsrc
 %dir %{_datadir}/apps/rssnow
 %{_datadir}/apps/rssnow/feeds
 %{_iconsdir}/*/*x*/apps/previewer.png
@@ -328,6 +342,12 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/apps/plasma-applet-frame
 %{_datadir}/apps/plasma_pastebin
 %{_datadir}/apps/plasma_wallpaper_pattern
+%{_datadir}/kde4/services/lancelot.desktop
+%{_datadir}/kde4/services/plasma-containment-griddesktop.desktop
+%{_datadir}/kde4/services/plasma-containment-groupingdesktop.desktop
+%{_datadir}/kde4/services/plasma-containment-groupingpanel.desktop
+%{_datadir}/kde4/services/plasma-runner-events.desktop
+%{_datadir}/kde4/services/plasma-runner-events_config.desktop
 
 %files lancelot
 %defattr(644,root,root,755)
@@ -343,7 +363,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/apps/desktoptheme/oxygen/lancelot
 %{_datadir}/kde4/services/plasma-applet-lancelot-launcher.desktop
 %{_datadir}/kde4/services/plasma-applet-lancelot-part.desktop
-%{_datadir}/dbus-1/services/org.kde.lancelot.service
+#%{_datadir}/dbus-1/services/org.kde.lancelot.service
 %{_datadir}/mime/packages/lancelotpart-mime.xml
 %{_datadir}/apps/lancelot
 %{_iconsdir}/hicolor/*x*/apps/lancelot.png
This page took 0.092203 seconds and 4 git commands to generate.