]> git.pld-linux.org Git - packages/ka5-kalarm.git/blobdiff - ka5-kalarm.spec
- excluding x32
[packages/ka5-kalarm.git] / ka5-kalarm.spec
index 1e754cce43b5403c9bb4b462ddc944a09d1e64fc..8f2df2b77129be805e0328cfdd519be811ffde7b 100644 (file)
@@ -1,20 +1,23 @@
-%define                kdeappsver      19.04.1
+#
+# Conditional build:
+%bcond_with    tests           # build with tests
+%define                kdeappsver      22.04.2
 %define                kframever       5.56.0
 %define                qtver           5.9.0
 %define                kaname          kalarm
 Summary:       kalarm
 Name:          ka5-%{kaname}
-Version:       19.04.1
-Release:       1
+Version:       22.04.2
+Release:       2
 License:       GPL v2+/LGPL v2.1+
 Group:         X11/Applications
-Source0:       http://download.kde.org/stable/applications/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
-# Source0-md5: ed0b01c26e17b187faa3ab0a043090f7
+Source0:       https://download.kde.org/stable/release-service/%{kdeappsver}/src/%{kaname}-%{version}.tar.xz
+# Source0-md5: d775dbaeef3ba93f00073c0136eec76a
 URL:           http://www.kde.org/
 BuildRequires: Qt5Core-devel >= %{qtver}
 BuildRequires: cmake >= 2.8.12
 BuildRequires: ka5-akonadi-devel >= 18.04.0
-BuildRequires: ka5-kalarmcal-devel >= %{kdeappsver}
+BuildRequires: ka5-kcalutils-devel >= %{kdeappsver}
 BuildRequires: ka5-kimap-devel >= %{kdeappsver}
 BuildRequires: ka5-mailcommon-devel >= %{kdeappsver}
 BuildRequires: kf5-extra-cmake-modules >= %{kframever}
@@ -34,6 +37,7 @@ BuildRequires:        rpmbuild(macros) >= 1.164
 BuildRequires: shared-mime-info
 BuildRequires: tar >= 1:1.22
 BuildRequires: xz
+ExclusiveArch: i686 %{x8664}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -41,13 +45,27 @@ KAlarm is a personal alarm message, command and email scheduler.
 
 Features
 
-• Display alarms using your own text message, the text generated by a
-command, or a text or image file. • Audible alarm using a sound file •
-Recurring alarm on an hours/minutes, daily, weekly, monthly or annual
-basis, or set it to trigger every time you log in. • Display alarms
-color and font customization • Support for multiple alarm calendars,
-which for example enables you to share alarms between a laptop and
-desktop computer.
+• Display alarms using your own text message, the text generated by
+a command, or a text or image file. • Audible alarm using a sound
+file • Recurring alarm on an hours/minutes, daily, weekly, monthly
+or annual basis, or set it to trigger every time you log in. •
+Display alarms color and font customization • Support for multiple
+alarm calendars, which for example enables you to share alarms between
+a laptop and desktop computer.
+
+%description -l pl.UTF-8
+KAlarm jest osobistym budzikiem i harmonogramem.
+
+Własciwości
+
+• Wyświetla własne wiadomości tekstowe, lub tekst wygenerowany
+przez program, lub wyświetla plik tekstowy bądź obrazek •
+Dźwiękowe powiadomomienia • Powtarzalne alarmy, o określonej
+godzinie/minucie, dzienne, tygodniowe, miesięczne lub roczne a także
+wyzwalane wtedy gdy się zalogujesz • Możliwość konfiguracji
+koloru i rodzaju czcionki • Wsparcie dla wielu kalendarzy
+powiadomień, co pozwala na przykład współdzielić alarmy między
+laptopem a komputerem stacjonarnym
 
 %prep
 %setup -q -n %{kaname}-%{version}
@@ -57,11 +75,17 @@ install -d build
 cd build
 %cmake \
        -G Ninja \
+       %{!?with_tests:-DBUILD_TESTING=OFF} \
        -DHTML_INSTALL_DIR=%{_kdedocdir} \
        -DKDE_INSTALL_USE_QT_SYS_PATHS=ON \
        ..
 %ninja_build
 
+%if %{with tests}
+ctest
+%endif
+
+
 %install
 rm -rf $RPM_BUILD_ROOT
 %ninja_install -C build
@@ -71,19 +95,18 @@ rm -rf $RPM_BUILD_ROOT
 %clean
 rm -rf $RPM_BUILD_ROOT
 
+%post -p /sbin/ldconfig
+%postun -p /sbin/ldconfig
+
 %files -f %{kaname}.lang
 %defattr(644,root,root,755)
-/etc/dbus-1/system.d/org.kde.kalarm.rtcwake.conf
 /etc/xdg/autostart/kalarm.autostart.desktop
-/etc/xdg/kalarm.categories
-/etc/xdg/kalarm.renamecategories
 %attr(755,root,root) %{_bindir}/kalarm
 %attr(755,root,root) %{_bindir}/kalarmautostart
 %{_prefix}/libexec/kauth/kalarm_helper
 %{_desktopdir}/org.kde.kalarm.desktop
 %{_datadir}/config.kcfg/kalarmconfig.kcfg
 %{_datadir}/dbus-1/interfaces/org.kde.kalarm.kalarm.xml
-%{_datadir}/dbus-1/system-services/org.kde.kalarm.rtcwake.service
 %{_iconsdir}/hicolor/128x128/apps/kalarm.png
 %{_iconsdir}/hicolor/16x16/apps/kalarm.png
 %{_iconsdir}/hicolor/22x22/apps/kalarm.png
@@ -91,14 +114,14 @@ rm -rf $RPM_BUILD_ROOT
 %{_iconsdir}/hicolor/48x48/apps/kalarm.png
 %{_iconsdir}/hicolor/64x64/apps/kalarm.png
 %{_datadir}/kalarm
-%attr(755,root,root) %{_datadir}/kconf_update/kalarm-1.2.1-general.pl
-%attr(755,root,root) %{_datadir}/kconf_update/kalarm-1.9.5-defaults.pl
-%attr(755,root,root) %{_datadir}/kconf_update/kalarm-15.08-kickoff.sh
-%attr(755,root,root) %{_datadir}/kconf_update/kalarm-2.0.2-general.pl
-%attr(755,root,root) %{_datadir}/kconf_update/kalarm-2.1.5-general.pl
-%attr(755,root,root) %{_datadir}/kconf_update/kalarm-version.pl
-%{_datadir}/kconf_update/kalarm.upd
 %dir %{_datadir}/kxmlgui5/kalarm
 %{_datadir}/kxmlgui5/kalarm/kalarmui.rc
 %{_datadir}/metainfo/org.kde.kalarm.appdata.xml
 %{_datadir}/polkit-1/actions/org.kde.kalarm.rtcwake.policy
+%{_datadir}/dbus-1/system-services/org.kde.kalarm.rtcwake.service
+%{_datadir}/dbus-1/system.d/org.kde.kalarm.rtcwake.conf
+%{_datadir}/qlogging-categories5/kalarm.categories
+%{_datadir}/qlogging-categories5/kalarm.renamecategories
+%{_datadir}/knotifications5/kalarm.notifyrc
+%ghost %{_libdir}/libkalarmprivate.so.5
+%attr(755,root,root) %{_libdir}/libkalarmprivate.so.*.*.*
This page took 0.039036 seconds and 4 git commands to generate.