]> git.pld-linux.org Git - packages/john.git/blobdiff - john.spec
- adapterized
[packages/john.git] / john.spec
index 1a9fba39334bf9b9664f33204ed3ad7e550c9066..753a815311205a43cfecf02c7fa8991ef634c50e 100644 (file)
--- a/john.spec
+++ b/john.spec
@@ -1,36 +1,41 @@
 #
+# TODO:
+# - investigate build-time vs runtime detection
+#
 # Conditional build:
-%bcond_with jumbopatch # This patch integrates lots of contributed
-                       # patches adding support for over 30
-                       # of additional hash types, and more.
+%bcond_without opencl          # OpenCL support (in jumbo version)
+%bcond_without openmp          # OpenMP support (in jumbo version)
+
+%define                snap            20181101
+%define                githash         d73288b91d92f3bd670c18d3853ddaf0e02159f0
 
-%ifarch i586 i686 athlon pentium2 pentium3 pentium4
-%define do_mmx 1
-%else
-%define        do_mmx 0
-%endif
-%ifarch i586 i686
-%define do_mmxfb 1
-%define        optmmxfb        -DCPU_FALLBACK=1
-%else
-%define do_mmxfb 0
-%undefine optmmxfb
-%endif
 Summary:       Password cracker
 Summary(pl.UTF-8):     Łamacz haseł
 Name:          john
-Version:       1.7.6
-Release:       1
-License:       GPL
+Version:       1.8.0
+Release:       2.%{snap}.1
+License:       GPL v2
 Group:         Applications/System
-Source0:       http://www.openwall.com/john/g/%{name}-%{version}.tar.bz2
-# Source0-md5: 321ac0793f1aa4f0603b33a393133756
+Source0:       https://github.com/magnumripper/JohnTheRipper/archive/%{githash}/%{name}-%{snap}.tar.gz
+# Source0-md5: a75c1108111c5181b471a9f4a9dab898
 Patch0:                %{name}-mailer.patch
-Patch1:                optflags.patch
-%{?with_jumbopatch:Patch1: http://www.openwall.com/john/contrib/%{name}-%{version}-jumbo-2.diff.gz}
+Patch1:                jumbo-optflags.patch
+Patch4:                %{name}-x32.patch
 URL:           http://www.openwall.com/john/
-%{?with_jumbopatch:BuildRequires: openssl-devel >= 0.9.7}
+%{?with_opencl:BuildRequires:  OpenCL-devel}
+BuildRequires: autoconf >= 2.69
+BuildRequires: bzip2-devel
+%{?with_openmp:BuildRequires:  gcc >= 6:4.2}
+BuildRequires: gmp-devel
+%{?with_openmp:BuildRequires:  libgomp-devel}
 BuildRequires: rpmbuild(macros) >= 1.213
+BuildRequires: tar >= 1:1.22
+# for SIPdump and vncpcap2john binaries, which are not packaged
+#BuildRequires:        libpcap-devel
+BuildRequires: openssl-devel >= 0.9.7
+BuildRequires: pkgconfig
+BuildRequires: yasm
+BuildRequires: zlib-devel
 Requires:      words
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -54,55 +59,31 @@ na różnych uniksach, obsługiwane są także skróty Kerberos/AFS oraz
 Windows NT/2000/XP LM, a także kilka innych przy użyciu łat.
 
 %prep
-%setup -q
+%setup -q -n JohnTheRipper-%{githash}
 %patch0 -p1
 %patch1 -p1
-%{?with_jumbopatch:%patch1 -p1}
-
-rm -f doc/INSTALL
+%ifarch x32
+%patch4 -p1
+%endif
 
 %build
 cd src
+%{__autoconf}
 
-%if %{do_mmxfb}
-%{__make} linux-x86-any \
-       CC="%{__cc}" \
-       OPTFLAGS="%{rpmcflags} -DJOHN_SYSTEMWIDE=1"
-mv ../run/john ../run/john-non-mmx
-%{__make} clean
+%ifarch x32
+ax_intel_x32=yes \
 %endif
+%configure \
+       %{!?with_opencl:--disable-opencl} \
+       %{!?with_openmp:--disable-openmp}
 
-TARG=generic
-%ifarch %{ix86}
-       %if %{do_mmx}
-               TARG=linux-x86-mmx
-       %else
-               TARG=linux-x86-any
-       %endif
-%endif
-%ifarch alpha
-       TARG=linux-alpha
-%endif
-%ifarch sparc sparcv9
-       TARG=linux-sparc
-%endif
-%ifarch %{x8664}
-       TARG=linux-x86-64
-%endif
-
-%{__make} $TARG \
-       CC="%{__cc}" \
-       OPTFLAGS="%{rpmcflags} -DJOHN_SYSTEMWIDE=1 -DJOHN_SYSTEMWIDE_EXEC=\\\"%{_libdir}/john\\\" %{?optmmxfb}"
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/john}
 cp -a run/{*.conf,*.chr,*.lst} $RPM_BUILD_ROOT%{_datadir}/john
 install -p run/john $RPM_BUILD_ROOT%{_bindir}
-%if %{do_mmxfb}
-install -d $RPM_BUILD_ROOT%{_libdir}/john
-install -p run/john-non-mmx $RPM_BUILD_ROOT%{_libdir}/john
-%endif
 
 ln -sf john $RPM_BUILD_ROOT%{_bindir}/unafs
 ln -sf john $RPM_BUILD_ROOT%{_bindir}/unique
@@ -118,8 +99,4 @@ rm -rf $RPM_BUILD_ROOT
 %attr(755,root,root) %{_bindir}/unafs
 %attr(755,root,root) %{_bindir}/unique
 %attr(755,root,root) %{_bindir}/unshadow
-%if %{do_mmxfb}
-%dir %{_libdir}/john
-%attr(755,root,root) %{_libdir}/john/john-non-mmx
-%endif
 %{_datadir}/john
This page took 1.097442 seconds and 4 git commands to generate.