]> git.pld-linux.org Git - packages/john.git/blobdiff - john.spec
- tabs in preamble
[packages/john.git] / john.spec
index c4101f01488a37d1a1bc19e3ee8a0bb7d5156bbe..24c0e0f8e42d691085198fc524924773297381b7 100644 (file)
--- a/john.spec
+++ b/john.spec
@@ -1,54 +1,67 @@
 #
-# Conditional build:
-%bcond_with    mmx     # MMX optimization
-# Optimization must be chosen at compile time :(
-# Maybe some patch...? But not yet.
-#
-%ifarch athlon
-%define with_mmx 1
+%ifarch i586 i686 athlon pentium2 pentium3 pentium4
+%define do_mmx 1
+%else
+%define        do_mmx 0
+%endif
+%ifarch i586 i686
+%define do_mmxfb 1
+%define        optmmxfb        -DCPU_FALLBACK=1
+%else
+%define do_mmxfb 0
+%undefine optmmxfb
 %endif
 Summary:       Password cracker
-Summary(pl):   £amacz hase³
+Summary(pl.UTF-8):     Łamacz haseł
 Name:          john
-Version:       1.7
-Release:       0.2
+Version:       1.7.2
+Release:       1
 License:       GPL
 Group:         Applications/System
-Source0:       http://www.openwall.com/john/d/%{name}-%{version}.tar.bz2
-# Source0-md5: 615b912caa677eec790e28745a12b2ae
+Source0:       http://www.openwall.com/john/f/%{name}-%{version}.tar.bz2
+# Source0-md5: dc6a6c2a885110ccb5da4c1e2010cb07
 Patch0:                %{name}-mailer.patch
 URL:           http://www.openwall.com/john/
 BuildRequires: rpmbuild(macros) >= 1.213
-BuildRequires: sed >= 4.0
 Requires:      words
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-John the Ripper is a password cracker, currently available for UNIX,
-DOS, WinNT/Win95. Its primary purpose is to detect weak UNIX
-passwords. It has been tested with Linux x86/Alpha/SPARC, FreeBSD x86,
-OpenBSD x86, Solaris 2.x SPARC and x86, Digital UNIX, AIX, HP-UX, and
-IRIX.
+John the Ripper is a fast password cracker, currently available for
+many flavors of Unix (11 are officially supported, not counting
+different architectures), DOS, Win32, BeOS, and OpenVMS (the latter
+requires a contributed patch). Its primary purpose is to detect weak
+Unix passwords. Besides several crypt(3) password hash types most
+commonly found on various Unix flavors, supported out of the box are
+Kerberos/AFS and Windows NT/2000/XP LM hashes, plus several more with
+contributed patches.
 
-%description -l pl
-John The Ripper jest "³amaczem" hase³ dostêpnym dla systemów UNIX,
-DOS, WinNT/Win95. G³ównym jego zadaniem jest wykrywanie "s³abych"
-hase³. By³ testowany z Linux x86/Alpha/SPARC, FreeBSD x86, OpenBSD x86,
-Solaris 2.x SPARC i x86, Digital UNIX, AIX, HP-UX oraz IRIX.
+%description -l pl.UTF-8
+John The Ripper jest szybkim "łamaczem" haseł dostępnym dla wielu
+rodzajów uniksów (oficjalnie obsługiwanych jest 11, nie licząc różnych
+architektur), DOS-a, Win32, BeOS-a i OpenVMS-a (ten ostatni wymaga
+łaty). Głównym zastosowaniem jest wykrywanie słabych haseł uniksowych.
+Oprócz różnych rodzajów skrótów haseł crypt(3) najczęściej używanych
+na różnych uniksach, obsługiwane są także skróty Kerberos/AFS oraz
+Windows NT/2000/XP LM, a także kilka innych przy użyciu łat.
 
 %prep
-%setup -q 
+%setup -q
 %patch0 -p1
 
-sed -i -e 's/CLK_TCK/CLOCKS_PER_SEC/g' src/*.c
-
 %build
 cd src
 
-# bleh... MMX code must be chosen at compile time :(
-# cannot use MMX for generic i586 nor i686 (Pentium/Pentium Pro have no MMX)
+%if %{do_mmxfb}
+%{__make} linux-x86-any \
+       CFLAGS="-c -Wall -fomit-frame-pointer %{rpmcflags} -DJOHN_SYSTEMWIDE=1" \
+       CC="%{__cc}"
+mv ../run/john ../run/john-non-mmx
+%{__make} clean
+%endif
+
 %ifarch %{ix86}
-       %if %{with mmx}
+       %if %{do_mmx}
                TARG=linux-x86-mmx
        %else
                TARG=linux-x86-any
@@ -64,13 +77,13 @@ cd src
                                TARG=linux-x86-64
                        %else
                                TARG=generic
-                       %endif  
+                       %endif
                %endif
        %endif
 %endif
 
 %{__make} $TARG \
-       CFLAGS="-c -Wall -fomit-frame-pointer %{rpmcflags} -DJOHN_SYSTEMWIDE=1" \
+       CFLAGS="-c -Wall -fomit-frame-pointer %{rpmcflags} -DJOHN_SYSTEMWIDE=1 -DJOHN_SYSTEMWIDE_EXEC=\\\"%{_libdir}/john\\\" %{?optmmxfb}" \
        CC="%{__cc}"
 
 %install
@@ -79,6 +92,10 @@ rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/john}
 install run/{*.conf,*.chr,*.lst} $RPM_BUILD_ROOT%{_datadir}/john
 install run/john $RPM_BUILD_ROOT%{_bindir}
+%if %{do_mmxfb}
+install -d $RPM_BUILD_ROOT%{_libdir}/john
+install run/john-non-mmx $RPM_BUILD_ROOT%{_libdir}/john
+%endif
 
 rm -f doc/INSTALL
 
@@ -94,4 +111,8 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc doc/* run/mailer
 %attr(755,root,root) %{_bindir}/*
+%if %{do_mmxfb}
+%dir %{_libdir}/john
+%attr(755,root,root) %{_libdir}/john/john-non-mmx
+%endif
 %{_datadir}/john
This page took 0.038383 seconds and 4 git commands to generate.