]> git.pld-linux.org Git - packages/iproute2.git/blobdiff - iproute2.spec
- added ss ("better" netstat) and ifstat utilities to the distribution
[packages/iproute2.git] / iproute2.spec
index a77ffa696a5438e7b1de92a2cca1d7c9bf78b784..fd136f46dcfcd9d420153dd8ae0610e996560604 100644 (file)
@@ -1,23 +1,46 @@
-%define mainver  2.2.4
-%define snapshot ss001007
+#
+# Conditional build
+%bcond_without doc     # don't build documentation
+%bcond_without tc      # don't build tc program (it breaks static linkage)
+%bcond_with    uClibc  # do some hacks to build with uClibc
+#
 Summary:       Utility to control Networking behavior in 2.2.X kernels
+Summary(es):   Herramientas para encaminamiento avanzado y configuración de interfaces de red
 Summary(pl):   Narzêdzie do kontrolowania Sieci w kernelach 2.2
+Summary(pt_BR):        Ferramentas para roteamento avançado e configuração de interfaces de rede
 Name:          iproute2
+%define                mainver         2.4.7
+%define                snapshot        ss020116
 Version:       %{mainver}.%{snapshot}
-Release:       2
-Vendor:                Alexey Kuznetsov <kuznet@ms2.inr.ac.ru>
+Release:       16
 License:       GPL
+Vendor:                Alexey Kuznetsov <kuznet@ms2.inr.ac.ru>
 Group:         Networking/Admin
-Group(pl):     Sieciowe/Administracyjne
 Source0:       ftp://ftp.inr.ac.ru/ip-routing/%{name}-%{mainver}-now-%{snapshot}.tar.gz
-Patch0:                %{name}-make.patch
-Patch1:                %{name}-ll_types.patch
-Patch2:                %{name}-rt_names_h.patch
-Patch3:                %{name}-utils_c.patch
+# Source0-md5: 2c7e5f3a10e703745ecdc613f7a7d187
+Source1:       %{name}-owl-man.tar.bz2
+# Source1-md5: cd4425df972a4ab001db31a5eb1c5da5
+Patch0:                %{name}-Makefile.patch
+Patch1:                %{name}-llh.patch
+Patch2:                %{name}-diffserv-config.patch
+Patch3:                %{name}-netlink.patch
+Patch4:                %{name}-ipaddress.patch
+Patch5:                %{name}-iprule.patch
+# uClibc hacks
+Patch6:                %{name}-uClibc.patch
+# extensions
+Patch10:       htb3.6_tc.patch
+Patch11:       wrr-iproute2-2.2.4.patch
+Patch12:       %{name}-2.2.4-now-ss001007-esfq.diff
+BuildRequires: bison
+BuildRequires: linux-libc-headers >= 7:2.6.4.0-3
+%if %{with doc}
+BuildRequires: psutils
+BuildRequires: sgml-tools
 BuildRequires: tetex-dvips
 BuildRequires: tetex-latex
-BuildRequires: psutils
-%{?BOOT:BuildRequires: uClibc-devel-BOOT}
+BuildRequires: tetex-tex-babel
+%endif
 Obsoletes:     iproute
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -25,81 +48,87 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _sysconfdir     /etc/iproute2
 
 %description
-This package contains the ip, tc and the rtmon tool that allow control
-of routing and other aspects of networking.
+Linux 2.2 maintains compatibility with the basic configuration
+utilities of the network (ifconfig, route) but a new utility is
+required to exploit the new characteristics and features of the
+kernel. This package includes the new utilities.
+
+%description -l es
+Linux mantiene compatibilidad con los utilitarios estándares de
+configuración de la red, pero se necesitan nuevos utilitarios para
+usar los recursos y características del nuevo núcleo. Este paquete
+incluye los nuevos utilitarios.
 
 %description -l pl
 Ten pakiet zawiera programy pozwalaj±ce na kontrolê routingu i innych
 aspektów dotycz±cych sieci.
 
+%description -l pt_BR
+O Linux mantém compatibilidade com os utilitários padrão de
+configuração da rede, mas novos utilitários são necessários para fazer
+uso das características e recursos da nova kernel. This package
+includes the new utilities.
 
-%if %{?BOOT:1}%{!?BOOT:0}
-%package BOOT
-Summary:       Utility to control Networking behavior in 2.2.X kernels
-Summary(pl):   Narzêdzie do kontrolowania Sieci w kernelach 2.2
-Group:         Networking/Admin
-
-%description BOOT
+%package -n libnetlink-devel
+Summary:       Library for the netlink interface
+Summary(pl):   Biblioteka do interfejsu netlink
+Group:         Development/Libraries
 
-%endif
+%description -n libnetlink-devel
+This library provides an interface for kernel-user netlink interface.
 
+%description -n libnetlink-devel -l pl
+Ta biblioteka udostêpnia interfejs do interfejsu netlink miêdzy j±drem
+a przestrzeni± u¿ytkownika.
 
 %prep
-%setup -q -n %{name}
+%setup -q -n %{name} -a1
+rm -rf include-glibc
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
+%patch5 -p1
+%{?with_uClibc:%patch6 -p1}
+%patch10 -p1
+%patch11 -p1
+%patch12 -p1
 
 %build
+%{__make} \
+       CC="%{__cc}" \
+       OPT="%{rpmcflags}" \
+       %{!?with_tc:SUBDIRS="lib ip misc" LDFLAGS="%{rpmldflags}"}
 
-%if %{?BOOT:1}%{!?BOOT:0}
-#%{__make} \
-#      OPT="-Os" GLIBCFIX="" \
-#      KERNEL_INCLUDE="/usr/lib/bootdisk%{_includedir}" \
-#      LDFLAGS="-nostdlib -s"  ADDLIB="inet_ntop.o inet_pton.o" \
-#      LDLIBS="%{_libdir}/bootdisk%{_libdir}/crt0.o %{_libdir}/bootdisk%{_libdir}/libc.a -lgcc"
-
-# there are some problems compiling with uClibc, fallibg back to simple glibc-static
-%{__make} SUBDIRS="lib ip" OPT="-Os" LDFLAGS="-static -s" 
-mv -f ip/ip ip-BOOT
-%{__make} clean
-%endif
-
-%{__make} OPT="%{!?debug:$RPM_OPT_FLAGS}%{?debug:-g -O0}"
-%{__make} -C doc
-
-
+%{?with_doc:%{__make} -C doc}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%if %{?BOOT:1}%{!?BOOT:0}
-install -d $RPM_BUILD_ROOT%{_libdir}/bootdisk/bin
-install -s ip-BOOT $RPM_BUILD_ROOT%{_libdir}/bootdisk/bin/ip
-%endif
+install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir},%{_mandir}/man8,%{_libdir},%{_includedir}}
 
-install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}}
-install ip/{ip,rtmon,rtacct,routel} tc/tc $RPM_BUILD_ROOT%{_sbindir}
+install ip/{ip,rtmon,routel} %{?with_tc:tc/tc} misc/{rtacct,rtstat,ss,ifstat} $RPM_BUILD_ROOT%{_sbindir}
 install etc/iproute2/rt_protos \
        etc/iproute2/rt_realms \
        etc/iproute2/rt_scopes \
        etc/iproute2/rt_tables \
        $RPM_BUILD_ROOT%{_sysconfdir}
-
-gzip -9nf READ* RELNOTES doc/*.ps
+install man/*  $RPM_BUILD_ROOT%{_mandir}/man8
+install lib/libnetlink.a $RPM_BUILD_ROOT%{_libdir}
+install include/libnetlink.h $RPM_BUILD_ROOT%{_includedir}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc {README,README.iproute2+tc,RELNOTES}.gz
-%doc doc/*.ps.gz
+%doc README README.iproute2+tc RELNOTES %{?with_doc:doc/*.ps}
 %attr(755,root,root) %{_sbindir}/*
-%{_sysconfdir}
+%dir %{_sysconfdir}
+%config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/*
+%{_mandir}/man8/*
 
-%if %{?BOOT:1}%{!?BOOT:0}
-%files BOOT
+%files -n libnetlink-devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/bootdisk/bin/*
-%endif
+%{_libdir}/lib*.a
+%{_includedir}/*.h
This page took 0.068208 seconds and 4 git commands to generate.