]> git.pld-linux.org Git - packages/iproute2.git/blobdiff - iproute2.spec
- up to 2.6.16
[packages/iproute2.git] / iproute2.spec
index b6cc818f31a2e8b5c95c2685e404671ca530a6a4..69f2731c668fbb7d87bc8e840481bab7c1343012 100644 (file)
@@ -1,59 +1,64 @@
 #
+# TODO:
+#      - fix build @ uClibc
+#
 # Conditional build
-%bcond_without doc     # don't build documentation
-%bcond_without tc      # don't build tc program (it breaks static linkage)
-%bcond_with    uClibc  # do some hacks to build with uClibc
+%bcond_without doc             # don't build documentation
+%bcond_without tc              # don't build tc program (it breaks static linkage)
+%bcond_without atm             # don't required ATM.
+%bcond_with    uClibc          # do some hacks to build with uClibc
 #
-Summary:       Utility to control Networking behavior in 2.2.X kernels
+Summary:       Utility to control Networking behavior in.X kernels
 Summary(es):   Herramientas para encaminamiento avanzado y configuración de interfaces de red
-Summary(pl):   Narzêdzie do kontrolowania Sieci w kernelach 2.2
+Summary(pl):   Narzêdzie do kontrolowania Sieci w kernelach
 Summary(pt_BR):        Ferramentas para roteamento avançado e configuração de interfaces de rede
 Name:          iproute2
-%define                mainver         2.4.7
-%define                snapshot        ss020116
-Version:       %{mainver}.%{snapshot}
-Release:       17
+%define        sdate   060323
+# do not use ,,2.6.X'' as version here, put whole number like 2.6.8
+Version:       2.6.16
+Release:       1
 License:       GPL
-Vendor:                Alexey Kuznetsov <kuznet@ms2.inr.ac.ru>
+Vendor:                Stephen Hemminger <shemminger@osdl.org>
 Group:         Networking/Admin
-Source0:       ftp://ftp.inr.ac.ru/ip-routing/%{name}-%{mainver}-now-%{snapshot}.tar.gz
-# Source0-md5: 2c7e5f3a10e703745ecdc613f7a7d187
-Source1:       %{name}-owl-man.tar.bz2
-# Source1-md5: cd4425df972a4ab001db31a5eb1c5da5
-Patch0:                %{name}-llh.patch
-Patch1:                %{name}-Makefile.patch
-Patch2:                %{name}-diffserv-config.patch
-Patch3:                %{name}-netlink.patch
-Patch4:                %{name}-ipaddress.patch
-Patch5:                %{name}-iprule.patch
-# uClibc hacks
-Patch6:                %{name}-uClibc.patch
+Source0:       http://developer.osdl.org/dev/iproute2/download/%{name}-%{version}-%{sdate}.tar.gz
+# Source0-md5: f31d4516b35bbfeaa72c762f5959e97c
+Patch0:                %{name}-build.patch
+Patch1:                %{name}-arp.patch
+Patch2:                %{name}-lex.patch
+Patch3:                %{name}-iptables.patch
+Patch4:                %{name}-iptables64.patch
 # extensions
-Patch10:       %{name}-htb3.6_tc.patch
-Patch11:       %{name}-2.2.4-wrr.patch
-Patch12:       %{name}-2.2.4-esfq.patch
-Patch13:       %{name}-hfsc.patch
+Patch10:       %{name}-2.2.4-wrr.patch
+Patch11:       esfq-%{name}.patch
+URL:           http://linux-net.osdl.org/index.php/Iproute2
 BuildRequires: bison
-BuildRequires: linux-libc-headers >= 7:2.6.5.1-1
+BuildRequires: db-devel
+BuildRequires: flex
+%if %{with atm}
+BuildRequires: linux-atm-devel
+%endif
+BuildRequires: linux-libc-headers >= 7:2.6.12.0-13
 %if %{with doc}
 BuildRequires: psutils
 BuildRequires: sgml-tools
 BuildRequires: tetex-dvips
-BuildRequires: tetex-latex
+BuildRequires: tetex-fonts-jknappen
+BuildRequires: tetex-format-latex
+BuildRequires: tetex-metafont
 BuildRequires: tetex-tex-babel
 %endif
 Obsoletes:     iproute
-Conflicts:     ifstat
+Obsoletes:     ifstat
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _sbindir        /sbin
 %define                _sysconfdir     /etc/iproute2
 
 %description
-Linux 2.2 maintains compatibility with the basic configuration
-utilities of the network (ifconfig, route) but a new utility is
-required to exploit the new characteristics and features of the
-kernel. This package includes the new utilities.
+Linux maintains compatibility with the basic configuration utilities
+of the network (ifconfig, route) but a new utility is required to
+exploit the new characteristics and features of the kernel. This
+package includes the new utilities.
 
 %description -l es
 Linux mantiene compatibilidad con los utilitarios estándares de
@@ -84,23 +89,22 @@ Ta biblioteka udost
 a przestrzeni± u¿ytkownika.
 
 %prep
-%setup -q -n %{name} -a1
-rm -rf include-glibc
+%setup -q -n %{name}-%{version}-%{sdate}
+rm -rf include-glibc include/linux
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
+%ifarch "%{_lib}" == "lib64"
 %patch4 -p1
-%patch5 -p1
-%{?with_uClibc:%patch6 -p1}
+%else
+%patch3 -p1
+%endif
 %patch10 -p1
 %patch11 -p1
-%patch12 -p1
-%patch13 -p1
 
 %build
 %{__make} \
-       CC="%{__cc}" \
+       %{?with_uClibc:CC="%{_target_cpu}-uclibc-gcc"}%{!?with_uClibc:CC="%{__cc}"} \
        OPT="%{rpmcflags}" \
        %{!?with_tc:SUBDIRS="lib ip misc" LDFLAGS="%{rpmldflags}"}
 
@@ -110,13 +114,17 @@ rm -rf include-glibc
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir},%{_mandir}/man8,%{_libdir},%{_includedir}}
 
-install ip/{ip,rtmon,routel} %{?with_tc:tc/tc} misc/{rtacct,rtstat,ss,ifstat} $RPM_BUILD_ROOT%{_sbindir}
+install ip/{ip,rtmon,routel} %{?with_tc:tc/tc} misc/{ifstat,lnstat,nstat,rtacct,ss} $RPM_BUILD_ROOT%{_sbindir}
 install etc/iproute2/rt_protos \
        etc/iproute2/rt_realms \
        etc/iproute2/rt_scopes \
        etc/iproute2/rt_tables \
        $RPM_BUILD_ROOT%{_sysconfdir}
-install man/*  $RPM_BUILD_ROOT%{_mandir}/man8
+
+install man/man8/*     $RPM_BUILD_ROOT%{_mandir}/man8
+echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-bfifo.8
+echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-pfifo.8
+
 install lib/libnetlink.a $RPM_BUILD_ROOT%{_libdir}
 install include/libnetlink.h $RPM_BUILD_ROOT%{_includedir}
 
@@ -125,10 +133,11 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README README.iproute2+tc RELNOTES %{?with_doc:doc/*.ps}
+%doc README README.decnet README.iproute2+tc README.lnstat RELNOTES
+%doc ChangeLog %{?with_doc:doc/*.ps}
 %attr(755,root,root) %{_sbindir}/*
 %dir %{_sysconfdir}
-%config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/*
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
 %{_mandir}/man8/*
 
 %files -n libnetlink-devel
This page took 0.079778 seconds and 4 git commands to generate.