]> git.pld-linux.org Git - packages/iproute2.git/blobdiff - iproute2.spec
- up to 2.6.16
[packages/iproute2.git] / iproute2.spec
index 977d71b43e6ecd0f946ce3a034fff379a2c0b030..69f2731c668fbb7d87bc8e840481bab7c1343012 100644 (file)
@@ -1,59 +1,64 @@
 #
+# TODO:
+#      - fix build @ uClibc
+#
 # Conditional build
-%bcond_without tetex   # don't build documentation
-%bcond_without tc      # don't build tc program (it breaks static linkage)
-%bcond_without tc_esfq # build tc without esfq support (requires patched headers)
-%bcond_without tc_wrr  # build tc without wrr support
-%bcond_with    uClibc  # do some hacks to build with uClibc
-
-Summary:       Utility to control Networking behavior in 2.2.X kernels
+%bcond_without doc             # don't build documentation
+%bcond_without tc              # don't build tc program (it breaks static linkage)
+%bcond_without atm             # don't required ATM.
+%bcond_with    uClibc          # do some hacks to build with uClibc
+#
+Summary:       Utility to control Networking behavior in.X kernels
 Summary(es):   Herramientas para encaminamiento avanzado y configuración de interfaces de red
-Summary(pl):   Narzêdzie do kontrolowania Sieci w kernelach 2.2
+Summary(pl):   Narzêdzie do kontrolowania Sieci w kernelach
 Summary(pt_BR):        Ferramentas para roteamento avançado e configuração de interfaces de rede
 Name:          iproute2
-%define mainver        2.4.7
-%define snapshot ss020116
-Version:       %{mainver}.%{snapshot}
-Release:       14
+%define        sdate   060323
+# do not use ,,2.6.X'' as version here, put whole number like 2.6.8
+Version:       2.6.16
+Release:       1
 License:       GPL
-Vendor:                Alexey Kuznetsov <kuznet@ms2.inr.ac.ru>
+Vendor:                Stephen Hemminger <shemminger@osdl.org>
 Group:         Networking/Admin
-Source0:       ftp://ftp.inr.ac.ru/ip-routing/%{name}-%{mainver}-now-%{snapshot}.tar.gz
-# Source0-md5: 2c7e5f3a10e703745ecdc613f7a7d187
-Source1:       %{name}-owl-man.tar.bz2
-# Source1-md5: cd4425df972a4ab001db31a5eb1c5da5
-Patch0:                %{name}-make.patch
-Patch1:                %{name}-no_libresolv.patch
-Patch2:                %{name}-disable_arpd.patch
-Patch3:                %{name}-uspace.patch
-Patch4:                %{name}-diffserv-config.patch
-Patch5:                %{name}-netlink.patch
-Patch6:                %{name}-kernellast.patch
-# uClibc hacks
-Patch7:                %{name}-uClibc.patch
-Patch8:                htb3.6_tc.patch
-Patch9:                %{name}-stats.patch
+Source0:       http://developer.osdl.org/dev/iproute2/download/%{name}-%{version}-%{sdate}.tar.gz
+# Source0-md5: f31d4516b35bbfeaa72c762f5959e97c
+Patch0:                %{name}-build.patch
+Patch1:                %{name}-arp.patch
+Patch2:                %{name}-lex.patch
+Patch3:                %{name}-iptables.patch
+Patch4:                %{name}-iptables64.patch
 # extensions
-Patch10:       wrr-iproute2-2.2.4.patch
-Patch11:       %{name}-2.2.4-now-ss001007-esfq.diff
-Patch12:       %{name}-kernel_headers.patch
+Patch10:       %{name}-2.2.4-wrr.patch
+Patch11:       esfq-%{name}.patch
+URL:           http://linux-net.osdl.org/index.php/Iproute2
 BuildRequires: bison
-%{?with_tetex:BuildRequires:   psutils}
-%{?with_tetex:BuildRequires:   sgml-tools}
-%{?with_tetex:BuildRequires:   tetex-dvips}
-%{?with_tetex:BuildRequires:   tetex-latex}
-%{?with_tetex:BuildRequires:   tetex-tex-babel}
+BuildRequires: db-devel
+BuildRequires: flex
+%if %{with atm}
+BuildRequires: linux-atm-devel
+%endif
+BuildRequires: linux-libc-headers >= 7:2.6.12.0-13
+%if %{with doc}
+BuildRequires: psutils
+BuildRequires: sgml-tools
+BuildRequires: tetex-dvips
+BuildRequires: tetex-fonts-jknappen
+BuildRequires: tetex-format-latex
+BuildRequires: tetex-metafont
+BuildRequires: tetex-tex-babel
+%endif
 Obsoletes:     iproute
+Obsoletes:     ifstat
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _sbindir        /sbin
 %define                _sysconfdir     /etc/iproute2
 
 %description
-Linux 2.2 maintains compatibility with the basic configuration
-utilities of the network (ifconfig, route) but a new utility is
-required to exploit the new characteristics and features of the
-kernel. This package includes the new utilities.
+Linux maintains compatibility with the basic configuration utilities
+of the network (ifconfig, route) but a new utility is required to
+exploit the new characteristics and features of the kernel. This
+package includes the new utilities.
 
 %description -l es
 Linux mantiene compatibilidad con los utilitarios estándares de
@@ -84,44 +89,42 @@ Ta biblioteka udost
 a przestrzeni± u¿ytkownika.
 
 %prep
-%setup -q -n %{name} -a1
+%setup -q -n %{name}-%{version}-%{sdate}
+rm -rf include-glibc include/linux
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
-%patch3 -p1
+%ifarch "%{_lib}" == "lib64"
 %patch4 -p1
-%patch5 -p1
-%patch6 -p1
-%{?with_uClibc:%patch7 -p1}
-%patch8 -p1
-%patch9 -p1
-%{?with_tc_wrr:%patch10 -p1}
-%{?with_tc_esfq:%patch11 -p1}
-%patch12 -p1
+%else
+%patch3 -p1
+%endif
+%patch10 -p1
+%patch11 -p1
 
 %build
-WRRDEF=""
-%{?with_tc_wrr:grep -q tc_wrr_class_weight kernel-headers/linux/pkt_sched.h || WRRDEF="-DNEED_WRR_DEFS"}
-
 %{__make} \
-       CC="%{__cc}" \
-       OPT="%{rpmcflags} ${WRRDEF}" \
-       KERNEL_INCLUDE="`pwd`/kernel-headers" \
+       %{?with_uClibc:CC="%{_target_cpu}-uclibc-gcc"}%{!?with_uClibc:CC="%{__cc}"} \
+       OPT="%{rpmcflags}" \
        %{!?with_tc:SUBDIRS="lib ip misc" LDFLAGS="%{rpmldflags}"}
 
-%{?with_tetex:%{__make} -C doc}
+%{?with_doc:%{__make} -C doc}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir},%{_mandir}/man8,%{_libdir},%{_includedir}}
 
-install ip/{ip,rtmon,routel} %{?with_tc:tc/tc} misc/{rtacct,rtstat} $RPM_BUILD_ROOT%{_sbindir}
+install ip/{ip,rtmon,routel} %{?with_tc:tc/tc} misc/{ifstat,lnstat,nstat,rtacct,ss} $RPM_BUILD_ROOT%{_sbindir}
 install etc/iproute2/rt_protos \
        etc/iproute2/rt_realms \
        etc/iproute2/rt_scopes \
        etc/iproute2/rt_tables \
        $RPM_BUILD_ROOT%{_sysconfdir}
-install man/*  $RPM_BUILD_ROOT%{_mandir}/man8
+
+install man/man8/*     $RPM_BUILD_ROOT%{_mandir}/man8
+echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-bfifo.8
+echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-pfifo.8
+
 install lib/libnetlink.a $RPM_BUILD_ROOT%{_libdir}
 install include/libnetlink.h $RPM_BUILD_ROOT%{_includedir}
 
@@ -130,10 +133,11 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README README.iproute2+tc RELNOTES %{?with_tetex:doc/*.ps}
+%doc README README.decnet README.iproute2+tc README.lnstat RELNOTES
+%doc ChangeLog %{?with_doc:doc/*.ps}
 %attr(755,root,root) %{_sbindir}/*
 %dir %{_sysconfdir}
-%config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/*
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
 %{_mandir}/man8/*
 
 %files -n libnetlink-devel
This page took 0.056591 seconds and 4 git commands to generate.