]> git.pld-linux.org Git - packages/iproute2.git/blobdiff - iproute2.spec
- new (enable diffserv; use userspace headers)
[packages/iproute2.git] / iproute2.spec
index efe9be2cf3f45db80512beb98333911ac82c82dd..403f091cfb591f37c6cdcc39fd42ecee53539702 100644 (file)
@@ -1,22 +1,48 @@
-%define mainver  2.4.7
-%define snapshot ss010803
+#
+# Conditional build
+# _without_tetex       - don't build documentation
+# _without_tc          - don't build tc program (it breaks static linkage)
+# _without_tc_esfq     - build tc without esfq support (requires patched headers)
+#
+%define                _kernel24       %(echo %{_kernel_ver} | grep -q '2\.[012]\.' ; echo $?)
+%define mainver                2.4.7
+%define snapshot       ss020116
 Summary:       Utility to control Networking behavior in 2.2.X kernels
+Summary(es):   Herramientas para encaminamiento avanzado y configuración de interfaces de red
 Summary(pl):   Narzêdzie do kontrolowania Sieci w kernelach 2.2
+Summary(pt_BR):        Ferramentas para roteamento avançado e configuração de interfaces de rede
 Name:          iproute2
 Version:       %{mainver}.%{snapshot}
-Release:       1
-Vendor:                Alexey Kuznetsov <kuznet@ms2.inr.ac.ru>
+%define _rel    11
+Release:       %{_rel}@%{_kernel_ver_str}
 License:       GPL
+Vendor:                Alexey Kuznetsov <kuznet@ms2.inr.ac.ru>
 Group:         Networking/Admin
-Group(de):     Netzwerkwesen/Administration
-Group(pl):     Sieciowe/Administracyjne
 Source0:       ftp://ftp.inr.ac.ru/ip-routing/%{name}-%{mainver}-now-%{snapshot}.tar.gz
+# Source0-md5: 2c7e5f3a10e703745ecdc613f7a7d187
+Source1:       %{name}-owl-man.tar.bz2
+# Source1-md5: cd4425df972a4ab001db31a5eb1c5da5
 Patch0:                %{name}-make.patch
-%{?BOOT:Patch1:        %{name}-uClibc.patch}
-BuildRequires: tetex-dvips
-BuildRequires: tetex-latex
-BuildRequires: psutils
-%{?BOOT:BuildRequires: uClibc-devel-BOOT}
+Patch1:                %{name}-uClibc.patch
+Patch2:                %{name}-fix-2_2.patch
+Patch3:                %{name}-label.patch
+Patch4:                %{name}-latest.patch
+Patch5:                %{name}-htb2_tc.patch
+Patch6:                wrr-iproute2-2.2.4.patch
+Patch7:                htb3.6_tc.patch
+Patch8:                %{name}-no_libresolv.patch
+Patch9:                %{name}-2.2.4-now-ss001007-esfq.diff
+Patch10:       %{name}-stats.patch
+Patch11:       %{name}-disable_arpd.patch
+Patch100:      %{name}-2.6.0-t7-test.patch
+
+BuildRequires: bison
+%{!?_without_tetex:BuildRequires:      latex2html}
+%{!?_without_tetex:BuildRequires:      psutils}
+%{!?_without_tetex:BuildRequires:      sgml-tools}
+%{!?_without_tetex:BuildRequires:      tetex-dvips}
+%{!?_without_tetex:BuildRequires:      tetex-latex}
+%{!?_without_tetex:BuildRequires:      tetex-tex-babel}
 Obsoletes:     iproute
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -24,94 +50,97 @@ BuildRoot:  %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                _sysconfdir     /etc/iproute2
 
 %description
-This package contains the ip, tc and the rtmon tool that allow control
-of routing and other aspects of networking.
+Linux 2.2 maintains compatibility with the basic configuration
+utilities of the network (ifconfig, route) but a new utility is
+required to exploit the new characteristics and features of the
+kernel. This package includes the new utilities.
+
+%description -l es
+Linux mantiene compatibilidad con los utilitarios estándares de
+configuración de la red, pero se necesitan nuevos utilitarios para
+usar los recursos y características del nuevo núcleo. Este paquete
+incluye los nuevos utilitarios.
 
 %description -l pl
 Ten pakiet zawiera programy pozwalaj±ce na kontrolê routingu i innych
 aspektów dotycz±cych sieci.
 
+%description -l pt_BR
+O Linux mantém compatibilidade com os utilitários padrão de
+configuração da rede, mas novos utilitários são necessários para fazer
+uso das características e recursos da nova kernel. This package
+includes the new utilities.
 
-%if %{?BOOT:1}%{!?BOOT:0}
-%package BOOT
-Summary:       Utility to control Networking behavior in 2.2.X kernels
-Summary(pl):   Narzêdzie do kontrolowania Sieci w kernelach 2.2
-Group:         Networking/Admin
-Group(de):     Netzwerkwesen/Administration
-Group(pl):     Sieciowe/Administracyjne
-
-%description BOOT
+%package -n libnetlink-devel
+Summary:       Library for the netlink interface
+Summary(pl):   Biblioteka do interfejsu netlink
+Group:         Development/Libraries
 
-%endif
+%description -n libnetlink-devel
+This library provides an interface for kernel-user netlink interface.
 
+%description -n libnetlink-devel -l pl
+Ta biblioteka udostêpnia interfejs do interfejsu netlink miêdzy j±drem
+a przestrzeni± u¿ytkownika.
 
 %prep
-%setup -q -n %{name}
+%setup -q -n %{name} -a1
 %patch0 -p1
-%{?BOOT:%patch1 -p1}
+%patch1 -p1
+%patch2 -p1
+#%%patch3 -p1
+#%%patch4 -p1
+%if %{_kernel24}
+%patch7 -p1
+%patch10 -p1
+%else
+%patch5 -p1
+%endif
+%patch6 -p1
+%patch8 -p1
+%{!?_without_tc_esfq:%patch9 -p1}
+%patch11 -p1
+
+#%patch100 -p1
 
 %build
+WRRDEF=""
+grep -q tc_wrr_class_weight %{_kernelsrcdir}/include/linux/pkt_sched.h || WRRDEF="-DNEED_WRR_DEFS"
 
-%if %{?BOOT:1}%{!?BOOT:0}
 %{__make} \
-       OPT="-m386 -Os" GLIBCFIX="" \
+       CC="%{__cc}" \
+       OPT="%{rpmcflags} ${WRRDEF}" \
        KERNEL_INCLUDE="%{_kernelsrcdir}/include" \
-       OPT="-I%{_libdir}/bootdisk%{_includedir}" \
-       LDFLAGS="-nostdlib -static -s" \
-       LDLIBS="%{_libdir}/bootdisk%{_libdir}/crt0.o %{_libdir}/bootdisk%{_libdir}/libc.a -lgcc" \
-       ADDLIB="inet_ntop.o inet_pton.o dnet_ntop.o dnet_pton.o ipx_ntop.o ipx_pton.o" \
-       SUBDIRS="lib ip"
-
-# there are some problems compiling with uClibc, falling back to simple glibc-static
-%{__make} \
-       SUBDIRS="lib ip" \
-       OPT="-Os" \
-       LDFLAGS="-static -s" \
-       KERNEL_INCLUDE="%{_kernelsrcdir}/include"
-mv -f ip/ip ip-BOOT
-mv -f ip/rtacct rtacct-BOOT
-mv -f ip/rtmon rtmon-BOOT
-%{__make} clean
-%endif
-
-%{__make} \
-       OPT="%{rpmcflags}" \
-       KERNEL_INCLUDE="%{_kernelsrcdir}/include"
-%{__make} -C doc
-
-
+       LDFLAGS="%{rpmldflags}" \
+       %{?_without_tc:SUBDIRS="lib ip misc"}
+%{!?_without_tetex:%{__make} -C doc}
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%if %{?BOOT:1}%{!?BOOT:0}
-install -d $RPM_BUILD_ROOT%{_libdir}/bootdisk/sbin
-# we need only 'ip' on bootdisk (don't we??)
-install ip-BOOT $RPM_BUILD_ROOT%{_libdir}/bootdisk/sbin/ip
-%endif
+install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir},%{_mandir}/man8,%{_libdir},%{_includedir}}
 
-install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir}}
-install ip/{ip,rtmon,rtacct,routel} tc/tc $RPM_BUILD_ROOT%{_sbindir}
+install ip/{ip,rtmon,routel} %{!?_without_tc:tc/tc} misc/{rtacct,rtstat} $RPM_BUILD_ROOT%{_sbindir}
 install etc/iproute2/rt_protos \
        etc/iproute2/rt_realms \
        etc/iproute2/rt_scopes \
        etc/iproute2/rt_tables \
        $RPM_BUILD_ROOT%{_sysconfdir}
-
-gzip -9nf READ* RELNOTES doc/*.ps
+install man/*  $RPM_BUILD_ROOT%{_mandir}/man8
+install lib/libnetlink.a $RPM_BUILD_ROOT%{_libdir}
+install include/libnetlink.h $RPM_BUILD_ROOT%{_includedir}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc {README,README.iproute2+tc,RELNOTES}.gz
-%doc doc/*.ps.gz
+%doc README README.iproute2+tc RELNOTES %{!?_without_tetex:doc/*.ps}
 %attr(755,root,root) %{_sbindir}/*
 %dir %{_sysconfdir}
 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/*
+%{_mandir}/man8/*
 
-%if %{?BOOT:1}%{!?BOOT:0}
-%files BOOT
+%files -n libnetlink-devel
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_libdir}/bootdisk/sbin/*
-%endif
+%{_libdir}/lib*.a
+%{_includedir}/*.h
This page took 0.039646 seconds and 4 git commands to generate.