]> git.pld-linux.org Git - packages/iproute2.git/blobdiff - iproute2.spec
- added iproute2-match-nfmark-in-u32.patch
[packages/iproute2.git] / iproute2.spec
index e7624659059a44c9d6ac081805f24f1858311871..381eab2a064f0ebd0980eaa6cea1794682ae6c31 100644 (file)
@@ -1,55 +1,61 @@
 #
+# TODO:
+#      - fix build @ uClibc
+#      - remove -DCONFIG_CLS_U32_PERF=1 when llh will be fixed
+#
 # Conditional build
-%bcond_without doc     # don't build documentation
-%bcond_without tc      # don't build tc program (it breaks static linkage)
-%bcond_with    uClibc  # do some hacks to build with uClibc
+%bcond_without doc             # don't build documentation
+%bcond_without tc              # don't build tc program (it breaks static linkage)
+%bcond_without atm             # don't required ATM.
+%bcond_with    uClibc          # do some hacks to build with uClibc
+%bcond_with    iec_complaint   # fix bitrate calculations
 #
-Summary:       Utility to control Networking behavior in 2.2.X kernels
+Summary:       Utility to control Networking behavior in.X kernels
 Summary(es):   Herramientas para encaminamiento avanzado y configuración de interfaces de red
-Summary(pl):   Narzêdzie do kontrolowania Sieci w kernelach 2.2
+Summary(pl):   Narzêdzie do kontrolowania Sieci w kernelach
 Summary(pt_BR):        Ferramentas para roteamento avançado e configuração de interfaces de rede
 Name:          iproute2
-%define                mainver         2.4.7
-%define                snapshot        ss020116
-Version:       %{mainver}.%{snapshot}
-Release:       16
+%define        sdate   041019
+# do not use ,,2.6.X'' as version here, put whole number like 2.6.8
+Version:       2.6.9
+Release:       0.1
 License:       GPL
-Vendor:                Alexey Kuznetsov <kuznet@ms2.inr.ac.ru>
+Vendor:                Stephen Hemminger <shemminger@osdl.org>
 Group:         Networking/Admin
-Source0:       ftp://ftp.inr.ac.ru/ip-routing/%{name}-%{mainver}-now-%{snapshot}.tar.gz
-# Source0-md5: 2c7e5f3a10e703745ecdc613f7a7d187
-Source1:       %{name}-owl-man.tar.bz2
-# Source1-md5: cd4425df972a4ab001db31a5eb1c5da5
-Patch0:                %{name}-Makefile.patch
-Patch1:                %{name}-llh.patch
-Patch2:                %{name}-diffserv-config.patch
-Patch3:                %{name}-netlink.patch
-Patch4:                %{name}-ipaddress.patch
-Patch5:                %{name}-iprule.patch
-# uClibc hacks
-Patch6:                %{name}-uClibc.patch
+Source0:       http://developer.osdl.org/dev/iproute2/download/%{name}-%{version}-%{sdate}.tar.gz
+# Source0-md5: 4b3f335b0139cb909c6a2ae8bf72e548
+Patch0:         %{name}-build.patch
+Patch1:                %{name}-arp.patch
 # extensions
-Patch10:       %{name}-htb3.6_tc.patch
-Patch11:       %{name}-2.2.4-wrr.patch
-Patch12:       %{name}-2.2.4-esfq.patch
-Patch13:       %{name}-hfsc.patch
+Patch10:        %{name}-2.2.4-wrr.patch
+Patch11:        %{name}-2.2.4-esfq.patch
+Patch13:        %{name}-rates-1024-fix.patch
+Patch14:        %{name}-match-nfmark-in-u32.patch
+URL:           http://developer.osdl.org/dev/iproute2/
 BuildRequires: bison
-BuildRequires: linux-libc-headers >= 7:2.6.4.0-3
+BuildRequires: db-devel
+%if %{with atm}
+BuildRequires: linux-atm-devel
+%endif
+BuildRequires: linux-libc-headers >= 7:2.6.7.0-9
 %if %{with doc}
 BuildRequires: psutils
 BuildRequires: sgml-tools
 BuildRequires: tetex-dvips
-BuildRequires: tetex-latex
+BuildRequires: tetex-fonts-jknappen
+BuildRequires: tetex-format-latex
+BuildRequires: tetex-metafont
 BuildRequires: tetex-tex-babel
 %endif
 Obsoletes:     iproute
+Obsoletes:     ifstat
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _sbindir        /sbin
 %define                _sysconfdir     /etc/iproute2
 
 %description
-Linux 2.2 maintains compatibility with the basic configuration
+Linux maintains compatibility with the basic configuration
 utilities of the network (ifconfig, route) but a new utility is
 required to exploit the new characteristics and features of the
 kernel. This package includes the new utilities.
@@ -83,24 +89,22 @@ Ta biblioteka udost
 a przestrzeni± u¿ytkownika.
 
 %prep
-%setup -q -n %{name} -a1
+%setup -q
 rm -rf include-glibc
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
-%patch3 -p1
-%patch4 -p1
-%patch5 -p1
-%{?with_uClibc:%patch6 -p1}
+
 %patch10 -p1
 %patch11 -p1
-%patch12 -p1
-%patch13 -p1
+%{?with_iec_complaint:%patch13 -p1}
+%patch14 -p1
 
 %build
+rm -rf include/linux
+
 %{__make} \
-       CC="%{__cc}" \
-       OPT="%{rpmcflags}" \
+       %{?with_uClibc:CC="%{_target_cpu}-uclibc-gcc"}%{!?with_uClibc:CC="%{__cc}"} \
+       OPT="%{rpmcflags} -DCONFIG_CLS_U32_PERF=1" \
        %{!?with_tc:SUBDIRS="lib ip misc" LDFLAGS="%{rpmldflags}"}
 
 %{?with_doc:%{__make} -C doc}
@@ -109,13 +113,17 @@ rm -rf include-glibc
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir},%{_mandir}/man8,%{_libdir},%{_includedir}}
 
-install ip/{ip,rtmon,routel} %{?with_tc:tc/tc} misc/{rtacct,rtstat,ss,ifstat} $RPM_BUILD_ROOT%{_sbindir}
+install ip/{ip,rtmon,routel} %{?with_tc:tc/tc} misc/{ifstat,lnstat,nstat,rtacct,ss} $RPM_BUILD_ROOT%{_sbindir}
 install etc/iproute2/rt_protos \
        etc/iproute2/rt_realms \
        etc/iproute2/rt_scopes \
        etc/iproute2/rt_tables \
        $RPM_BUILD_ROOT%{_sysconfdir}
-install man/*  $RPM_BUILD_ROOT%{_mandir}/man8
+
+install man/man8/*     $RPM_BUILD_ROOT%{_mandir}/man8
+echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-bfifo.8
+echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-pfifo.8
+
 install lib/libnetlink.a $RPM_BUILD_ROOT%{_libdir}
 install include/libnetlink.h $RPM_BUILD_ROOT%{_includedir}
 
This page took 0.059918 seconds and 4 git commands to generate.