]> git.pld-linux.org Git - packages/iproute2.git/blobdiff - iproute2.spec
- fix BR
[packages/iproute2.git] / iproute2.spec
index 01ca6af31349f04c3ee1596e224b824061cddfae..13f6870e108455303018c08712f483fc69aa0f4f 100644 (file)
@@ -1,44 +1,47 @@
-# conditional build
-# --without tetex
-# --without tc (don't build tc program, it break static linkage)
-# --without dist_kernel
-
-%define                _kernel24       %(echo %{_kernel_ver} | grep -q '2\.[012]\.' ; echo $?)
-%define mainver                2.4.7
-%define snapshot       ss020116
-Summary:       Utility to control Networking behavior in 2.2.X kernels
+#
+# TODO:
+#      - build @ uClibc
+#
+# Conditional build
+%bcond_without doc             # don't build documentation
+%bcond_without tc              # don't build tc program (it breaks static linkage)
+%bcond_with    uClibc          # do some hacks to build with uClibc
+%bcond_with    iec_complaint   # fix bitrate calculations
+#
+Summary:       Utility to control Networking behavior in.X kernels
 Summary(es):   Herramientas para encaminamiento avanzado y configuración de interfaces de red
-Summary(pl):   Narzêdzie do kontrolowania Sieci w kernelach 2.2
+Summary(pl):   Narzêdzie do kontrolowania Sieci w kernelach
 Summary(pt_BR):        Ferramentas para roteamento avançado e configuração de interfaces de rede
 Name:          iproute2
-Version:       %{mainver}.%{snapshot}
-%define _rel    10
-Release:        %{_rel}@%{_kernel_ver_str}
+%define        sdate   040608
+Version:       2.6.7
+Release:       0.1
 License:       GPL
-Vendor:                Alexey Kuznetsov <kuznet@ms2.inr.ac.ru>
+Vendor:                Stephen Hemminger <shemminger@osdl.org>
 Group:         Networking/Admin
-Source0:       ftp://ftp.inr.ac.ru/ip-routing/%{name}-%{mainver}-now-%{snapshot}.tar.gz
-Source1:       %{name}-owl-man.tar.bz2
-Patch0:                %{name}-make.patch
-Patch1:                %{name}-uClibc.patch
-Patch2:                %{name}-fix-2_2.patch
-Patch3:                %{name}-label.patch
-Patch4:                %{name}-latest.patch
-Patch5:                %{name}-htb2_tc.patch
-Patch6:                wrr-iproute2-2.2.4.patch
-Patch7:                htb3.6_tc.patch
-Patch8:                %{name}-no_libresolv.patch
-%{!?_without_tetex:BuildRequires:      tetex-dvips}
-%{!?_without_tetex:BuildRequires:      tetex-latex}
-%{!?_without_tetex:BuildRequires:      psutils}
+Source0:       http://developer.osdl.org/dev/iproute2/download/%{name}-%{version}-ss%{sdate}.tar.gz
+# Source0-md5: 28196897deb1a45295cd606bd911a33d
+Patch0:                %{name}-db.patch
+Patch1:                %{name}-arp.patch
+URL:           http://developer.osdl.org/dev/iproute2/
+BuildRequires: bison
+BuildRequires: linux-libc-headers >= 7:2.6.6.0-2
+%if %{with doc}
+BuildRequires: psutils
+BuildRequires: sgml-tools
+BuildRequires: tetex-dvips
+BuildRequires: tetex-latex
+BuildRequires: tetex-tex-babel
+%endif
 Obsoletes:     iproute
+Conflicts:     ifstat
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _sbindir        /sbin
 %define                _sysconfdir     /etc/iproute2
 
 %description
-Linux 2.2 maintains compatibility with the basic configuration
+Linux maintains compatibility with the basic configuration
 utilities of the network (ifconfig, route) but a new utility is
 required to exploit the new characteristics and features of the
 kernel. This package includes the new utilities.
@@ -72,42 +75,33 @@ Ta biblioteka udost
 a przestrzeni± u¿ytkownika.
 
 %prep
-%setup -q -n %{name} -a1
+%setup -q
 %patch0 -p1
 %patch1 -p1
-%patch2 -p1
-#%%patch3 -p1
-#%%patch4 -p1
-%if %{_kernel24}
-%patch7 -p1
-%else
-%patch5 -p1
-%endif
-%patch6 -p1
-%patch8 -p1
 
 %build
-WRRDEF=""
-grep -q tc_wrr_class_weight /usr/include/linux/pkt_sched.h || WRRDEF="-DNEED_WRR_DEFS"
-
 %{__make} \
        CC="%{__cc}" \
-       OPT="%{rpmcflags} ${WRRDEF}" \
-       KERNEL_INCLUDE="%{_kernelsrcdir}/include" \
-       %{?_without_tc:SUBDIRS="lib ip" LDFLAGS="%{rpmldflags}"}
-%{!?_without_tetex:%{__make} -C doc}
+       CCOPTS="-D_GNU_SOURCE %{rpmcflags}" \
+       %{!?with_tc:SUBDIRS="lib ip misc" LDFLAGS="%{rpmldflags}"}
+
+%{?with_doc:%{__make} -C doc}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_sysconfdir},%{_mandir}/man8,%{_libdir},%{_includedir}}
 
-install ip/{ip,rtmon,routel} %{!?_without_tc:tc/tc} $RPM_BUILD_ROOT%{_sbindir}
+install ip/{ip,rtmon,routel} %{?with_tc:tc/tc} misc/{rtacct,rtstat,ss,ifstat} $RPM_BUILD_ROOT%{_sbindir}
 install etc/iproute2/rt_protos \
        etc/iproute2/rt_realms \
        etc/iproute2/rt_scopes \
        etc/iproute2/rt_tables \
        $RPM_BUILD_ROOT%{_sysconfdir}
-install man/*  $RPM_BUILD_ROOT%{_mandir}/man8
+
+install man/man8/*     $RPM_BUILD_ROOT%{_mandir}/man8
+echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-bfifo.8
+echo ".so tc-pbfifo.8" > $RPM_BUILD_ROOT%{_mandir}/man8/tc-pfifo.8
+
 install lib/libnetlink.a $RPM_BUILD_ROOT%{_libdir}
 install include/libnetlink.h $RPM_BUILD_ROOT%{_includedir}
 
@@ -116,8 +110,7 @@ rm -rf $RPM_BUILD_ROOT
 
 %files
 %defattr(644,root,root,755)
-%doc README README.iproute2+tc RELNOTES
-%{!?_without_tetex:%doc doc/*.ps}
+%doc README README.iproute2+tc RELNOTES %{?with_doc:doc/*.ps}
 %attr(755,root,root) %{_sbindir}/*
 %dir %{_sysconfdir}
 %config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/*
@@ -125,5 +118,5 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -n libnetlink-devel
 %defattr(644,root,root,755)
-%{_libdir}/*
-%{_includedir}/*
+%{_libdir}/lib*.a
+%{_includedir}/*.h
This page took 0.037802 seconds and 4 git commands to generate.