]> git.pld-linux.org Git - packages/intel-graphics-compiler.git/blobdiff - intel-graphics-compiler.spec
- fix building with LLVM 12
[packages/intel-graphics-compiler.git] / intel-graphics-compiler.spec
index 3a0676c23175982eabe53ff6f56a8b4901694d03..07beb1df8904f9bcb1004bd62fb533a769282498 100644 (file)
@@ -1,30 +1,33 @@
 
 # requires the OpenCL patches
-%define llvm_version 8.0.1
+%define llvm_version 12.0.0
 
-%define opencl_clang_version 8.0.1
+%define opencl_clang_version 12.0.0
 
 Summary:       The Intel Graphics Compiler for OpenCL
 Name:          intel-graphics-compiler
-Version:       1.0.8
-Release:       3
+Version:       1.0.7423
+Release:       1
 License:       MIT
 Group:         Libraries
 Source0:       https://github.com/intel/intel-graphics-compiler/archive/igc-%{version}/igc-%{version}.tar.gz
-# Source0-md5: 9999fd7b6947b2ed0a11f7b07b1e7acc
+# Source0-md5: a24f432bd43fe1f5ff04a2fa47961ad1
 Patch0:                pkgconfig.patch
 Patch1:                cxx_flags.patch
+Patch2:                missing-header.patch
+Patch3:                llvm12.patch
 URL:           https://github.com/intel/intel-graphics-compiler/
 BuildRequires: llvm-devel >= %{llvm_version}
 BuildRequires: opencl-clang-devel >= %{opencl_clang_version}
 BuildRequires: cmake >= 3.2.0
 BuildRequires: pkgconfig
+BuildRequires: rpmbuild(macros) >= 1.605
 Requires:      %{name}-libs = %{version}-%{release}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
-The Intel Graphics Compiler for OpenCL is an LLVM based compiler for OpenCL
-targeting Intel Gen graphics hardware architecture.
+The Intel Graphics Compiler for OpenCL is an LLVM based compiler for
+OpenCL targeting Intel Gen graphics hardware architecture.
 
 %package libs
 Summary:       The Intel Graphics Compiler for OpenCL libraries
@@ -51,6 +54,10 @@ Pliki nagłówkowe biblioteki %{name}.
 
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
+%patch3 -p1
+
+%{__sed} -i -e 's/-Werror/-Werror -Wno-error=deprecated-declarations/' IGC/CMakeLists.txt
 
 %build
 install -d build
@@ -59,7 +66,8 @@ cd build
        -DCMAKE_BUILD_TYPE=Release \
        -DCMAKE_CXX_FLAGS_RELEASE="${CXXFLAGS:-%{rpmcxxflags} -DNDEBUG -DQT_NO_DEBUG}" \
        -DCCLANG_FROM_SYSTEM=ON \
-       -DIGC_PREFERRED_LLVM_VERSION=%{llvm_version} \
+       -DIGC_OPTION__LLVM_PREFERRED_VERSION=%{llvm_version} \
+       -DIGC_BUILD__VC_ENABLED=OFF \
        ../
 %{__make}
 
@@ -100,7 +108,9 @@ rm -rf $RPM_BUILD_ROOT
 
 %files devel
 %defattr(644,root,root,755)
+%{_includedir}/iga
 %{_includedir}/igc
+%{_includedir}/visa
 %ifarch %{x8664}
 %attr(755,root,root) %{_libdir}/libiga64.so
 %else
This page took 0.340984 seconds and 4 git commands to generate.