]> git.pld-linux.org Git - packages/icewm.git/blobdiff - icewm.spec
- standardize locale dir names (no->nb, zh_TW.Big5->zh_TW)
[packages/icewm.git] / icewm.spec
index 89dae5475c6cbaa8ce5d91bb807ada81832281f2..aae755853de350211972fd63ff2b1189ff1c7c09 100644 (file)
@@ -1,15 +1,14 @@
 #
 # Conditional build:
-# _with_gradients      - enable gradients (implies _with_antialiasing)
-# _without_antialiasing        - disable antialiasing
-# _without_freetype    - disable xfreetype support (implies _without_antialiasing)
-# _without_guievents   - disable guievents
-# _without_gnome       - disable GNOME support
-# _without_imlib       - disable imlib support
+%bcond_with    gradients       # enable gradients (implies with_antialiasing)
+%bcond_without antialiasing    # disable antialiasing
+%bcond_without freetype        # disable xfreetype support (implies !with_antialiasing)
+%bcond_without guievents       # disable guievents
+%bcond_with    gnome           # enable GNOME support
+%bcond_without imlib           # disable imlib support
 #
 # TODO:
 # - make a PLD-theme - default :]
-# - bigger menu-file
 #
 
 Summary:       IceWM X11 Window Manager
@@ -19,13 +18,14 @@ Summary(pt_BR):     Gerenciador de Janelas X11
 Summary(ru):   ïËÏÎÎÙÊ ÍÅÎÅÄÖÅÒ ÄÌÑ X11
 Summary(uk):   ÷¦ËÏÎÎÉÊ ÍÅÎÅÄÖÅÒ ÄÌÑ X11
 Name:          icewm
-Version:       1.2.8
-Release:       1
+Version:       1.2.14
+%define _pre pre9
+Release:       1.%{_pre}.2
 Epoch:         2
 License:       LGPL
 Group:         X11/Window Managers
-Source0:       http://dl.sourceforge.net/icewm/%{name}-%{version}.tar.gz
-# Source0-md5: 8f4e57c875cfe3d612e4ee068a1c2d83
+Source0:       http://dl.sourceforge.net/icewm/%{name}-%{version}%{_pre}.tar.gz
+# Source0-md5: b28db6d83f44d1b440fdae6657970eda
 Source1:       IceWM.desktop
 Source2:       %{name}.directory
 Source3:       http://dl.sourceforge.net/icewm/iceicons-0.6.tar.gz
@@ -34,22 +34,29 @@ Source4:    IceWM.RunWM
 Source5:       IceWM.wm_style
 Source6:       http://dl.sourceforge.net/icewm/netscapeicons-0.2.tar.gz
 # Source6-md5: 409aa9b02adc11309ed546c5120c01d2
+Source7:       %{name}-xsession.desktop
+Patch0:                %{name}-broken-xrandr.patch
+Patch1:                %{name}-home_etc.patch
+Patch2:                %{name}-link_with_g++.patch
+Patch3:                %{name}-showdesktopkey.patch
 URL:           http://www.icewm.org/
 BuildRequires: XFree86-devel
-BuildRequires: autoconf
+BuildRequires: autoconf >= 2.50
 BuildRequires: automake
-%{!?_without_guievents:BuildRequires:  esound-devel}
+%{?with_guievents:BuildRequires:       esound-devel}
 BuildRequires: gettext-devel
-%{!?_without_gnome:BuildRequires:      gnome-libs-devel}
-%{!?_without_imlib:BuildRequires:      imlib-devel}
+%{?with_gnome:BuildRequires:   gnome-desktop-devel}
+%{?with_imlib:BuildRequires:   imlib-devel}
 BuildRequires: libstdc++-devel
-%{!?_without_freetype:BuildRequires:   Xft-devel >= 2.1}
+%{?with_freetype:BuildRequires:        xft-devel >= 2.1}
+BuildRequires: yiff-devel
 Requires(pre): fileutils
 Requires(pre): sh-utils
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %define                _wmstyledir     /etc/sysconfig/wmstyle
 %define                _wmpropsdir     /usr/share/wm-properties
+%define                specflags_ia32  "-fomit-frame-pointer"
 
 %description
 Window Manager for X Window System. Can emulate the look of
@@ -110,25 +117,31 @@ Wszystkie stworzone przez Marko Macka: gtk2, metal2, motif, nice,
 nice2, warp3, warp4, win95.
 
 %prep
-%setup -q
+%setup -q -n %{name}-%{version}%{_pre}
+%patch0 -p1
+%patch1 -p1
+%patch2 -p1
+%patch3 -p1
+
+mv -f po/{no,nb}.po
+mv -f po/{zh_TW.Big5,zh_TW}.po
 
 cd lib/icons
 tar -xzf %{SOURCE3}
 tar -xzf %{SOURCE6}
-cd ../..
 
 %build
-rm -f missing
+cp -f /usr/share/automake/config.sub .
 %{__aclocal}
 %{__autoconf}
 %{__autoheader}
 %configure \
-       %{?_with_gradients:--enable-gradients} \
-       %{!?_without_antialiasing:--enable-antialiasing} \
-       %{?_without_freetype:--disable-xfreetype} \
-       %{!?_without_guievents:--enable-guievents} \
-       %{!?_without_gnome:--with-gnome-menus} \
-       %{?_without_imlib:--without-imlib} \
+       %{?with_gradients:--enable-gradients} \
+       %{?with_antialiasing:--enable-antialiasing} \
+       %{!?with_freetype:--disable-xfreetype} \
+       %{?with_guievents:--enable-guievents} \
+       %{?with_gnome:--enable-menus-gnome} \
+       %{!?with_imlib:--without-imlib} \
        --enable-shaped-decorations \
        --with-cfgdir=%{_sysconfdir}/X11/%{name} \
        --with-docdir=%{_docdir}
@@ -136,23 +149,31 @@ rm -f missing
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{%{_pixmapsdir},%{_wmstyledir}} \
+install -d $RPM_BUILD_ROOT{%{_datadir}/xsessions,%{_pixmapsdir},%{_wmstyledir}} \
        $RPM_BUILD_ROOT{%{_applnkdir}/Settings/IceWM,%{_wmpropsdir},%{_sysconfdir}/X11/%{name}}
 
-%{__make} install DESTDIR=$RPM_BUILD_ROOT
+%{__make} install \
+       DESTDIR=$RPM_BUILD_ROOT
 
 install %{SOURCE1} $RPM_BUILD_ROOT%{_wmpropsdir}
 install %{SOURCE2} $RPM_BUILD_ROOT%{_applnkdir}/Settings/IceWM/.directory
-install %{SOURCE4} $RPM_BUILD_ROOT%{_wmstyledir}/IceWM.sh
-install %{SOURCE5} $RPM_BUILD_ROOT%{_wmstyledir}/IceWM.names
+install %{SOURCE4} $RPM_BUILD_ROOT%{_wmstyledir}/%{name}.sh
+install %{SOURCE5} $RPM_BUILD_ROOT%{_wmstyledir}/%{name}.names
+install %{SOURCE7} $RPM_BUILD_ROOT%{_datadir}/xsessions/%{name}.desktop
 install lib/keys $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/keys
 install lib/preferences $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/preferences
 install lib/toolbar $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/toolbar
 install lib/winoptions $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/winoptions
+echo %{_bindir}/icewmbg > $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/startup
+:> $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/restart
 
 ln -s %{_datadir}/icewm/icons $RPM_BUILD_ROOT%{_pixmapsdir}/icewm
 
-echo "menuprog \"Programs\" %{_datadir}/icewm/icons/folder_16x16.xpm icewm-menu-gnome1 --list \"%{_applnkdir}\"" > $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/menu
+%if %{with gnome}
+echo "menuprog \"Programs\" %{_datadir}/icewm/icons/folder_16x16.xpm icewm-menu-gnome2 --list \"%{_applnkdir}\"" > $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/menu
+%else
+echo "menuprog \"Programs\" %{_datadir}/icewm/icons/folder_16x16.xpm wmconfig --output icewm" > $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/menu
+%endif
 
 %find_lang %{name}
 
@@ -164,10 +185,11 @@ test -h %{_pixmapsdir}/icewm || rm -rf %{_pixmapsdir}/icewm
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc AUTHORS BUGS CHANGES FAQ PLATFORMS README* TODO icewm.lsm doc/*.html
+%doc AUTHORS BUGS CHANGES PLATFORMS README* TODO icewm.lsm doc/*.html
 %attr(755,root,root) %{_bindir}/*
 %dir %{_sysconfdir}/X11/%{name}
-%config(noreplace) %verify(not md5 size mtime) %{_sysconfdir}/X11/%{name}/*
+%config(noreplace,missingok) %verify(not md5 size mtime) %{_sysconfdir}/X11/%{name}/[!rs]*
+%config(noreplace,missingok) %verify(not md5 size mtime) %attr(755,root,root) %{_sysconfdir}/X11/%{name}/[rs]*
 %{_pixmapsdir}/icewm
 %dir %{_datadir}/icewm
 %{_datadir}/icewm/icons
@@ -177,11 +199,12 @@ test -h %{_pixmapsdir}/icewm || rm -rf %{_pixmapsdir}/icewm
 %dir %{_datadir}/icewm/themes
 %{_datadir}/icewm/themes/Infadel2
 %{_datadir}/icewm/themes/icedesert
+%{_datadir}/xsessions/%{name}.desktop
 %dir %{_applnkdir}/Settings/IceWM
 %{_applnkdir}/Settings/IceWM/.directory
 %{_wmpropsdir}/*
-%attr(755,root,root) %{_wmstyledir}/IceWM.sh
-%attr(644,root,root) %{_wmstyledir}/IceWM.names
+%{_wmstyledir}/%{name}.names
+%attr(755,root,root) %{_wmstyledir}/%{name}.sh
 
 %files themes-base
 %defattr(644,root,root,755)
This page took 0.074416 seconds and 4 git commands to generate.