]> git.pld-linux.org Git - packages/icedove.git/blobdiff - icedove.spec
- up to 17.0.7
[packages/icedove.git] / icedove.spec
index e33d071710ffe80eb5316a56d283f579096a013d..d72391577a90abd1a65af481dc367950369ba6f3 100644 (file)
 %undefine      crashreporter
 %endif
 
-%define                enigmail_ver    1.4.2
-%define                nspr_ver        4.9
-%define                nss_ver         3.13.3
+%define                enigmail_ver    1.5.1
+%define                nspr_ver        4.9.3
+%define                nss_ver         3.14.1
 
-%define                xulrunner_ver   2:13.0
+%define                xulrunner_ver   2:17.0
 
 %if %{without xulrunner}
 # The actual sqlite version (see RHBZ#480989):
 Summary:       Icedove - email client
 Summary(pl.UTF-8):     Icedove - klient poczty
 Name:          icedove
-Version:       13.0.1
-Release:       2
+Version:       17.0.7
+Release:       1
 License:       MPL 1.1 or GPL v2+ or LGPL v2.1+
-Group:         X11/Applications/Networking
+Group:         X11/Applications/Mail
 Source0:       http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
-# Source0-md5: 721088faf4bedfd8d7beb6f8295856d1
+# Source0-md5: 31f07c3911d1d6772831195af64db963
 Source1:       http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
-# Source1-md5: ed608e1cd4cd20b96f7f5afdbf081141
+# Source1-md5: 3e71f84ed2c11471282412ebe4f5eb2d
 Source2:       %{name}-branding.tar.bz2
 # Source2-md5: 2da351522bdd7f4a3bd8aaff4c776976
 Source3:       %{name}-rm_nonfree.sh
@@ -48,7 +48,6 @@ Source4:      %{name}.desktop
 Source5:       %{name}.sh
 Patch0:                %{name}-branding.patch
 Patch1:                %{name}-enigmail-shared.patch
-Patch2:                %{name}-system-xulrunner.patch
 Patch3:                %{name}-fonts.patch
 Patch4:                %{name}-install.patch
 Patch5:                %{name}-hunspell.patch
@@ -59,6 +58,9 @@ Patch9:               system-cairo.patch
 Patch10:       %{name}-extensiondir.patch
 Patch11:       crashreporter.patch
 Patch12:       no-subshell.patch
+# Edit patch below and restore --system-site-packages when system virtualenv gets 1.7 upgrade
+Patch13:       system-virtualenv.patch
+Patch14:       gyp-slashism.patch
 URL:           http://www.pld-linux.org/Packages/Icedove
 BuildRequires: GConf2-devel >= 1.2.1
 BuildRequires: alsa-lib-devel
@@ -75,7 +77,9 @@ BuildRequires:        libIDL-devel >= 0.8.0
 %{?with_gnomeui:BuildRequires: libgnome-keyring-devel}
 %{?with_gnomeui:BuildRequires: libgnomeui-devel >= 2.2.0}
 BuildRequires: libiw-devel
+# requires libjpeg-turbo implementing at least libjpeg 6b API
 BuildRequires: libjpeg-devel >= 6b
+BuildRequires: libjpeg-turbo-devel
 BuildRequires: libnotify-devel >= 0.4
 BuildRequires: libpng-devel >= 1.4.1
 BuildRequires: libstdc++-devel
@@ -95,6 +99,7 @@ BuildRequires:        yasm
 BuildRequires: zip
 %if %{with xulrunner}
 BuildRequires: xulrunner-devel >= %{xulrunner_ver}
+BuildRequires: xulrunner-devel < 2:18
 %else
 Requires:      myspell-common
 Requires:      nspr >= 1:%{nspr_ver}
@@ -105,6 +110,7 @@ Requires(post):     mktemp >= 1.5-18
 %if %{with xulrunner}
 %requires_eq_to        xulrunner xulrunner-devel
 %endif
+Requires:      libjpeg-turbo
 Obsoletes:     mozilla-thunderbird
 Obsoletes:     mozilla-thunderbird-dictionary-en-US
 Conflicts:     icedove-lang-resources < %{version}
@@ -184,14 +190,13 @@ Główne możliwości:
 
 %prep
 %setup -qc
-mv comm-release mozilla
+mv comm-esr17 mozilla
 %setup -q -T -D -a2
 cd mozilla
 %{?with_enigmail:%{__gzip} -dc %{SOURCE1} | %{__tar} -xf - -C mailnews/extensions}
 /bin/sh %{SOURCE3}
 %patch0 -p1
 %{?with_enigmail:%patch1 -p1}
-%{?with_xulrunner:%patch2 -p1}
 %patch3 -p1
 %patch4 -p1
 %patch6 -p1
@@ -201,6 +206,8 @@ cd mozilla
 %patch10 -p2
 %patch11 -p2
 %patch12 -p1
+%patch13 -p1
+%patch14 -p1
 
 %build
 cd mozilla
@@ -317,6 +324,7 @@ EOF
 %{__make} -j1 -f client.mk build \
        STRIP="/bin/true" \
        MOZ_MAKE_FLAGS="%{?_smp_mflags}" \
+       XLIBS="-lX11 -lXt" \
        CC="%{__cc}" \
        CXX="%{__cxx}"
 
@@ -430,10 +438,8 @@ cd mozilla/dist/bin
 cp -rfLp chrome/enigmail.jar $ext_dir/chrome
 cp -rfLp components/enig* $ext_dir/components
 cp -rfLp components/libenigmime.so $ext_dir/components
-cp -rfLp components/libipc.so $ext_dir/components
-cp -rfLp components/ipc.xpt $ext_dir/components
 cp -rfLp defaults/preferences/enigmail.js $ext_dir/defaults/preferences
-cp -rfLp modules/{commonFuncs,enigmailCommon,keyManagement,pipeConsole,pipeTransport,subprocess}.jsm $ext_dir/modules
+cp -rfLp modules/{commonFuncs,enigmailCommon,keyManagement,pipeConsole,subprocess}.jsm $ext_dir/modules
 cp -rfLp modules/{subprocess_worker_unix,subprocess_worker_win}.js $ext_dir/modules
 cd -
 cp -p %{topdir}/mozilla/mailnews/extensions/enigmail/package/install.rdf $ext_dir
@@ -487,6 +493,7 @@ exit 0
 %attr(755,root,root) %{_libdir}/%{name}/icedove
 %attr(755,root,root) %{_libdir}/%{name}/register
 %if %{without xulrunner}
+%{_libdir}/%{name}/dependentlibs.list
 %{_libdir}/%{name}/platform.ini
 %{_libdir}/%{name}/greprefs.js
 %attr(755,root,root) %{_libdir}/%{name}/components/*.so
@@ -525,7 +532,6 @@ exit 0
 %exclude %{_datadir}/%{name}/modules/enigmailCommon.jsm
 %exclude %{_datadir}/%{name}/modules/keyManagement.jsm
 %exclude %{_datadir}/%{name}/modules/pipeConsole.jsm
-%exclude %{_datadir}/%{name}/modules/pipeTransport.jsm
 %exclude %{_datadir}/%{name}/modules/subprocess.jsm
 %exclude %{_datadir}/%{name}/modules/subprocess_worker_unix.js
 %exclude %{_datadir}/%{name}/modules/subprocess_worker_win.js
This page took 0.049417 seconds and 4 git commands to generate.