]> git.pld-linux.org Git - packages/icedove.git/blobdiff - icedove.spec
- updated to 3.1.5, fixes CVE-2010-3174, CVE-2010-3175, CVE-2010-3176,
[packages/icedove.git] / icedove.spec
index c7081743dafc10e076e5ada19ee9345ee6f64c0b..a48f3937b364ac0b7339dc23b0b7fb94774888d9 100644 (file)
@@ -2,11 +2,6 @@
 # - separate spec for enigmail
 # - fix icedove (building) and installing nss/nspr libs!
 # - build with system mozldap
-# - about dialog broken:
-#XML Parsing Error: undefined entity
-#Location: chrome://messenger/content/aboutDialog.xul
-#Line Number 27, Column 37:        <description id="copyright">&logoTrademark;</description>
-#------------------------------------^
 #
 # Conditional builds
 %bcond_without enigmail        # don't build enigmail - GPG/PGP support
 Summary:       Icedove - email client
 Summary(pl.UTF-8):     Icedove - klient poczty
 Name:          icedove
-Version:       3.1.2
-Release:       0.10
+Version:       3.1.5
+Release:       1
 License:       MPL 1.1 or GPL v2+ or LGPL v2.1+
 Group:         X11/Applications/Networking
 Source0:       http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/%{version}/source/thunderbird-%{version}.source.tar.bz2
-# Source0-md5: 48e80576a7af70e64d30a5162364525a
+# Source0-md5: 9a75383c7142a9b2487f0ce7e7913824
 Source1:       http://www.mozilla-enigmail.org/download/source/enigmail-%{enigmail_ver}.tar.gz
 # Source1-md5: 7d329d5e8afbbb28214ca1995beb09c9
 Source2:       %{name}-branding.tar.bz2
-# Source2-md5: 85fdf877e2f1bc41329d8086ef5cf0f1
+# Source2-md5: 2da351522bdd7f4a3bd8aaff4c776976
 Source3:       %{name}-rm_nonfree.sh
 Source4:       %{name}.desktop
 Source5:       %{name}.sh
@@ -62,6 +57,7 @@ Patch8:               %{name}-makefile.patch
 Patch9:                %{name}-libpng.patch
 Patch10:       %{name}-extensiondir.patch
 Patch11:       crashreporter.patch
+Patch12:       no-subshell.patch
 URL:           http://www.pld-linux.org/Packages/Icedove
 %{?with_gnomevfs:BuildRequires:        GConf2-devel >= 1.2.1}
 BuildRequires: alsa-lib-devel
@@ -85,12 +81,13 @@ BuildRequires:      nss-devel >= 1:3.12.0
 BuildRequires: pango-devel >= 1:1.1.0
 BuildRequires: pkgconfig
 BuildRequires: sed >= 4.0
-BuildRequires: sqlite3-devel >= 3.6.22
+BuildRequires: sqlite3-devel >= 3.7.2-2
 BuildRequires: startup-notification-devel >= 0.8
 BuildRequires: xorg-lib-libXext-devel
 BuildRequires: xorg-lib-libXinerama-devel
 BuildRequires: xorg-lib-libXt-devel
 BuildRequires: zip
+Requires(post):        mktemp >= 1.5-18
 %if %{with xulrunner}
 %else
 Requires:      myspell-common
@@ -105,12 +102,12 @@ BuildRoot:        %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 %define                filterout_cpp           -D_FORTIFY_SOURCE=[0-9]+
 
 # iceweasel/icedove/iceape provide their own versions
-%define                _noautoreqdep           libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpcom_core.so libxpistub.so
+%define                _noautoreqdep           libgfxpsshar.so libgkgfx.so libgtkxtbin.so libjsj.so libxpcom_compat.so libxpistub.so
 %define                _noautoprovfiles        %{_libdir}/%{name}/components
 # we don't want these to satisfy xulrunner-devel
-%define                _noautoprov             libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
+%define                _noautoprov             libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
 # and as we don't provide them, don't require either
-%define                _noautoreq              libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so
+%define                _noautoreq              libgtkembedmoz.so libmozjs.so libxpcom.so libxul.so libxpcom_core.so
 
 %define                topdir          %{_builddir}/%{name}-%{version}
 %define                objdir          %{topdir}/obj-%{_target_cpu}
@@ -191,6 +188,7 @@ cd mozilla
 %patch9 -p0
 %patch10 -p2
 %patch11 -p2
+%patch12 -p1
 
 %build
 cd mozilla
@@ -380,9 +378,21 @@ ln -s %{name} $RPM_BUILD_ROOT%{_bindir}/mozilla-thunderbird
 cp -a %{SOURCE4} $RPM_BUILD_ROOT%{_desktopdir}/%{name}.desktop
 cp -a %{topdir}/mozilla/icedove/branding/content/icon64.png $RPM_BUILD_ROOT%{_pixmapsdir}/%{name}.png
 
-# files created by regxpcom -register
+# files created by regxpcom -register in post
 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/compreg.dat
 touch $RPM_BUILD_ROOT%{_libdir}/%{name}/components/xpti.dat
+cat << 'EOF' > $RPM_BUILD_ROOT%{_libdir}/%{name}/register
+#!/bin/sh
+umask 022
+# make temporary HOME, as it attempts to touch files in $HOME/.mozilla
+# dangerous if you run this with sudo with keep_env += HOME
+# also TMPDIR could be pointing to sudo user's homedir so we reset that too.
+t=$(mktemp -d)
+rm -f %{_libdir}/%{name}/components/{compreg,xpti}.dat
+TMPDIR= TMP= HOME=$t %{_libdir}/%{name}/icedove -register
+rm -rf $t
+EOF
+chmod a+rx $RPM_BUILD_ROOT%{_libdir}/%{name}/register
 
 %if %{with enigmail}
 ext_dir=$RPM_BUILD_ROOT%{_libdir}/%{name}/extensions/\{847b3a00-7ab1-11d4-8f02-006008948af5\}
@@ -428,6 +438,9 @@ for d in chrome defaults greprefs icons isp modules res; do
 done
 exit 0
 
+%post
+%{_libdir}/%{name}/register || :
+
 %files
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/icedove
@@ -447,6 +460,7 @@ exit 0
 %attr(755,root,root) %{_libdir}/%{name}/*-bin
 %attr(755,root,root) %{_libdir}/%{name}/mozilla-xremote-client
 %attr(755,root,root) %{_libdir}/%{name}/icedove
+%attr(755,root,root) %{_libdir}/%{name}/register
 
 # symlinks
 %{_libdir}/%{name}/chrome
This page took 0.033607 seconds and 4 git commands to generate.