]> git.pld-linux.org Git - packages/hhvm.git/blobdiff - hhvm.spec
up to 3.3.1
[packages/hhvm.git] / hhvm.spec
index d3a3c741aa777a60555dd714602da22eb3ff09b7..4c475305ae9901b65ffe9351036c56aac23f1183 100644 (file)
--- a/hhvm.spec
+++ b/hhvm.spec
@@ -1,37 +1,39 @@
 # NOTES:
 # - hphp/runtime/base/runtime-option.cpp evalJitDefault enables jit if /.hhvm-jit exists (yes, in filesystem root)
+# - patch /usr/lib/hphp/CMake/HPHPIZEFunctions.cmake for %{_libdir}/hhvm as extension dir
 # TODO
 # - system libmbfl, system xhp, sqlite3
-# git show HHVM-3.2.0
-%define                githash 01228273b8cf709aacbd3df1c51b1e690ecebac8
-%define                folly           09a81a9
-%define                thirdparty      2234d64
+# git show HHVM-3.3.1
+%define                githash e0c98e21167b425dddf1fc9efe78c9f7a36db268
+# these hashes are git submodules
+%define                folly           6e46d46
+%define                thirdparty      fdef620
 Summary:       Virtual Machine, Runtime, and JIT for PHP
 Name:          hhvm
-Version:       3.2.0
-Release:       1
-License:       PHP 3.01
+Version:       3.3.1
+Release:       0.1
+License:       PHP 3.01 and BSD
 Group:         Development/Languages
 Source0:       https://github.com/facebook/hhvm/archive/HHVM-%{version}.tar.gz
-# Source0-md5: 791ca8c56d155a71f948387de8859f98
-Source2:       https://github.com/facebook/folly/archive/%{folly}/folly-0.1-%{folly}.tar.gz
-# Source2-md5: 17bc7ee76939cd6a26755588d80313c9
+# Source0-md5: bab9490837ff4f54f295bbcf428d7a1c
+Source2:       https://github.com/facebook/folly/archive/%{folly}/folly-3.2-%{folly}.tar.gz
+# Source2-md5: c4bdbea4c0ffe0650d12d9ff370b8255
 Source3:       https://github.com/hhvm/hhvm-third-party/archive/%{thirdparty}/third_party-%{thirdparty}.tar.gz
-# Source3-md5: 9d40c3fbf1394bb1f03648d7046f8b9c
-Source4:       %{name}-fcgi.init
-Source5:       %{name}-fcgi.sysconfig
+# Source3-md5: 63858096c50c172d6c45ddb3d9b6d721
+Source5:       %{name}-fcgi.init
+Source6:       %{name}-fcgi.sysconfig
+Source7:       php.ini
 Source100:     get-source.sh
-Patch0:                cmake-missing-library.patch
-Patch3:                system-xhp.patch
-Patch4:                system-libafdt.patch
-Patch5:                system-folly.patch
-Patch10:       no-debug.patch
+Patch1:                no-debug.patch
+Patch2:                hphpize.patch
 URL:           https://github.com/facebook/hhvm/wiki
 BuildRequires: ImageMagick-devel
 BuildRequires: a52dec-libs-devel
 BuildRequires: apr-devel
 BuildRequires: autoconf
 BuildRequires: binutils-devel
+# CMake/HPHPFindLibs.cmake:364 - FIND_LIBRARY (BFD_LIB libbfd.a)
+BuildRequires: binutils-static
 BuildRequires: boost-devel >= 1.50
 BuildRequires: cmake >= 2.8.5
 BuildRequires: curl-devel >= 7.29.0
@@ -48,7 +50,7 @@ BuildRequires:        libicu-devel >= 4.2
 #BuildRequires:        libmbfl-devel
 BuildRequires: libmcrypt-devel
 BuildRequires: libmemcached-devel >= 1.0.4
-BuildRequires: libstdc++-devel >= 6:4.3
+BuildRequires: libstdc++-devel >= 6:4.8
 BuildRequires: libunwind-devel
 BuildRequires: libxml2-devel
 BuildRequires: libxslt-devel
@@ -67,13 +69,14 @@ BuildRequires:      zlib-devel
 #BuildRequires:        flex >= 2.5.35
 #BuildRequires:        libafdt-devel >= 0.1.0
 #BuildRequires:        re2c >= 0.13.0
-Provides:      %{name}(api) = %{hhvm_api_version}
 # foreach (get_loaded_extensions() as $ext) printf("Provides:\tphp(%s)\n", strtolower($ext));
+Provides:      %{name}(api) = %{hhvm_api_version}
 Provides:      php(apache)
 Provides:      php(apc)
 Provides:      php(bcmath)
 Provides:      php(bz2)
 Provides:      php(calendar)
+Provides:      php(core) = %{php_version}
 Provides:      php(ctype)
 Provides:      php(curl)
 Provides:      php(date)
@@ -150,7 +153,11 @@ ExclusiveArch:     %{x8664}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 # must be in sync with source. extra check ensuring that it is so is done in %%build
-%define                hhvm_api_version                20140702
+%define                hhvm_api_version        20140829
+# hphp/system/idl/constants.idl.json defines it as 5.6.99-hhvm, but use some saner value
+%define                php_version                     5.6.0
+
+%define                hhvm_extensiondir       %{_libdir}/hhvm
 
 %description
 HHVM (aka the HipHop Virtual Machine) is a new open-source virtual
@@ -216,27 +223,14 @@ mv hhvm-third-party-* third-party
 rmdir third-party/folly/src
 mv folly-* third-party/folly/src
 
-%patch10 -p1
-#%patch5 -p1
+%patch1 -p1
+%patch2 -p1
 
 # prefer ones from system
 rm CMake/FindBISON.cmake
 rm CMake/FindFLEX.cmake
 rm CMake/FindFreetype.cmake
 
-%if 0
-%patch0 -p1
-%patch1 -p1
-#%patch3 -p1
-%patch4 -p1
-
-#rm -rf src/third_party/libmbfl
-#sed -i -e '/add_subdirectory(third_party\/libmbfl)/d' src/CMakeLists.txt
-
-rm -rf src/third_party/xhp
-rm -rf src/third_party/libafdt
-%endif
-
 %build
 # also in: hphp/tools/hphpize/hphpize.cmake
 API=$(awk '/#define HHVM_API_VERSION/{v=$3; sub(/L$/, "", v); print v}' hphp/runtime/ext/extension.h)
@@ -246,47 +240,36 @@ if [ $API != %{hhvm_api_version} ]; then
        exit 1
 fi
 
-export HPHP_HOME=$(pwd)
-export HPHP_LIB=$HPHP_HOME/bin
-install -d $HPHP_LIB
+# out of dir build broken (can't find it's tools, or headers)
+#install -d build
+#cd build
 
-%undefine      with_ccache
-
-# asm linking breaks on $CC containing spaces
+# handle cmake & ccache
+# http://stackoverflow.com/questions/1815688/how-to-use-ccache-with-cmakec
+# ASM fix: http://lists.busybox.net/pipermail/buildroot/2013-March/069436.html
 if [[ "%{__cc}" = *ccache* ]]; then
-       cat <<-'EOF' > $HPHP_LIB/gcc
-       #!/bin/sh
-       exec %{__cc} "$@"
-       EOF
-       chmod +x $HPHP_LIB/gcc
-       CC=$HPHP_LIB/gcc
-fi
-
-if [[ "%{__cxx}" = *ccache* ]]; then
-       cat <<-'EOF' > $HPHP_LIB/g++
-       #!/bin/sh
-       exec %{__cxx} "$@"
-       EOF
-       chmod +x $HPHP_LIB/g++
-       CXX=$HPHP_LIB/g++
+       cc="%{__cc}"
+       cxx="%{__cxx}"
+       ccache="
+       -DCMAKE_C_COMPILER="ccache" -DCMAKE_C_COMPILER_ARG1="${cc#ccache }" \
+       -DCMAKE_CXX_COMPILER="ccache" -DCMAKE_CXX_COMPILER_ARG1="${cxx#ccache }" \
+       -DCMAKE_ASM_COMPILER="${cc#ccache }" \
+       "
 fi
 
-%if 0
-# out of dir build broken (can't find it's tools)
-install -d build
-cd build
-%endif
-
 %cmake \
+       $ccache \
        -DCMAKE_PREFIX_PATH=%{_prefix} \
+       -DHHVM_DYNAMIC_EXTENSION_DIR=%{hhvm_extensiondir} \
        -DUSE_JEMALLOC=OFF \
        -DUSE_TCMALLOC=OFF \
        -DHPHP_NOTEST=ON \
-       ./
+       -DENABLE_COTIRE=ON \
+       .
 
 # setup COMPILER_ID/HHVM_REPO_SCHEMA so it doesn't look it up from our package git repo
 # see hphp/util/generate-buildinfo.sh
-export COMPILER_ID=HHVM-%{version}-%{release}-%{githash}
+export COMPILER_ID=HHVM-%{version}-%{release}-g%{githash}
 export HHVM_REPO_SCHEMA=$(date +%N_%s)
 
 %{__make}
@@ -298,7 +281,7 @@ export HHVM_REPO_SCHEMA=$(date +%N_%s)
 if [ ! -f makeinstall.stamp -o ! -d $RPM_BUILD_ROOT ]; then
        rm -rf makeinstall.stamp installed.stamp $RPM_BUILD_ROOT
 
-       %{__make} install \
+       %{__make} install -C build \
                HPHP_HOME__=$(pwd) \
                DESTDIR=$RPM_BUILD_ROOT
 
@@ -307,9 +290,11 @@ fi
 
 rm -rf $RPM_BUILD_ROOT%{_docdir}
 if [ ! -f installed.stamp ]; then
-install -d $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
 # begin install block
 
+install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_libdir}/%{name}}
+cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
+
 ln -s hhvm $RPM_BUILD_ROOT%{_bindir}/php
 ln -s hhvm $RPM_BUILD_ROOT%{_bindir}/hphp
 
@@ -318,8 +303,10 @@ cp -p hphp/doc/mime.hdf $RPM_BUILD_ROOT%{_datadir}/%{name}/hdf/static.mime-types
 
 # install fastcgi initscript
 install -d $RPM_BUILD_ROOT/etc/{sysconfig,rc.d/init.d}
-cp -p %{SOURCE4} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-fcgi
-cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/sysconfig/%{name}-fcgi
+cp -p %{SOURCE5} $RPM_BUILD_ROOT/etc/rc.d/init.d/%{name}-fcgi
+cp -p %{SOURCE6} $RPM_BUILD_ROOT/etc/sysconfig/%{name}-fcgi
+
+install -p hphp/hack/bin/hh_{server,client} $RPM_BUILD_ROOT%{_bindir}
 
 %if 0
 # setup -devel
@@ -382,13 +369,19 @@ fi
 %defattr(644,root,root,755)
 %doc README.md hphp/NEWS
 %dir %{_sysconfdir}/%{name}
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/php.ini
 %attr(755,root,root) %{_bindir}/hhvm
 %attr(755,root,root) %{_bindir}/hphp
+%attr(755,root,root) %{_bindir}/hh_client
+%attr(755,root,root) %{_bindir}/hh_server
 
 %dir %{_datadir}/%{name}
 %dir %{_datadir}/%{name}/hdf
 %{_datadir}/%{name}/hdf/static.mime-types.hdf
 
+# dir for extensions
+%dir %{_libdir}/%{name}
+
 %files fcgi
 %defattr(644,root,root,755)
 %attr(754,root,root) /etc/rc.d/init.d/%{name}-fcgi
This page took 0.050581 seconds and 4 git commands to generate.