]> git.pld-linux.org Git - packages/hhvm.git/blobdiff - hhvm.spec
- icu&boost rebuild
[packages/hhvm.git] / hhvm.spec
index 4df0d1e16e06bc7b162bb67f2a761b5c74b044ad..2940606bd45f58853de6959f1fcf2264e0bb9f6e 100644 (file)
--- a/hhvm.spec
+++ b/hhvm.spec
@@ -4,7 +4,7 @@
 %bcond_without system_sqlite   # system sqlite3
 %bcond_without system_lz4              # system lz4
 %bcond_without system_fastlz   # system fastlz
-%bcond_without system_libafdt  # system libafdt
+%bcond_with    system_libafdt  # system libafdt
 %bcond_without system_libzip   # system libzip
 # cotire breaks sqlite3 on builders: https://github.com/facebook/hhvm/issues/4524
 %bcond_with    cotire                  # cotire (compile time reducer): Speed up the build by precompiling headers
@@ -22,8 +22,8 @@
 # hphp/system/idl/constants.idl.json defines it as 5.6.99-hhvm, but use some saner value
 %define                php_version                     5.6.0
 
-# git show HHVM-3.3.3
-%define                githash 54b5f51c3670fe55852b6dab17a47c67b2271116
+# git show HHVM-3.3.5
+%define                githash b2856c601e317b6d66fd1861c4cc889ae91d9f6f
 # these hashes are git submodules (be sure to check them on proper branch)
 # GIT_DIR=third-party/.git git log -1
 %define                thirdparty      bf581f8
@@ -34,12 +34,12 @@ Summary:    Virtual Machine, Runtime, and JIT for PHP
 Name:          hhvm
 # we prefer LTS versions
 # see http://hhvm.com/blog/6083/hhvm-long-term-support
-Version:       3.3.3
-Release:       1
+Version:       3.3.5
+Release:       3
 License:       PHP 3.01 and BSD
 Group:         Development/Languages
 Source0:       https://github.com/facebook/hhvm/archive/HHVM-%{version}.tar.gz
-# Source0-md5: 89c620e2df253530a4f6f1a185ec913a
+# Source0-md5: 57af76be5b4a10e35cb6eb705e0ff663
 Source2:       https://github.com/facebook/folly/archive/%{folly}/folly-3.2-%{folly}.tar.gz
 # Source2-md5: c4bdbea4c0ffe0650d12d9ff370b8255
 Source3:       https://github.com/hhvm/hhvm-third-party/archive/%{thirdparty}/third_party-%{thirdparty}.tar.gz
@@ -53,6 +53,7 @@ Patch2:               hphpize.patch
 Patch3:                MAX.patch
 Patch4:                system-thirdparty.patch
 Patch5:                cmake.patch
+Patch6:                libvpx2.patch
 URL:           https://github.com/facebook/hhvm/wiki
 BuildRequires: ImageMagick-devel
 BuildRequires: a52dec-libs-devel
@@ -258,7 +259,8 @@ mv folly-* third-party/folly/src
 %patch2 -p1
 %patch3 -p1
 %patch4 -p1
-%patch5 -p1
+#%patch5 -p1
+%patch6 -p1
 
 # prefer ones from system
 rm CMake/FindBISON.cmake
@@ -266,10 +268,9 @@ rm CMake/FindFLEX.cmake
 rm CMake/FindFreetype.cmake
 
 # ensure system libs get used
-# NOTE: keep sqlite dir, build breaks with 3.8.5.0
-
 cd third-party
 rm -r pcre \
+       %{?with_system_sqlite:libsqlite3} \
        %{?with_system_lz4:lz4} \
        %{?with_system_dconv:double-conversion} \
        %{?with_system_fastlz:fastlz} \
@@ -310,13 +311,6 @@ fi
        -DUSE_JEMALLOC=OFF \
        -DUSE_TCMALLOC=OFF \
        -DTEST_BIN=OFF \
-       -DPCRE_LIBRARY=OFF \
-       %{?with_system_sqlite:-DLIBSQLITE3_LIBRARY=OFF} \
-       %{?with_system_lz4:-DLZ4_LIBRARY=OFF} \
-       %{?with_system_dconv:-DDOUBLE_CONVERSION_LIBRARY=OFF} \
-       %{?with_system_fastlz:-DFASTLZ_LIBRARY=OFF} \
-       %{?with_system_libafdt:-DLIBAFDT_LIBRARY=OFF} \
-       %{?with_system_libzip:-DLIBZIP_LIBRARY=OFF} \
        -DENABLE_COTIRE=%{!?with_cotire:OFF}%{?with_cotire:ON} \
        .
 
This page took 0.083156 seconds and 4 git commands to generate.