]> git.pld-linux.org Git - packages/hhvm.git/blobdiff - hhvm.spec
- icu&boost rebuild
[packages/hhvm.git] / hhvm.spec
index 4bd43e45ae97a7fc6847b2e54407623a1ee4a661..2940606bd45f58853de6959f1fcf2264e0bb9f6e 100644 (file)
--- a/hhvm.spec
+++ b/hhvm.spec
@@ -1,25 +1,49 @@
+#
+# Conditional build:
+%bcond_without system_dconv    # system double-conversion
+%bcond_without system_sqlite   # system sqlite3
+%bcond_without system_lz4              # system lz4
+%bcond_without system_fastlz   # system fastlz
+%bcond_with    system_libafdt  # system libafdt
+%bcond_without system_libzip   # system libzip
+# cotire breaks sqlite3 on builders: https://github.com/facebook/hhvm/issues/4524
+%bcond_with    cotire                  # cotire (compile time reducer): Speed up the build by precompiling headers
+
+# TODO
+# - system xhp
+# - system proxygen
+# - system thrift
+
 # NOTES:
 # - hphp/runtime/base/runtime-option.cpp evalJitDefault enables jit if /.hhvm-jit exists (yes, in filesystem root)
-# - patch /usr/lib/hphp/CMake/HPHPIZEFunctions.cmake for %{_libdir}/hhvm as extension dir
-# TODO
-# - system libmbfl, system xhp, sqlite3
-# git show HHVM-3.3.1
-%define                githash e0c98e21167b425dddf1fc9efe78c9f7a36db268
-# these hashes are git submodules
+
+# must be in sync with source. extra check ensuring that it is so is done in %%build
+%define                hhvm_api_version        20140829
+# hphp/system/idl/constants.idl.json defines it as 5.6.99-hhvm, but use some saner value
+%define                php_version                     5.6.0
+
+# git show HHVM-3.3.5
+%define                githash b2856c601e317b6d66fd1861c4cc889ae91d9f6f
+# these hashes are git submodules (be sure to check them on proper branch)
+# GIT_DIR=third-party/.git git log -1
+%define                thirdparty      bf581f8
+# 6e46d468cf2876dd59c7a4dddcb4e37abf070b7a
+# GIT_DIR=third-party/folly/src/.git git log -1
 %define                folly           6e46d46
-%define                thirdparty      fdef620
 Summary:       Virtual Machine, Runtime, and JIT for PHP
 Name:          hhvm
-Version:       3.3.1
-Release:       0.1
+# we prefer LTS versions
+# see http://hhvm.com/blog/6083/hhvm-long-term-support
+Version:       3.3.5
+Release:       3
 License:       PHP 3.01 and BSD
 Group:         Development/Languages
 Source0:       https://github.com/facebook/hhvm/archive/HHVM-%{version}.tar.gz
-# Source0-md5: bab9490837ff4f54f295bbcf428d7a1c
+# Source0-md5: 57af76be5b4a10e35cb6eb705e0ff663
 Source2:       https://github.com/facebook/folly/archive/%{folly}/folly-3.2-%{folly}.tar.gz
 # Source2-md5: c4bdbea4c0ffe0650d12d9ff370b8255
 Source3:       https://github.com/hhvm/hhvm-third-party/archive/%{thirdparty}/third_party-%{thirdparty}.tar.gz
-# Source3-md5: 63858096c50c172d6c45ddb3d9b6d721
+# Source3-md5: 17210db0b2211c63d911076e02aab487
 Source5:       %{name}-fcgi.init
 Source6:       %{name}-fcgi.sysconfig
 Source7:       php.ini
@@ -27,6 +51,9 @@ Source100:    get-source.sh
 Patch1:                no-debug.patch
 Patch2:                hphpize.patch
 Patch3:                MAX.patch
+Patch4:                system-thirdparty.patch
+Patch5:                cmake.patch
+Patch6:                libvpx2.patch
 URL:           https://github.com/facebook/hhvm/wiki
 BuildRequires: ImageMagick-devel
 BuildRequires: a52dec-libs-devel
@@ -38,13 +65,16 @@ BuildRequires:      binutils-static
 BuildRequires: boost-devel >= 1.50
 BuildRequires: cmake >= 2.8.5
 BuildRequires: curl-devel >= 7.29.0
+%{?with_system_dconv:BuildRequires:    double-conversion-devel >= 1.1.1}
 BuildRequires: elfutils-devel
 BuildRequires: expat-devel
+%{?with_system_fastlz:BuildRequires:   fastlz-devel >= 0.1.0-0.r12}
 BuildRequires: gcc >= 6:4.6.0
 BuildRequires: gd-devel
 BuildRequires: glog-devel >= 0.3.2
 BuildRequires: imap-devel >= 1:2007
 #BuildRequires:        jemalloc-devel >= 3.0.0
+%{?with_system_libafdt:BuildRequires:  libafdt-devel >= 0.1.0}
 BuildRequires: libcap-devel
 BuildRequires: libdwarf-devel >= 20130729
 BuildRequires: libicu-devel >= 4.2
@@ -55,34 +85,37 @@ BuildRequires:      libstdc++-devel >= 6:4.8
 BuildRequires: libunwind-devel
 BuildRequires: libxml2-devel
 BuildRequires: libxslt-devel
+%{?with_system_libzip:BuildRequires:   libzip-devel >= 0.11.2}
+%{?with_system_lz4:BuildRequires:      lz4-devel >= 0.0-1.r119}
 BuildRequires: mysql-devel
 BuildRequires: ocaml-findlib
 BuildRequires: oniguruma-devel
 BuildRequires: openssl-devel
-BuildRequires: pcre-devel
+BuildRequires: pcre-devel >= 8.32
 #BuildRequires:        php-xhp-devel >= 1.3.9-6
 BuildRequires: readline-devel
 BuildRequires: rpmbuild(macros) >= 1.675
+%{?with_system_sqlite:BuildRequires:   sqlite3-devel >= 3.7.15.2}
 BuildRequires: tbb-devel >= 4.0.6000
 BuildRequires: zlib-devel
 # check later, seem unused
 #BuildRequires:        bison >= 2.3
 #BuildRequires:        flex >= 2.5.35
-#BuildRequires:        libafdt-devel >= 0.1.0
+BuildRequires: libafdt-devel >= 0.1.0
 #BuildRequires:        re2c >= 0.13.0
-# foreach (get_loaded_extensions() as $ext) printf("Provides:\tphp(%s)\n", strtolower($ext));
 Provides:      %{name}(api) = %{hhvm_api_version}
-Provides:      php(apache)
+Provides:      php(core) = %{php_version}
+# foreach (get_loaded_extensions() as $ext) printf("Provides:\tphp(%s)\n", strtolower($ext));
 Provides:      php(apc)
 Provides:      php(bcmath)
 Provides:      php(bz2)
 Provides:      php(calendar)
-Provides:      php(core) = %{php_version}
 Provides:      php(ctype)
 Provides:      php(curl)
 Provides:      php(date)
 Provides:      php(debugger)
 Provides:      php(dom)
+Provides:      php(enum)
 Provides:      php(exif)
 Provides:      php(fb)
 Provides:      php(fileinfo)
@@ -90,6 +123,7 @@ Provides:    php(filter)
 Provides:      php(ftp)
 Provides:      php(gd)
 Provides:      php(gettext)
+Provides:      php(gmp)
 Provides:      php(hash)
 Provides:      php(hh)
 Provides:      php(hhvm.debugger)
@@ -103,11 +137,12 @@ Provides: php(intl)
 Provides:      php(json)
 Provides:      php(ldap)
 Provides:      php(libxml)
+Provides:      php(mail)
+Provides:      php(mailparse)
 Provides:      php(mbstring)
 Provides:      php(mcrypt)
 Provides:      php(memcache)
 Provides:      php(memcached)
-Provides:      php(misc)
 Provides:      php(mysql)
 Provides:      php(mysqli)
 Provides:      php(oauth)
@@ -153,10 +188,6 @@ Obsoletes: hiphop-php < 2.3.2-0.2
 ExclusiveArch: %{x8664}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-# must be in sync with source. extra check ensuring that it is so is done in %%build
-%define                hhvm_api_version        20140829
-# hphp/system/idl/constants.idl.json defines it as 5.6.99-hhvm, but use some saner value
-%define                php_version                     5.6.0
 
 %define                hhvm_extensiondir       %{_libdir}/hhvm
 
@@ -227,12 +258,26 @@ mv folly-* third-party/folly/src
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
+#%patch5 -p1
+%patch6 -p1
 
 # prefer ones from system
 rm CMake/FindBISON.cmake
 rm CMake/FindFLEX.cmake
 rm CMake/FindFreetype.cmake
 
+# ensure system libs get used
+cd third-party
+rm -r pcre \
+       %{?with_system_sqlite:libsqlite3} \
+       %{?with_system_lz4:lz4} \
+       %{?with_system_dconv:double-conversion} \
+       %{?with_system_fastlz:fastlz} \
+       %{?with_system_libafdt:libafdt} \
+       %{?with_system_libzip:libzip} \
+       %{nil}
+
 %build
 # also in: hphp/tools/hphpize/hphpize.cmake
 API=$(awk '/#define HHVM_API_VERSION/{v=$3; sub(/L$/, "", v); print v}' hphp/runtime/ext/extension.h)
@@ -265,8 +310,8 @@ fi
        -DHHVM_DYNAMIC_EXTENSION_DIR=%{hhvm_extensiondir} \
        -DUSE_JEMALLOC=OFF \
        -DUSE_TCMALLOC=OFF \
-       -DHPHP_NOTEST=ON \
-       -DENABLE_COTIRE=ON \
+       -DTEST_BIN=OFF \
+       -DENABLE_COTIRE=%{!?with_cotire:OFF}%{?with_cotire:ON} \
        .
 
 # setup COMPILER_ID/HHVM_REPO_SCHEMA so it doesn't look it up from our package git repo
@@ -293,6 +338,13 @@ rm -rf $RPM_BUILD_ROOT%{_docdir}
 if [ ! -f installed.stamp ]; then
 # begin install block
 
+# fix broken cmake rules
+# TODO: fix cmake rules
+if [ -d $RPM_BUILD_ROOT%{_prefix}/usr ]; then
+       cp -a $RPM_BUILD_ROOT%{_prefix}/usr/* $RPM_BUILD_ROOT%{_prefix}
+       rm -rf $RPM_BUILD_ROOT%{_prefix}/usr
+fi
+
 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_libdir}/%{name}}
 cp -p %{SOURCE7} $RPM_BUILD_ROOT%{_sysconfdir}/%{name}
 
@@ -309,44 +361,6 @@ cp -p %{SOURCE6} $RPM_BUILD_ROOT/etc/sysconfig/%{name}-fcgi
 
 install -p hphp/hack/bin/hh_{server,client} $RPM_BUILD_ROOT%{_bindir}
 
-%if 0
-# setup -devel
-install -d $RPM_BUILD_ROOT%{_datadir}/cmake/Modules
-cp -p CMake/*.cmake $RPM_BUILD_ROOT%{_datadir}/cmake/Modules
-
-HPHP_HOME=$(pwd)
-sed -e "
-       /HHVM_INCLUDE_DIRS/ s,$HPHP_HOME,%{_includedir},g
-" hphp/tools/hphpize/hphpize.cmake > $RPM_BUILD_ROOT%{_datadir}/cmake/Modules/hphpize.cmake
-
-oIFS=$IFS
-IFS=";"
-set -- $(sed -ne 's/set(HHVM_INCLUDE_DIRS "\(.*\)")/\1/p' hphp/tools/hphpize/hphpize.cmake)
-IFS=$oIFS
-set -- $(
-       for dir in "$@"; do
-               [[ "$dir" = $HPHP_HOME/hphp/* ]] && echo $dir
-       done
-)
-
-set +x
-for dir in "$@" \
-       $HPHP_HOME/hphp/runtime \
-       $HPHP_HOME/hphp/util \
-       $HPHP_HOME/hphp/neo \
-       $HPHP_HOME/hphp/system \
-       $HPHP_HOME/hphp/parser \
-; do
-       echo "D %{_includedir}${dir#$HPHP_HOME}"
-       find $dir -name '*.h' | while read path; do
-               file=%{_includedir}${path#$HPHP_HOME}
-               echo "F $file"
-               install -Dp $path $RPM_BUILD_ROOT$file
-       done
-done
-set -x
-%endif
-
 # end of install block
 touch installed.stamp; fi
 
@@ -396,6 +410,6 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/hphpize
 %{_includedir}/hphp
-%dir %{_prefix}/lib/hphp
-%{_prefix}/lib/hphp/CMake
-%{_prefix}/lib/hphp/hphpize
+%dir %{_libdir}/hhvm
+%{_libdir}/hhvm/CMake
+%{_libdir}/hhvm/hphpize
This page took 0.101226 seconds and 4 git commands to generate.