]> git.pld-linux.org Git - packages/hdf.git/blobdiff - hdf.spec
- added szip patch to fix szip encoder detection; release 2
[packages/hdf.git] / hdf.spec
index 202f8e1414b9ce542d5417560ca8c69f427edb93..c49009ebd90df6fc07cfd5ace803a91940af2164 100644 (file)
--- a/hdf.spec
+++ b/hdf.spec
@@ -5,19 +5,20 @@
 Summary:       Hierarchical Data Format library
 Summary(pl.UTF-8):     Biblioteka HDF (Hierarchical Data Format)
 Name:          hdf
-Version:       4.2.6
-Release:       1
+Version:       4.2.10
+Release:       2
 Epoch:         1
 Group:         Libraries
 License:       Nearly BSD, but changed sources must be marked
 Source0:       ftp://ftp.hdfgroup.org/HDF/HDF_Current/src/hdf-%{version}.tar.bz2
-# Source0-md5: eed281ded7f81f6ba1a3b1b1d5109bfe
+# Source0-md5: bf26b3caaf3c0090965c8995578375bd
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
 # Source1-md5: 607df78cacc131b37dfdb443e61e789a
 Patch0:                %{name}-shared.patch
-Patch1:                %{name}-opt.patch
-Patch2:                %{name}-morearchs.patch
-Patch3:                %{name}-link.patch
+Patch1:                %{name}-morearchs.patch
+Patch2:                %{name}-link.patch
+Patch3:                %{name}-format.patch
+Patch4:                %{name}-szip.patch
 URL:           http://hdf.ncsa.uiuc.edu/
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
@@ -30,9 +31,12 @@ BuildRequires:       libtool >= 2:1.4d-3
 BuildRequires: netcdf-devel
 %{?with_szip:BuildRequires:    szip-devel >= 2.0}
 BuildRequires: which
-BuildRequires: zlib-devel >= 1.1.3
+BuildRequires: zlib-devel >= 1.1.4
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+# because of mfhdf/hdfimport/hdfimport.c false positives (const strings as format arguments)
+%define                filterout_c     -Werror=format-security
+
 %description
 HDF is a multi-object file format that facilitates the transfer of
 various types of scientific data between machines and operating
@@ -64,7 +68,7 @@ Group:                Development/Libraries
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 Requires:      libjpeg-devel >= 6b
 %{?with_szip:Requires: szip-devel >= 2.0}
-Requires:      zlib-devel >= 1.1.3
+Requires:      zlib-devel >= 1.1.4
 
 %description devel
 Header files for HDF library.
@@ -96,12 +100,24 @@ Utilities to convert from/to HDF format.
 %description progs -l pl.UTF-8
 Narzędzia do konwersji z i do formatu HDF.
 
+%package examples
+Summary:       HDF example programs (source code)
+Summary(pl.UTF-8):     Przykładowe programy dla biblioteki HDF (w postaci źródłowej)
+Group:         Documentation
+
+%description examples
+HDF example programs (source code).
+
+%description examples -l pl.UTF-8
+Przykładowe programy dla biblioteki HDF (w postaci źródłowej).
+
 %prep
 %setup -q
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
 %patch3 -p1
+%patch4 -p1
 
 # evil -R
 sed -i '/^if HDF_BUILD_XDR/,/^endif/d;/^if HDF_BUILD_SHARED/,/^endif/d' config/commence.am
@@ -125,7 +141,9 @@ rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_mandir}/man{3,7},%{_includedir}/hdf}
 
 %{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT
+       DESTDIR=$RPM_BUILD_ROOT \
+       EXAMPLETOPDIR=$RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} \
+       EXAMPLEDIR=$RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/c \
 
 mv -f $RPM_BUILD_ROOT%{_includedir}/*.{h,inc,f90} $RPM_BUILD_ROOT%{_includedir}/hdf
 
@@ -222,3 +240,14 @@ rm -rf $RPM_BUILD_ROOT
 %{_mandir}/man1/ristosds.1*
 %{_mandir}/man1/vmake.1*
 %{_mandir}/man1/vshow.1*
+
+%files examples
+%defattr(644,root,root,755)
+%dir %{_examplesdir}/%{name}-%{version}
+%{_examplesdir}/%{name}-%{version}/README
+%attr(755,root,root) %{_examplesdir}/%{name}-%{version}/run-all-ex.sh
+%dir %{_examplesdir}/%{name}-%{version}/c
+%{_examplesdir}/%{name}-%{version}/c/*.c
+%{_examplesdir}/%{name}-%{version}/c/*.f
+%attr(755,root,root) %{_examplesdir}/%{name}-%{version}/c/run-c-ex.sh
+%attr(755,root,root) %{_examplesdir}/%{name}-%{version}/c/run-fortran-ex.sh
This page took 0.152182 seconds and 4 git commands to generate.