]> git.pld-linux.org Git - packages/hdf.git/blobdiff - hdf.spec
- new URLs, updated to 4.2.13
[packages/hdf.git] / hdf.spec
index 6d87ab05cca49dfc5cdc00bc095aa46eb1b35773..690751c1fbd092a61e115586788d20c02d25593e 100644 (file)
--- a/hdf.spec
+++ b/hdf.spec
@@ -5,20 +5,20 @@
 Summary:       Hierarchical Data Format library
 Summary(pl.UTF-8):     Biblioteka HDF (Hierarchical Data Format)
 Name:          hdf
-Version:       4.2.5
+Version:       4.2.13
 Release:       1
 Epoch:         1
 Group:         Libraries
 License:       Nearly BSD, but changed sources must be marked
-Source0:       ftp://ftp.hdfgroup.org/HDF/HDF_Current/src/hdf-%{version}.tar.bz2
-# Source0-md5: 91bc17ec735b52736507570a530fe8a9
+Source0:       https://support.hdfgroup.org/ftp/HDF/releases/HDF%{version}/src/hdf-%{version}.tar.bz2
+# Source0-md5: 2c1b6c7fdf97738251154680b37bd86a
 Source1:       http://www.mif.pg.gda.pl/homepages/ankry/man-PLD/%{name}-man-pages.tar.bz2
 # Source1-md5: 607df78cacc131b37dfdb443e61e789a
 Patch0:                %{name}-shared.patch
-Patch1:                %{name}-opt.patch
-Patch2:                %{name}-morearchs.patch
-Patch3:                %{name}-jpeg.patch
-URL:           http://hdf.ncsa.uiuc.edu/
+Patch1:                %{name}-morearchs.patch
+Patch2:                %{name}-link.patch
+Patch3:                %{name}-szip.patch
+URL:           https://support.hdfgroup.org/products/hdf4/
 BuildRequires: autoconf >= 2.50
 BuildRequires: automake
 BuildRequires: bison
@@ -30,9 +30,12 @@ BuildRequires:       libtool >= 2:1.4d-3
 BuildRequires: netcdf-devel
 %{?with_szip:BuildRequires:    szip-devel >= 2.0}
 BuildRequires: which
-BuildRequires: zlib-devel >= 1.1.3
+BuildRequires: zlib-devel >= 1.1.4
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+# because of mfhdf/hdfimport/hdfimport.c false positives (const strings as format arguments)
+%define                filterout_c     -Werror=format-security
+
 %description
 HDF is a multi-object file format that facilitates the transfer of
 various types of scientific data between machines and operating
@@ -64,7 +67,7 @@ Group:                Development/Libraries
 Requires:      %{name} = %{epoch}:%{version}-%{release}
 Requires:      libjpeg-devel >= 6b
 %{?with_szip:Requires: szip-devel >= 2.0}
-Requires:      zlib-devel >= 1.1.3
+Requires:      zlib-devel >= 1.1.4
 
 %description devel
 Header files for HDF library.
@@ -96,6 +99,17 @@ Utilities to convert from/to HDF format.
 %description progs -l pl.UTF-8
 Narzędzia do konwersji z i do formatu HDF.
 
+%package examples
+Summary:       HDF example programs (source code)
+Summary(pl.UTF-8):     Przykładowe programy dla biblioteki HDF (w postaci źródłowej)
+Group:         Documentation
+
+%description examples
+HDF example programs (source code).
+
+%description examples -l pl.UTF-8
+Przykładowe programy dla biblioteki HDF (w postaci źródłowej).
+
 %prep
 %setup -q
 %patch0 -p1
@@ -104,7 +118,7 @@ Narzędzia do konwersji z i do formatu HDF.
 %patch3 -p1
 
 # evil -R
-:> config/commence.am
+sed -i '/^if HDF_BUILD_XDR/,/^endif/d;/^if HDF_BUILD_SHARED/,/^endif/d' config/commence.am
 
 %build
 %{__libtoolize}
@@ -114,19 +128,24 @@ Narzędzia do konwersji z i do formatu HDF.
 %{__automake}
 # need to pass F77 to override F77=g77 in config/linux-gnu
 %configure \
+%ifarch x32
+       F77="x86_64-pld-linux-gnux32-gfortran" \
+%else
        F77="%{_target_cpu}-pld-linux-gfortran" \
+%endif
        --enable-shared \
        %{?with_szip:--with-szlib}
 
-%{__make} \
-       libmfhdf_la_LIBADD=$(pwd)/hdf/src/libdf.la
+%{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 install -d $RPM_BUILD_ROOT{%{_mandir}/man{3,7},%{_includedir}/hdf}
 
 %{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT
+       DESTDIR=$RPM_BUILD_ROOT \
+       EXAMPLETOPDIR=$RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version} \
+       EXAMPLEDIR=$RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/c \
 
 mv -f $RPM_BUILD_ROOT%{_includedir}/*.{h,inc,f90} $RPM_BUILD_ROOT%{_includedir}/hdf
 
@@ -140,6 +159,8 @@ for i in ncdump ncgen ; do
 done
 
 bzip2 -dc %{SOURCE1} | tar xf - -C $RPM_BUILD_ROOT%{_mandir}
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/README.hdf-man-pages
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/diff.*
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -173,5 +194,62 @@ rm -rf $RPM_BUILD_ROOT
 
 %files progs
 %defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/*
-%{_mandir}/man1/*
+%attr(755,root,root) %{_bindir}/gif2hdf
+%attr(755,root,root) %{_bindir}/h4cc
+%attr(755,root,root) %{_bindir}/h4fc
+%attr(755,root,root) %{_bindir}/h4redeploy
+%attr(755,root,root) %{_bindir}/hdf24to8
+%attr(755,root,root) %{_bindir}/hdf2gif
+%attr(755,root,root) %{_bindir}/hdf2jpeg
+%attr(755,root,root) %{_bindir}/hdf8to24
+%attr(755,root,root) %{_bindir}/hdfcomp
+%attr(755,root,root) %{_bindir}/hdfed
+%attr(755,root,root) %{_bindir}/hdfimport
+%attr(755,root,root) %{_bindir}/hdfls
+%attr(755,root,root) %{_bindir}/hdfncdump
+%attr(755,root,root) %{_bindir}/hdfncgen
+%attr(755,root,root) %{_bindir}/hdfpack
+%attr(755,root,root) %{_bindir}/hdftopal
+%attr(755,root,root) %{_bindir}/hdftor8
+%attr(755,root,root) %{_bindir}/hdfunpac
+%attr(755,root,root) %{_bindir}/hdiff
+%attr(755,root,root) %{_bindir}/hdp
+%attr(755,root,root) %{_bindir}/hrepack
+%attr(755,root,root) %{_bindir}/jpeg2hdf
+%attr(755,root,root) %{_bindir}/paltohdf
+%attr(755,root,root) %{_bindir}/r8tohdf
+%attr(755,root,root) %{_bindir}/ristosds
+%attr(755,root,root) %{_bindir}/vmake
+%attr(755,root,root) %{_bindir}/vshow
+%{_mandir}/man1/fp2hdf.1*
+%{_mandir}/man1/gif2hdf.1*
+%{_mandir}/man1/hdf24to8.1*
+%{_mandir}/man1/hdf2gif.1*
+%{_mandir}/man1/hdf2jpeg.1*
+%{_mandir}/man1/hdf8to24.1*
+%{_mandir}/man1/hdfcomp.1*
+%{_mandir}/man1/hdfed.1*
+%{_mandir}/man1/hdfls.1*
+%{_mandir}/man1/hdfncdump.1*
+%{_mandir}/man1/hdfncgen.1*
+%{_mandir}/man1/hdfpack.1*
+%{_mandir}/man1/hdftopal.1*
+%{_mandir}/man1/hdftor8.1*
+%{_mandir}/man1/hdp.1*
+%{_mandir}/man1/jpeg2hdf.1*
+%{_mandir}/man1/paltohdf.1*
+%{_mandir}/man1/r8tohdf.1*
+%{_mandir}/man1/ristosds.1*
+%{_mandir}/man1/vmake.1*
+%{_mandir}/man1/vshow.1*
+
+%files examples
+%defattr(644,root,root,755)
+%dir %{_examplesdir}/%{name}-%{version}
+%{_examplesdir}/%{name}-%{version}/README
+%attr(755,root,root) %{_examplesdir}/%{name}-%{version}/run-all-ex.sh
+%dir %{_examplesdir}/%{name}-%{version}/c
+%{_examplesdir}/%{name}-%{version}/c/*.c
+%{_examplesdir}/%{name}-%{version}/c/*.f
+%attr(755,root,root) %{_examplesdir}/%{name}-%{version}/c/run-c-ex.sh
+%attr(755,root,root) %{_examplesdir}/%{name}-%{version}/c/run-fortran-ex.sh
This page took 0.106055 seconds and 4 git commands to generate.