]> git.pld-linux.org Git - packages/gnome-terminal.git/blobdiff - gnome-terminal.spec
- updated to 2.18.4
[packages/gnome-terminal.git] / gnome-terminal.spec
index 03bc0d7d9b7e0fddc8b81d72e02ddf9ef8d68423..0499bea7ec7b2ef072024ec25717aadc1d90e962 100644 (file)
@@ -1,68 +1,92 @@
 #
+# Conditional build:
 # This causes <prev-tab> key do nothing on the first tab (instead of 
 # passing the keypress to the application running in the terminal). Ditto 
 # for the last tab. This is kinda annoying.
 %bcond_with    disable_prev_next_tab_sensitivity_changes
+# This is specific to PLD and causes an "unknown term type" on most other
+# hosts I have to work on (the rest of the world uses xterm for g-t)
+%bcond_with    term_voodoo
+# This allows to mark on-terminal urls containing square brackets (eg. to
+# copy them or to open in external browser).
+%bcond_with    classify_square_brackets_into_url_paths
 #
 Summary:       GNOME Terminal
-Summary(pl):   Terminal dla GNOME
+Summary(pl.UTF-8):     Terminal dla GNOME
 Name:          gnome-terminal
-Version:       2.10.0
-Release:       3
+Version:       2.18.4
+Release:       1
 License:       GPL
 Group:         X11/Applications
-Source0:       http://ftp.gnome.org/pub/gnome/sources/gnome-terminal/2.10/%{name}-%{version}.tar.bz2
-# Source0-md5: 062744daca0c7f708b8c52f47b5db0d1
+Source0:       http://ftp.gnome.org/pub/GNOME/sources/gnome-terminal/2.18/%{name}-%{version}.tar.bz2
+# Source0-md5: e4429d66d0d2ede8e14756cfbc15d30a
 Patch0:                %{name}-TERM.patch
 Patch1:                %{name}-disable-prev_next-tab-sensitivity-changes.patch
 Patch2:                %{name}-desktop.patch
-Patch3:                %{name}-ne.po.patch
+Patch3:                %{name}-save-session-crash.patch
+Patch4:                %{name}-url-regex.patch
 URL:           http://www.gnome.org/
-BuildRequires: GConf2-devel >= 2.10.0
+BuildRequires: GConf2-devel >= 2.20.0
 BuildRequires: autoconf >= 2.53
 BuildRequires: automake
-BuildRequires: gtk+2-devel >= 2:2.6.0
-BuildRequires: gnome-common >= 2.8.0-2
-BuildRequires: gnome-vfs2-devel >= 2.10.0-2
-BuildRequires: intltool
-BuildRequires: libglade2-devel >= 1:2.5.1
-BuildRequires: libgnomeui-devel >= 2.10.0
+BuildRequires: gtk+2-devel >= 2:2.12.0
+BuildRequires: gnome-common >= 2.20.0
+BuildRequires: gnome-doc-utils >= 0.12.0
+BuildRequires: gnome-vfs2-devel >= 2.20.0
+BuildRequires: intltool >= 0.36.2
+BuildRequires: libglade2-devel >= 1:2.6.2
+BuildRequires: libgnomeui-devel >= 2.20.0
 BuildRequires: libtool
 BuildRequires: pkgconfig >= 1:0.12.0
+BuildRequires: rpmbuild(find_lang) >= 1.23
 BuildRequires: rpmbuild(macros) >= 1.197
 BuildRequires: scrollkeeper
+BuildRequires: sed >= 4.0
 BuildRequires: startup-notification-devel >= 0.8
-BuildRequires: vte-devel >= 0.11.12
-BuildRequires: xft-devel >= 2.1-2
+BuildRequires: vte-devel >= 0.16.9
 Requires(post,preun):  GConf2
 Requires(post,postun): scrollkeeper
-Requires:      libgnomeui >= 2.10.0
+Requires:      libgnomeui >= 2.20.0
 Requires:      startup-notification >= 0.8
+Requires:      vte >= 0.16.9
 Requires:      terminfo
+# sr@Latn vs. sr@latin
+Conflicts:     glibc-misc < 6:2.7
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 This is a terminal thing that isn't finished at all.
 
-%description -l pl
-To jest terminal, na razie ca³kowicie nie dokoñczony.
+%description -l pl.UTF-8
+To jest terminal, na razie całkowicie nie dokończony.
 
 %prep
 %setup -q
+%if %{with term_voodoo}
 %patch0 -p1
+%endif
 %if %{with disable_prev_next_tab_sensitivity_changes}
 %patch1 -p1
 %endif
 %patch2 -p1
 %patch3 -p1
+%if %{with classify_square_brackets_into_url_paths}
+%patch4 -p1
+%endif
+
+sed -i -e 's#sr\@Latn#sr\@latin#' po/LINGUAS
+mv po/sr\@{Latn,latin}.po
 
 %build
-cp /usr/share/gnome-common/data/omf.make .
+%{__intltoolize}
+%{__gnome_doc_common}
 %{__libtoolize}
 %{__aclocal}
 %{__autoconf}
 %{__automake}
-%configure
+%configure \
+       --disable-schemas-install \
+       --disable-scrollkeeper
 %{__make}
 
 %install
@@ -73,10 +97,9 @@ rm -rf $RPM_BUILD_ROOT
        GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1 \
        localedir=%{_localedir}
 
-rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
 rm -rf $RPM_BUILD_ROOT%{_datadir}/application-registry
 
-%find_lang %{name} --with-gnome --all-name
+%find_lang %{name} --with-gnome --with-omf --all-name
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -93,11 +116,10 @@ rm -rf $RPM_BUILD_ROOT
 
 %files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc README ChangeLog NEWS TODO AUTHORS
-%doc %{_omf_dest_dir}/%{name}
+%doc AUTHORS ChangeLog NEWS README
 %attr(755,root,root) %{_bindir}/*
-%{_sysconfdir}/gconf/schemas/*
-%{_datadir}/%{name}
 %{_libdir}/bonobo/servers/*
-%{_desktopdir}/*
+%{_datadir}/%{name}
+%{_desktopdir}/*.desktop
 %{_pixmapsdir}/*
+%{_sysconfdir}/gconf/schemas/gnome-terminal.schemas
This page took 0.726971 seconds and 4 git commands to generate.