]> git.pld-linux.org Git - packages/gnome-panel.git/blobdiff - gnome-panel.spec
- 2.8.2, STBR
[packages/gnome-panel.git] / gnome-panel.spec
index 1059056369459a2835364895a01b9514e07775fd..b40e486487e10851f4446620fc18b65881eed4ae 100644 (file)
@@ -1,38 +1,56 @@
+#
+# Conditional build:
+%bcond_with     menu_stripe    # build with menu-stripe.patch
+#
 Summary:       The core programs for the GNOME GUI desktop environment
 Summary(pl):   Podstawowe programy ¶rodowiska graficznego GNOME
 Name:          gnome-panel
-Version:       2.3.7
+Version:       2.8.2
 Release:       1
 License:       LGPL
 Group:         X11/Applications
-Source0:       http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.3/%{name}-%{version}.tar.bz2
-# Source0-md5: e2e63580a64806970ad9b2f83db1803c
-Patch0:                %{name}-clock.patch
+Source0:       http://ftp.gnome.org/pub/GNOME/sources/%{name}/2.8/%{name}-%{version}.tar.bz2
+# Source0-md5: 8637a859fd84cd3f9373cfe107131023
+Source1:       pld-desktop-stripe.png
+# Source1-md5: 4b8b299a8aa7b95a606e7c4d8debd60c
+Patch0:                %{name}-no_launchers_on_panel.patch
+Patch1:                %{name}-finalize-memleak.patch
+%{?with_menu_stripe:Patch2:            %{name}-menu-stripe.patch}
+Patch3:                %{name}-notification_area_applet.patch
+Patch4:                %{name}-all_applications.patch
 URL:           http://www.gnome.org/
-BuildRequires: GConf2-devel >= 2.3.3
-BuildRequires: ORBit2-devel >= 2.7.6
+BuildRequires: GConf2-devel >= 2.8.0.1
+BuildRequires: ORBit2-devel >= 1:2.11.2
 BuildRequires: autoconf
 BuildRequires: automake
-BuildRequires: glib2-devel >= 2.2.2
-BuildRequires: gnome-common >= 2.3.0
-BuildRequires: gnome-desktop-devel >= 2.3.7
-BuildRequires: gtk+2-devel >= 2.2.2
+BuildRequires: evolution-data-server-devel >= 1.0.1
+BuildRequires: gnome-common >= 2.8.0-2
+BuildRequires: gnome-desktop-devel >= 2.8.0
+BuildRequires: gnome-vfs2-devel >= 2.8.1
+BuildRequires: gtk+2-devel >= 2:2.4.4
 BuildRequires: gtk-doc >= 1.1
-BuildRequires: intltool >= 0.27.2
-BuildRequires: libart_lgpl-devel >= 2.3.14
-BuildRequires: libglade2-devel >= 2.0.1
-BuildRequires: libgnomeui-devel >= 2.3.6
+BuildRequires: intltool >= 0.31
+BuildRequires: libart_lgpl-devel >= 2.3.15
+BuildRequires: libglade2-devel >= 1:2.4.0
+BuildRequires: libgnomeui-devel >= 2.8.0
+BuildRequires: libpng-devel >= 1.2.0
 BuildRequires: libtool
-BuildRequires: libwnck-devel >= 2.3.1
-BuildRequires: pkgconfig >= 0.15.0
+BuildRequires: libwnck-devel >= 2.8.0.1
+BuildRequires: pango-devel >= 1:1.6.0
+BuildRequires: perl-base
+BuildRequires: pkgconfig >= 1:0.15.0
 BuildRequires: rpm-build >= 4.1-10
 BuildRequires: scrollkeeper >= 0.3.11
+BuildRequires: zlib-devel
 BuildConflicts:        GConf-devel < 1.0.9-7
 Requires(post,postun): /sbin/ldconfig
 Requires(post,postun): scrollkeeper
-Requires(post):        GConf2 >= 2.3.3
-Requires:      gnome-desktop >= 2.3.7
-Requires:      libgnomeui >= 2.3.6
+Requires(post):        GConf2 >= 2.8.0
+Requires:      gnome-desktop >= 2.8.0
+Requires:      gnome-icon-theme >= 2.8.0
+Requires:      gnome-vfs-menu-module
+Requires:      libgnomeui >= 2.8.0
+Requires:      librsvg >= 1:2.8.1
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -57,9 +75,9 @@ panelu GNOME2.
 Summary:       GNOME panel includes, and more
 Summary(pl):   Pliki nag³ówkowe biblioteki panelu GNOME
 Group:         X11/Development/Libraries
-Requires:      %{name} = %{version}
-Requires:      libgnomeui-devel >= 2.3.6
+Requires:      %{name} = %{version}-%{release}
 Requires:      gtk-doc-common
+Requires:      libgnomeui-devel >= 2.8.0
 
 %description devel
 Panel header files for creating GNOME panels.
@@ -71,7 +89,7 @@ Pliki nag
 Summary:       GNOME panel static libraries
 Summary(pl):   Statyczne biblioteki panelu GNOME
 Group:         X11/Development/Libraries
-Requires:      %{name}-devel = %{version}
+Requires:      %{name}-devel = %{version}-%{release}
 
 %description static
 Panel static libraries.
@@ -82,18 +100,25 @@ Statyczne biblioteki panelu GNOME.
 %prep
 %setup -q
 %patch0 -p1
+%patch1 -p1
+%{?with_menu_stripe:%patch2 -p1}
+%patch3 -p1
+%patch4 -p1
 
 %build
+cp /usr/share/gnome-common/data/omf.make .
 intltoolize --copy --force
 %{__libtoolize}
 glib-gettextize --copy --force
-%{__aclocal} -I %{_aclocaldir}/gnome2-macros
+%{__aclocal}
 %{__autoheader}
 %{__autoconf}
 %{__automake}
 %configure \
        --enable-gtk-doc \
-       --with-html-dir=%{_gtkdocdir}
+       --with-html-dir=%{_gtkdocdir} \
+       --enable-eds \
+       --disable-schemas-install
 
 %{__make}
 
@@ -101,13 +126,18 @@ glib-gettextize --copy --force
 rm -rf $RPM_BUILD_ROOT
 
 %{__make} install \
-       DESTDIR=$RPM_BUILD_ROOT
+       DESTDIR=$RPM_BUILD_ROOT \
+       GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL=1
 
 install %{name}/panel-default-setup.entries $RPM_BUILD_ROOT%{_datadir}/%{name}
 
+install %{SOURCE1} $RPM_BUILD_ROOT%{_pixmapsdir}
+
 mv ChangeLog main-ChangeLog
 find . -name ChangeLog |awk '{src=$0; dst=$0;sub("^./","",dst);gsub("/","-",dst); print "cp " src " " dst}'|sh
 
+rm -r $RPM_BUILD_ROOT%{_datadir}/locale/no
+
 %find_lang %{name} --with-gnome --all-name
 
 %clean
@@ -118,8 +148,11 @@ rm -rf $RPM_BUILD_ROOT
 scrollkeeper-update
 %gconf_schema_install
 %{_bindir}/gconftool-2 --direct \
---config-source="`%{_bindir}/gconftool-2 --get-default-source`" \
---load %{_datadir}/%{name}/panel-default-setup.entries > /dev/null
+       --config-source="`%{_bindir}/gconftool-2 --get-default-source`" \
+       --load %{_datadir}/%{name}/panel-default-setup.entries > /dev/null
+%{_bindir}/gconftool-2 --direct \
+       --config-source="`%{_bindir}/gconftool-2 --get-default-source`" \
+       --load %{_datadir}/%{name}/panel-default-setup.entries /apps/panel/profiles/default > /dev/null
 
 %postun
 /sbin/ldconfig
@@ -132,11 +165,10 @@ scrollkeeper-update
 %attr(755,root,root) %{_bindir}/*
 %attr(755,root,root) %{_libdir}/fish-applet-2
 %attr(755,root,root) %{_libdir}/libpanel-applet*.so.*.*
-%attr(755,root,root) %{_libdir}/libclock-applet*.so
+%attr(755,root,root) %{_libdir}/clock-applet
 %attr(755,root,root) %{_libdir}/wnck-applet
 %attr(755,root,root) %{_libdir}/notification-area-applet
 %{_libdir}/bonobo/servers/*
-%{_datadir}/control-center-2.0/capplets/*
 %{_datadir}/gnome/panel
 %{_datadir}/gnome-2.0/ui/*
 %{_datadir}/gnome-panel
This page took 0.047885 seconds and 4 git commands to generate.