]> git.pld-linux.org Git - packages/glibc.git/blobdiff - glibc.spec
- fixed broken %post nscd script
[packages/glibc.git] / glibc.spec
index bf3a500dcc574763aa6348345f19a2349a68642f..e6f3d8251c8846965f0a45caa5f4381ddc3b5be5 100644 (file)
@@ -5,23 +5,26 @@ Summary(pl):  GNU libc
 Summary(tr):   GNU libc
 name:          glibc
 Version:       2.1.1
-Release:       3       
+Release:       6
 Copyright:     LGPL
 Group:         Libraries
 Group(pl):     Biblioteki
-########       ftp://sourceware.cygnus.com/pub/glibc/
-Source0:       %{name}-%{version}.tar.gz
-Source1:       %{name}-linuxthreads-%{version}.tar.gz
-########       http://www.ozemail.com.au/~geoffk/glibc-crypt
-Source2:       %{name}-crypt-%{version}.tar.gz
+Source0:       ftp://sourceware.cygnus.com/pub/glibc/%{name}-%{version}.tar.gz
+Source1:       ftp://sourceware.cygnus.com/pub/glibc/%{name}-linuxthreads-%{version}.tar.gz
+Source2:       http://www.ozemail.com.au/~geoffk/glibc-crypt/%{name}-crypt-%{version}.tar.gz
 Source3:       utmpd.init
 Source4:       nscd.init
 Source5:       utmpd.sysconfig
 Source6:       nscd.sysconfig
+Source7:       nscd.logrotate
 Patch0:                glibc-info.patch
 Patch1:                glibc-paths.patch
 Patch2:                glibc-versions.awk_fix.patch
+Patch3:                glibc-pld.patch
+Patch4:                glibc-getaddrinfo.patch
+Patch5:                glibc-gcc-2.95.patch
 URL:           http://www.gnu.org/software/libc/
+BuildRequires: perl
 Provides:      ld.so.2
 Obsoletes:     %{name}-profile
 Obsoletes:     %{name}-debug
@@ -76,7 +79,7 @@ C kitapl
 Linux sistemi çalýþmayacaktýr. Yerel dil desteði ve zaman dilimi veri tabaný
 da bu pakette yer alýr.
 
-%package       devel
+%package devel
 Summary:       Additional libraries required to compile
 Summary(de):   Weitere Libraries zum Kompilieren
 Summary(fr):   Librairies supplémentaires nécessaires à la compilation.
@@ -111,11 +114,11 @@ objektowe, niezb
 C kitaplýðýný kullanan (ki hemen hemen hepsi kullanýyor) programlar
 geliþtirmek için gereken standart baþlýk dosyalarý ve statik kitaplýklar.
 
-%package -n    nscd
+%package -n nscd
 Summary:       Name Service Caching Daemon
 Summary(pl):   Name Service Caching Daemon
-Group:         Networnikng/Daemons
-Group:         Sieciowe/Serwery
+Group:         Networking/Daemons
+Group(pl):     Sieciowe/Serwery
 Prereq:                /sbin/chkconfig
 
 %description -n nscd
@@ -132,7 +135,7 @@ poprawi
 Nie jest mo¿liwe u¿ywanie nscd z j±drami serii 2.0.x z powodu b³adów
 po stronie j±dra w ods³udze w±tków.
 
-%package -n    utmpd
+%package -n utmpd
 Summary:       utmp and utmpx synchronizer for libc5 applications.
 Summary(pl):   Synchrnnizuje zapis do plików utmp i utmpx.
 Group:         Daemons
@@ -148,7 +151,7 @@ utmpd stara si
 /var/run/utmp i /var/run/utmpx. Potrzebny jest tylko w przypadku korzystania
 ze starszych programów (bazuj±cych na libc5).
 
-%package       static
+%package static
 Summary:       Static libraries
 Summary(pl):   Biblioteki statyczne 
 Group:         Development/Libraries
@@ -166,10 +169,12 @@ GNU libc-2.1 Static libraries
 %patch0 -p1
 %patch1 -p1
 %patch2 -p1
+%patch3 -p1
+%patch4 -p1
+%patch5 -p1
 
 %build
-
-    %configure \
+%configure \
        --enable-add-ons=crypt,linuxthreads \
        --disable-profile \
        --disable-omitfp \
@@ -179,7 +184,7 @@ make
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT/{etc/{rc.d/init.d,sysconfig},%{_mandir}/man3,var/db}
+install -d $RPM_BUILD_ROOT/{etc/{rc.d/init.d,sysconfig,logrotate.d},%{_mandir}/man3,var/{db,log}}
 
 make install \
        install_root=$RPM_BUILD_ROOT \
@@ -205,14 +210,16 @@ install %{SOURCE4}                $RPM_BUILD_ROOT/etc/rc.d/init.d/nscd
 install %{SOURCE3}             $RPM_BUILD_ROOT/etc/rc.d/init.d/utmpd
 install %{SOURCE6}             $RPM_BUILD_ROOT/etc/sysconfig/nscd
 install %{SOURCE5}             $RPM_BUILD_ROOT/etc/sysconfig/utmpd
+install %{SOURCE7}             $RPM_BUILD_ROOT/etc/logrotate.d/nscd
 install nscd/nscd.conf         $RPM_BUILD_ROOT/etc
 install nss/nsswitch.conf      $RPM_BUILD_ROOT/etc
 
-install nss/db-Makefile $RPM_BUILD_ROOT/var/db
+install nss/db-Makefile $RPM_BUILD_ROOT/var/db/Makefile
+:> $RPM_BUILD_ROOT/var/log/nscd
 
 cat << EOF > $RPM_BUILD_ROOT/usr/bin/create-db
 #!/bin/sh
-/usr/bin/make -f /var/db/db-Makefile
+/usr/bin/make -sC /var/db/
 EOF
 
 ln -sf create-db $RPM_BUILD_ROOT%{_bindir}/update-db 
@@ -231,6 +238,10 @@ gzip -9fn README NEWS FAQ BUGS NOTES PROJECTS \
        $RPM_BUILD_ROOT{%{_mandir}/man*/*,%{_infodir}/libc*} \
        documentation/* login/README.utmpd
 
+strip $RPM_BUILD_ROOT/{sbin/*,usr/{sbin/*,bin/*}} ||:
+strip --strip-unneeded $RPM_BUILD_ROOT/lib/lib*.so.* \
+       $RPM_BUILD_ROOT/usr/lib/gconv/*.so
+
 %post   -p /sbin/ldconfig
 %postun -p /sbin/ldconfig
 
@@ -244,29 +255,31 @@ fi
 
 %post -n nscd
 /sbin/chkconfig --add nscd
+touch /var/log/nscd && (chown root.root /var/log/nscd ; chmod 640 /var/log/nscd)
 if [ -f /var/lock/subsys/nscd ]; then
-       /etc/rc.d/init.d/nscd restart &>/dev/null
+       /etc/rc.d/init.d/nscd restart 1>&2
 else
-       echo "Run \"/etc/rc.d/init.d/nscd start\" to start nscd daemon."
+       echo "Run \"/etc/rc.d/init.d/nscd start\" to start nscd daemon." 1>&2
 fi
 
 %preun -n nscd
 if [ "$1" = "0" ]; then
        /sbin/chkconfig --del nscd
-       /etc/rc.d/init.d/nscd stop &>/dev/null
+       /etc/rc.d/init.d/nscd stop 1>&2
 fi
 
 %post -n utmpd
 /sbin/chkconfig --add utmpd
-
 if [ -f /var/lock/subsys/utmpd ]; then
-       /etc/rc.d/init.d/utmpd restart &>/dev/null
+       /etc/rc.d/init.d/utmpd restart 1>&2
+else
+       echo "Run \"/etc/rc.d/init.d/utmpd start\" to start utmpd daemon." 1>&2
 fi
 
 %preun -n utmpd
 if [ "$1" = "0" ]; then
        /sbin/chkconfig --del utmpd
-       /etc/rc.d/init.d/utmpd stop &>/dev/null
+       /etc/rc.d/init.d/utmpd stop 1>&2
 fi
 
 %clean
@@ -295,8 +308,7 @@ rm -rf $RPM_BUILD_ROOT
 %{_datadir}/locale
 %{_datadir}/zoneinfo
 
-%dir /var/db
-%config /var/db/db-*
+%config /var/db/Makefile
 
 %files devel
 %defattr(644,root,root,755)
@@ -338,6 +350,8 @@ rm -rf $RPM_BUILD_ROOT
 %attr(640,root,root) %config(noreplace) %verify(not mtime md5 size) /etc/nscd.*
 %attr(755,root,root) /etc/rc.d/init.d/nscd
 %attr(755,root,root) %{_sbindir}/nscd
+%attr(640,root,root) /etc/logrotate.d/nscd
+%attr(640,root,root) %ghost /var/log/nscd
 
 %files -n utmpd
 %defattr(644,root,root,755)
@@ -349,31 +363,3 @@ rm -rf $RPM_BUILD_ROOT
 %files static
 %defattr(644,root,root,755)
 %{_libdir}/lib*.a
-
-%changelog
-  scripts/versions.awk),
-- added static subpackage (please, don't ask me why ...)
-- added {utmpd,nscd}.sysconfig
-- removed /var/db (it is in filesystem).
-
-* Wed Jun 02 1999 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
-- added static subpackage,
-- added {utmpd,nscd}.sysconfig,
-- fixed %doc && {utmpd,nscd}.init,
-- macro %configure in use ...
-
-* Wed May 26 1999 Wojtek ¦lusarczyk <wojtek@shadow.eu.org>
-  [2.1.1-2]
-- fixed utpmd.init,
-- added %post & %pre for utmpd subpackage.
-- macro %{_target_platform},
-- fixed %build,
-- minor changes.
-
-- pl translation by Wojtek ¦lusarczyk <wojtek@shadow.eu.org>.
-
-  [2.1.1-1]
-- based on RH spec,
-- spec rewrited by PLD team,
-  we start at GNU libc 2.0.92 one year ago ...
-- pl translation by Wojtek ¦lusarczyk <wojtek@shadow.eu.org>.
This page took 0.037856 seconds and 4 git commands to generate.