]> git.pld-linux.org Git - packages/glibc.git/blobdiff - glibc.spec
noarch -devel-doc
[packages/glibc.git] / glibc.spec
index cde8e05e1ada0288b07c403d026998600440efc0..dd2c4f4704d49755c68bd287def5520233bbb33f 100644 (file)
@@ -8,7 +8,7 @@
 # - math/{test-fenv,test-tgmath,test-float,test-ifloat}, debug/backtrace-tst(SEGV)  fail on alpha
 #
 # Conditional build:
-# min_kernel   (default is 2.6.32)
+# min_kernel   (default is 3.4.0 except for x86/x86_64 where 2.6.32 suffices)
 %bcond_without memusage        # don't build memusage utility
 %bcond_without selinux         # without SELinux support (in nscd)
 %bcond_with    tests           # perform "make test"
 %bcond_without nss_crypt       # disable crypt features based on Mozilla NSS library
 %bcond_with    bash_nls        # use bash NLS in shell scripts (ldd, sotruss); restores /bin/bash dep
 #
-%ifarch x32
-%{!?min_kernel:%global         min_kernel      3.4.0}
+%ifarch %{ix86} %{x8664}
+%{!?min_kernel:%global         min_kernel      2.6.32} 
 %else
-%{!?min_kernel:%global         min_kernel      2.6.32}
+%{!?min_kernel:%global         min_kernel      3.4.0}
 %endif
 
 %ifarch sparc64
 %undefine      with_memusage
 %endif
 
-%define                core_version    2.23
+%define                core_version    2.24
 %define                llh_version     7:2.6.32.1-1
 
 Summary:       GNU libc
@@ -41,23 +41,24 @@ Summary(tr.UTF-8):  GNU libc
 Summary(uk.UTF-8):     GNU libc версії
 Name:          glibc
 Version:       %{core_version}
-Release:       1
+Release:       3
 Epoch:         6
 License:       LGPL v2.1+
 Group:         Libraries
 Source0:       http://ftp.gnu.org/gnu/glibc/%{name}-%{version}.tar.xz
-# Source0-md5: 456995968f3acadbed39f5eba31678df
+# Source0-md5: 97dc5517f92016f3d70d83e3162ad318
 Source2:       nscd.init
 Source3:       nscd.sysconfig
 Source4:       nscd.logrotate
 # from man-pages.spec --with tars
 Source5:       %{name}-man-pages.tar.xz
-# Source5-md5: 3a4eabb7d28db7d35d8204fdb471a863
+# Source5-md5: 82537aa7f6ee31dd782e7e085cc21018
 Source6:       %{name}-localedb-gen
 Source7:       %{name}-LD-path.c
 Source9:       nscd.tmpfiles
-# git diff glibc-2.23..release/2.23/master
+# use branch.sh to update glibc-git.patch
 Patch0:                glibc-git.patch
+# Patch0-md5:  db84fc2f3b428f64896dde0c7b0d8856
 # against GNU TP (libc domain)
 #Patch1:               %{name}-pl.po-update.patch
 Patch2:                %{name}-pld.patch
@@ -83,16 +84,16 @@ Patch20:    %{name}-thread_start.patch
 
 Patch23:       %{name}-pt_pax.patch
 
-Patch27:       %{name}-locale-C.patch.xz
-# Patch27-md5: 34ebe52a2afb923e33af0fb7c541f540
-Patch28:       %{name}-locale-C-pld.patch
+# http://pkgs.fedoraproject.org/cgit/rpms/glibc.git/plain/glibc-c-utf8-locale.patch
+Patch27:       %{name}-c-utf8-locale.patch
+
 Patch29:       %{name}-arm-alignment-fix.patch
 Patch30:       glibc-rh1124987.patch
 
 Patch38:       1055_all_glibc-resolv-dynamic.patch
 URL:           http://www.gnu.org/software/libc/
 %{?with_selinux:BuildRequires: audit-libs-devel}
-BuildRequires: autoconf
+BuildRequires: autoconf >= 2.69
 BuildRequires: automake
 %ifarch alpha
 BuildRequires: binutils >= 2:2.17.50.0.7
@@ -384,6 +385,14 @@ El antiguo módulo NYS NSS de glibc
 %description -n nss_compat -l pl.UTF-8
 Stary moduł NYS NSS glibc.
 
+%package -n nss_db
+Summary:       Berkeley DB NSS glibc module
+Group:         Base
+Requires:      %{name} = %{epoch}:%{version}-%{release}
+
+%description -n nss_db
+Berkeley DB NSS glibc module.
+
 %package -n nss_dns
 Summary:       BIND NSS glibc module
 Summary(es.UTF-8):     Módulo BIND NSS de glibc
@@ -498,6 +507,12 @@ Provides:  %{name}-devel(%{_target_cpu}) = %{epoch}:%{version}-%{release}
 Provides:      %{name}-devel(ix86) = %{epoch}:%{version}-%{release}
 %endif
 Obsoletes:     libiconv-devel
+%ifarch %{x8664}
+# see http://lists.pld-linux.org/mailman/pipermail/pld-devel-en/2016-May/024902.html
+%if "%(rpm -q --qf '%{E}:%{V}' binutils)" >= "4:2.26"
+Conflicts: binutils < 4:2.26
+%endif
+%endif
 
 %description devel
 To develop programs which use the standard C libraries (which nearly
@@ -664,35 +679,10 @@ korzystające ze standardowych bibliotek C.
 Summary:       Documentation needed for development using standard C libraries
 Summary(pl.UTF-8):     Dokumentacja do tworzenia programów przy użyciu standardowych bibliotek C
 Group:         Documentation
-Provides:      %{name}-devel-doc(%{_target_cpu}) = %{epoch}:%{version}-%{release}
-%ifarch %{ix86}
-Provides:      %{name}-devel-doc(ix86) = %{epoch}:%{version}-%{release}
-%endif
-%ifarch %{x8664}
-# If both -m32 and -m64 is to be supported on x86_64, x86_64 package
-# have to be installed, not ix86 one.
-Obsoletes:     glibc-devel-doc(athlon)
-Obsoletes:     glibc-devel-doc(i386)
-Obsoletes:     glibc-devel-doc(i486)
-Obsoletes:     glibc-devel-doc(i586)
-Obsoletes:     glibc-devel-doc(i686)
-Obsoletes:     glibc-devel-doc(ix86)
-Obsoletes:     glibc-devel-doc(pentium3)
-Obsoletes:     glibc-devel-doc(pentium4)
-%endif
-%ifarch x32
-Obsoletes:     glibc-devel-doc(x86_64)
-%endif
-%ifarch ppc64
-Obsoletes:     glibc-devel-doc(ppc)
-%endif
-%ifarch s390x
-Obsoletes:     glibc-devel-doc(s390)
-%endif
-%ifarch sparc64
-Obsoletes:     glibc-devel-doc(sparc)
-%endif
 Conflicts:     man-pages < 4.00
+%if "%{_rpmversion}" >= "5"
+BuildArch:     noarch
+%endif
 
 %description devel-doc
 The glibc-devel-doc package contains info and manual pages necessary
@@ -985,7 +975,7 @@ exit 1
 %patch23 -p0
 
 %patch27 -p1
-%patch28 -p1
+
 %patch29 -p1
 %patch30 -p1
 
@@ -1047,7 +1037,9 @@ env LANGUAGE=C LC_ALL=C \
 
 %if %{without cross}
 CC="%{__cc}"
-diet ${CC#*ccache } %{SOURCE7} %{rpmcflags} -Os -static -o glibc-postinst
+CC=${CC#*ccache }
+CC=${CC#%{_libdir}/ccache/}
+diet ${CC} %{SOURCE7} %{rpmcflags} -Os -static -o glibc-postinst
 %endif
 
 %install
@@ -1161,31 +1153,32 @@ done
 #
 # To be added when they become supported by glibc:
 #   ach    (vlc, libreport)
-#   ak     (gtkspell3)
 #   aln    (vlc, libreport)
 #   bal    (libosinfo, libreport, newt, pessulus)
 #   cgg    (vlc)
 #   co     (vlc)
-#   frp    (xfce, lxlauncher)
+#   frp    (xfce, lxlauncher, mate)
 #   gn     (gn_BR in gnome, maybe gn_PY)
 #   haw    (iso-codes, stellarium)
 #   hrx    (stellarium)
 #   ilo    (kudzu, libosinfo, libreport)
 #   io     (gtk+2, gnome, alacarte)
-#   jv     (gmpc, avant-window-navigator, kdesudo, mate-desktop)
+#   jv     (gmpc, avant-window-navigator, kdesudo, mate)
 #   kmr    (vlc)
-#   ku_IQ  (mate-menus,mozo)
+#   ku_IQ  (mate)
 #   kw@kkcor, kw@uccor (libosinfo - currently empty) - add as supported variants when non-empty?
 #   man    (ccsm; incorrectly named md)
 #   mus    (bluez-gnome)
-#   nah    (mate-system-monitor)
-#   nqo           (mate-desktop)
-#   pms    (deluge)
-#   sco    (gnomad2, picard, stellarium)
+#   nah    (mate)
+#   nqo           (mate)
+#   pms    (deluge, mate-tweak)
+#   sco    (gnomad2, picard, stellarium, mate)
 #   son    (gtkspell3)
+#   su     (terminator)
 #   swg    (sim)
 #   syr    (iso-codes)
 #   tet    (vlc)
+#   tpi    (mate-tweak)
 #   tw     (libosinfo)
 #   vec    (mate-applet-indicator)
 #   wba    (libosinfo)
@@ -1196,6 +1189,7 @@ done
 #
 # Short forms (omitted country code, used instead of long form) for ambiguous or unclear cases:
 # aa=aa_ER
+# ak=ak_GH
 # anp=anp_IN
 # ar=common? (AE, BH, DZ, EG, IQ, JO, KW, LB, LY, MA, OM, QA, SA, SD, SY, TN, YE)
 # az=az_AZ
@@ -1226,6 +1220,7 @@ done
 # quz=quz_PE
 # ru=ru_RU
 # sd=sd_IN
+# shn=shn_MM
 # so=so_SO
 # sr=sr_RS [cyrillic]
 # sr@latin=sr_RS@latin
@@ -1244,14 +1239,14 @@ done
 #   be ca cs da de el en_GB es fi fr gl hr hu it ja ko nb nl pl pt_BR ru rw sk
 #   sv tr zh_CN zh_TW
 #
-for i in aa aa@saaho af am an ang anp ar ar_TN as ast az az_IR be@latin be@tarask bem \
+for i in aa aa@saaho af ak am an ang anp ar ar_TN as ast az az_IR be@latin be@tarask bem \
        bg bho bn bn_IN bo br brx bs byn ca@valencia ckb cmn crh csb cv cy de_AT de_CH doi dv dz en \
        en@boldquot en@quot en@shaw en_AU en_CA en_NZ en_US eo es_AR es_CL es_CO es_CR \
        es_DO es_EC es_GT es_HN es_MX es_NI es_PA es_PE es_PR es_SV es_UY \
        es_VE et eu fa ff fil fo fr_BE fr_CA fr_CH fur fy ga gd gez gu gv ha he \
        hi hne hsb hy ia id ig ik is it_CH iu ka kg kk kl km kn kok ks ku kw ky la lb \
        lg li lo lt lv mai mg mhr mi mk ml mn mni mr ms mt my nds ne nl_BE nn nr nso \
-       oc om or pa pap ps pt ps quz rm ro sa sat sc sd se si sid sl so sq sr sr@Latn szl tl \
+       oc om or pa pap ps pt ps quz rm ro sa sat sc sd se shn si sid sl so sq sr sr@Latn szl tl \
        sr@ije sr@ijekavian sr@ijekavianlatin sr@latin ss st sw ta te tg th ti \
        tig tk tl tlh tn ts tt tt@iqtelif ug uk ur uz uz@cyrillic ve vi wa wal wo xh yi yo \
        zh_HK zu; do
@@ -1459,13 +1454,6 @@ fi
 %endif
 %dir %{_prefix}/lib/locale
 
-#%files -n nss_db
-%defattr(644,root,root,755)
-%attr(755,root,root) %{_bindir}/makedb
-%attr(755,root,root) /%{_lib}/libnss_db-%{core_version}.so
-%attr(755,root,root) /%{_lib}/libnss_db.so.2
-%{_var}/db/Makefile
-
 #%files -n nss_dns
 %defattr(644,root,root,755)
 %attr(755,root,root) /%{_lib}/libnss_dns-%{core_version}.so
@@ -1782,6 +1770,13 @@ fi
 %attr(755,root,root) /%{_lib}/libnss_compat-%{core_version}.so
 %attr(755,root,root) /%{_lib}/libnss_compat.so.2
 
+%files -n nss_db
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_bindir}/makedb
+%attr(755,root,root) /%{_lib}/libnss_db-%{core_version}.so
+%attr(755,root,root) /%{_lib}/libnss_db.so.2
+%{_var}/db/Makefile
+
 %files -n nss_hesiod
 %defattr(644,root,root,755)
 %attr(755,root,root) /%{_lib}/libnss_hesiod-%{core_version}.so
This page took 0.042426 seconds and 4 git commands to generate.