]> git.pld-linux.org Git - packages/glibc.git/blobdiff - glibc.spec
- add country_car for wal_ET
[packages/glibc.git] / glibc.spec
index abb889f8a7d2943471a2097624eee65b1ccc9b16..bf828cad0558860240c1e41ffae4f49056e10ee7 100644 (file)
@@ -1,4 +1,5 @@
 # TODO:
+# - restore --with-pkgversion when tcl upstream fixes the #3599098 (broken platform::identify).
 # - --enable-systemtap
 # - look at locale fixes/updates in bugzilla
 # - no more chicken-egg problem (postshell is no more dynamically linked with libc), remove SONAME symlinks? see files section.
@@ -7,21 +8,20 @@
 # - math/{test-fenv,test-tgmath,test-float,test-ifloat}, debug/backtrace-tst(SEGV)  fail on alpha
 #
 # Conditional build:
-# min_kernel   (default is 2.6.12)
+# min_kernel   (default is 2.6.16)
 %bcond_without memusage        # don't build memusage utility
 %bcond_without selinux         # without SELinux support (in nscd)
 %bcond_with    tests           # perform "make test"
 %bcond_without localedb        # don't build localedb-all (is time consuming)
 %bcond_with    cross           # build using crossgcc (without libgcc_eh)
 #
-%{!?min_kernel:%global         min_kernel      2.6.12}
+%{!?min_kernel:%global         min_kernel      2.6.16}
 
 %ifarch sparc64
 %undefine      with_memusage
 %endif
 
-%define                core_version    2.16
-%define                ports_version   2.16.0
+%define                core_version    2.18
 %define                llh_version     7:2.6.20.4-1
 
 Summary:       GNU libc
@@ -34,15 +34,13 @@ Summary(ru.UTF-8):  GNU libc версии
 Summary(tr.UTF-8):     GNU libc
 Summary(uk.UTF-8):     GNU libc версії
 Name:          glibc
-Version:       %{core_version}.0
-Release:       3
+Version:       %{core_version}
+Release:       1
 Epoch:         6
 License:       LGPL v2.1+
 Group:         Libraries
 Source0:       http://ftp.gnu.org/gnu/glibc/%{name}-%{version}.tar.xz
-# Source0-md5: 80b181b02ab249524ec92822c0174cf7
-Source1:       http://ftp.gnu.org/gnu/glibc/%{name}-ports-%{ports_version}.tar.xz
-# Source1-md5: 9a2439641be7ca8b01a3175324013031
+# Source0-md5: 88fbbceafee809e82efd52efa1e3c58f
 Source2:       nscd.init
 Source3:       nscd.sysconfig
 Source4:       nscd.logrotate
@@ -64,8 +62,9 @@ Patch7:               1070_all_glibc-fadvise64_64.patch
 Patch8:                %{name}-missing-nls.patch
 Patch9:                %{name}-java-libc-wait.patch
 Patch10:       %{name}-info.patch
-Patch11:       %{name}-format.patch
-Patch12:       %{name}-rh-bug-769421.patch
+Patch11:       %{name}-autoconf.patch
+Patch12:       %{name}-format.patch
+
 Patch14:       %{name}-sparc-errno_fix.patch
 Patch15:       %{name}-new-charsets.patch
 Patch16:       %{name}-tzfile-noassert.patch
@@ -80,14 +79,11 @@ Patch25:    %{name}-cv_gnu89_inline.patch
 Patch26:       %{name}-posix-sh.patch
 
 Patch29:       %{name}-arm-alignment-fix.patch
-Patch30:       %{name}-bug-12492.patch
+
 Patch31:       %{name}-origin.patch
 Patch32:       %{name}-Os-fail-workaround.patch
-Patch33:       0020_all_glibc-tweak-rfc1918-lookup.patch
 
 Patch38:       1055_all_glibc-resolv-dynamic.patch
-
-Patch42:       %{name}-pr13013.patch
 URL:           http://www.gnu.org/software/libc/
 %{?with_selinux:BuildRequires: audit-libs-devel}
 BuildRequires: autoconf
@@ -104,13 +100,14 @@ BuildRequires:    gcc >= 6:4.3
 BuildRequires: gettext-devel >= 0.10.36
 %{?with_selinux:BuildRequires: libselinux-devel >= 1.18}
 BuildRequires: linux-libc-headers >= %{llh_version}
-BuildRequires: nss-devel >= 1:3.12.3
+BuildRequires: nss-devel >= 1:3.15.1-2
 BuildRequires: perl-base
 BuildRequires: rpm-build >= 4.3-0.20030610.28
 BuildRequires: rpmbuild(macros) >= 1.567
 BuildRequires: sed >= 4.0.5
 BuildRequires: texinfo
 Requires(post):        ldconfig = %{epoch}:%{version}-%{release}
+Requires:      filesystem
 Requires:      uname(release) >= %{min_kernel}
 Provides:      glibc(nptl)
 Provides:      glibc(tls)
@@ -133,6 +130,7 @@ Conflicts:  man-pages < 1.43
 Conflicts:     poldek < 0.18.8-5
 Conflicts:     rc-scripts < 0.3.1-13
 Conflicts:     rpm < 4.1
+Conflicts:     xorg-driver-video-nvidia-libs < 1:295.33
 ExclusiveArch: i486 i586 i686 pentium3 pentium4 athlon %{x8664} ia64 alpha s390 s390x sparc sparc64 sparcv9 ppc ppc64 armv5tel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
@@ -931,8 +929,12 @@ Memory usage profiler.
 Narzędzie do profilowania zużycia pamięci.
 
 %prep
-%setup -q -a1
-mv %{name}-ports-%{ports_version} ports
+%setup -q
+
+%if "%{min_kernel}" < "2.6.16"
+echo "Minimal supported kernel is 2.6.16" >&2
+exit 1
+%endif
 
 %patch2 -p1
 %patch3 -p0
@@ -945,6 +947,7 @@ mv %{name}-ports-%{ports_version} ports
 %patch10 -p1
 %patch11 -p1
 %patch12 -p1
+
 %patch14 -p0
 %patch15 -p1
 %patch16 -p1
@@ -960,15 +963,12 @@ mv %{name}-ports-%{ports_version} ports
 %patch26 -p1
 
 %patch29 -p1
-%patch30 -p0
+
 %patch31 -p1
 %patch32 -p1
-%patch33 -p1
 
 %patch38 -p1
 
-%patch42 -p1
-
 # cleanup backups after patching
 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
 
@@ -1005,6 +1005,7 @@ PATH=$(pwd)/alt-tools:$PATH; export PATH
 
 AWK="gawk" \
 ../%configure \
+       --with-bugurl=http://bugs.pld-linux.org/ \
        --with-binutils=$(pwd)/alt-tools \
        --enable-kernel="%{min_kernel}" \
        --with-headers=%{_includedir} \
@@ -1030,7 +1031,7 @@ cd ..
 %if %{with tests}
 cd builddir
 env LANGUAGE=C LC_ALL=C \
-%{__make} tests 2>&1 | awk '
+%{__make} -j1 tests 2>&1 | awk '
 BEGIN { file = "" }
 {
        if (($0 ~ /\*\*\* \[.*\.out\] Error/) && ($0 !~ /annexc/) && (file == "")) {
@@ -1052,9 +1053,9 @@ diet ${CC#*ccache } %{SOURCE7} %{rpmcflags} -Os -static -o glibc-postinst
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT/etc/{default,logrotate.d,rc.d/init.d,sysconfig,init} \
+install -d $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig,default,logrotate.d,init} \
        $RPM_BUILD_ROOT{%{_mandir}/man{3,8},/var/log,/var/{lib,run}/nscd} \
-       $RPM_BUILD_ROOT{/var/cache/ldconfig,/usr/lib/tmpfiles.d}
+       $RPM_BUILD_ROOT{/var/cache/ldconfig,%{systemdtmpfilesdir}}
 
 cd builddir
 env LANGUAGE=C LC_ALL=C \
@@ -1078,7 +1079,7 @@ install -p elf/soinit.os                          $RPM_BUILD_ROOT%{_libdir}/soinit.o
 install -p elf/sofini.os                               $RPM_BUILD_ROOT%{_libdir}/sofini.o
 
 # Include %{_libdir}/gconv/gconv-modules.cache
-LD_PRELOAD=$(pwd)/elf/ld.so:$(pwd)/libc.so.6 ./iconv/iconvconfig --nostdlib --prefix=$RPM_BUILD_ROOT %{_libdir}/gconv -o $RPM_BUILD_ROOT%{_libdir}/gconv/gconv-modules.cache
+$(pwd)/elf/ld.so --library-path $(pwd) ./iconv/iconvconfig --nostdlib --prefix=$RPM_BUILD_ROOT %{_libdir}/gconv -o $RPM_BUILD_ROOT%{_libdir}/gconv/gconv-modules.cache
 cd ..
 
 %if %{without cross}
@@ -1132,7 +1133,7 @@ rm -f $RPM_BUILD_ROOT%{_mandir}/*/man8/tzselect.8*
 : > $RPM_BUILD_ROOT/var/lib/nscd/group
 : > $RPM_BUILD_ROOT/var/lib/nscd/hosts
 
-install %{SOURCE9} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/nscd.conf
+install %{SOURCE9} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/nscd.conf
 
 rm -rf documentation
 install -d documentation
@@ -1144,7 +1145,7 @@ cp -af crypt/README.ufc-crypt ChangeLog* documentation
 
 # Collect locale files and mark them with %%lang()
 echo '%defattr(644,root,root,755)' > glibc.lang
-for i in $RPM_BUILD_ROOT%{_datadir}/locale/*; do
+for i in $RPM_BUILD_ROOT%{_localedir}/*; do
        if [ -d $i ]; then
                lang=$(basename $i)
                dir="${i#$RPM_BUILD_ROOT}"
@@ -1191,11 +1192,7 @@ done
 #
 # To be removed (after fixing packages still using it):
 #   sr@Latn (use sr@latin instead)
-#
-# To be clarified:
-#   sr@ije or sr@ijekavian? (currently sr@ije is supported)
-#   sr@ijelatin or sr@ijekavianlatin? (currently not supported)
-#   sr@ijekavian and sr@ijekavianlatin exist in: akonadi-googledata, amarok, k3b, konversation, ktorrent, wesnoth
+#   sr@ije (use sr@ijekavian instead)
 #
 # Short forms (omitted country code, used instead of long form) for ambiguous or unclear cases:
 # aa=aa_ER
@@ -1209,6 +1206,7 @@ done
 # eo=common
 # es=es_ES
 # eu=eu_ES
+# fa=fa_IR
 # ff=ff_SN
 # fr=fr_FR
 # fy=fy_NL
@@ -1218,11 +1216,15 @@ done
 # nds=nds_DE
 # nl=nl_NL
 # om=om_ET
+# or=or_IN
 # pa=pa_IN
 # pt=pt_PT
 # ru=ru_RU
 # so=so_SO
 # sr=sr_RS [cyrillic]
+# sr@latin=sr_RS@latin
+# sr@ijekavian=sr_BA@ijekavian
+# sr@ijekavianlatin=sr_BA@ijekavianlatin
 # sv=sv_SE
 # sw=sw_TZ (or common for KE, TZ, UG?)
 # ta=ta_IN
@@ -1244,23 +1246,24 @@ for i in aa aa@saaho af am an ang ar ar_TN as ast az be@latin be@tarask \
        hi hne hsb hy ia id ig ik is it_CH iu ka kg kk kl km kn ks ku kw ky la \
        lg li lo lt lv mai mg mi mk ml mn mr ms mt my nds ne nl_BE nn nr nso \
        oc om or pa pap ps pt ps rm ro sa sc se si sid sl so sq sr sr@Latn tl \
-       sr@ije sr@latin ss st sw ta te tg th ti tig tk tl tlh tn ts tt ug uk \
-       ur uz uz@cyrillic ve vi wa wal wo xh yi yo zh_HK zu; do
-       if [ ! -d $RPM_BUILD_ROOT%{_datadir}/locale/$i/LC_MESSAGES ]; then
-               install -d $RPM_BUILD_ROOT%{_datadir}/locale/$i/LC_MESSAGES
+       sr@ije sr@ijekavian sr@ijekavianlatin sr@latin ss st sw ta te tg th ti \
+       tig tk tl tlh tn ts tt ug uk ur uz uz@cyrillic ve vi wa wal wo xh yi yo \
+       zh_HK zu; do
+       if [ ! -d $RPM_BUILD_ROOT%{_localedir}/$i/LC_MESSAGES ]; then
+               install -d $RPM_BUILD_ROOT%{_localedir}/$i/LC_MESSAGES
                # use lang() tags with ll_CC@variant (stripping charset and @quot|@boldquot)
                lang=$(echo $i | sed -e 's/@quot\>\|@boldquot\>//')
-               echo "%lang($lang) %{_datadir}/locale/$i" >> glibc.lang
+               echo "%lang($lang) %{_localedir}/$i" >> glibc.lang
        fi
 done
 
 # LC_TIME category, used for localized date formats (at least by coreutils)
-for i in af be bg ca cs da de el en eo es et eu fi fr ga gl hu id it ja kk ko lg lt \
+for i in af be bg ca cs da de el en eo es et eu fi fr ga gl hr hu ia id it ja kk ko lg lt \
        ms nb nl pl pt pt_BR ro ru rw sk sl sv tr uk vi zh_CN zh_TW; do
-       if [ ! -d $RPM_BUILD_ROOT%{_datadir}/locale/$i ]; then
-               echo "%lang($lang) %{_datadir}/locale/$i" >> glibc.lang
+       if [ ! -d $RPM_BUILD_ROOT%{_localedir}/$i ]; then
+               echo "%lang($lang) %{_localedir}/$i" >> glibc.lang
        fi
-       install -d $RPM_BUILD_ROOT%{_datadir}/locale/$i/LC_TIME
+       install -d $RPM_BUILD_ROOT%{_localedir}/$i/LC_TIME
 done
 
 # localedb-gen infrastructure
@@ -1271,11 +1274,22 @@ install localedata/SUPPORTED $RPM_BUILD_ROOT%{_datadir}/i18n
 # shutup check-files
 %{__rm} $RPM_BUILD_ROOT%{_mandir}/README.*
 rm -f $RPM_BUILD_ROOT%{_infodir}/dir
-# we don't support kernel without ptys support
-%{__rm} $RPM_BUILD_ROOT%{_libdir}/pt_chown
 # rpcinfo dropped from glibc, provided by rpcbind now
 %{__rm} $RPM_BUILD_ROOT%{_mandir}/{,*/}man8/rpcinfo.8
 
+# stub for man page from man-pages package to make rpm consistency check happy
+# don't package them here
+install -d $RPM_BUILD_ROOT%{_mandir}{/,/ru,/es,/fr,/ja}/man2
+:>$RPM_BUILD_ROOT%{_mandir}/man2/syslog.2
+:>$RPM_BUILD_ROOT%{_mandir}/ru/man2/syslog.2
+:>$RPM_BUILD_ROOT%{_mandir}/es/man2/syslog.2
+:>$RPM_BUILD_ROOT%{_mandir}/fr/man2/syslog.2
+:>$RPM_BUILD_ROOT%{_mandir}/ja/man2/syslog.2
+
+# remove links to non existant translations
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/pl/man3/{alphasort,cfgetispeed,cfgetospeed,cfmakeraw,cfsetispeed,cfsetospeed,closelog,dn_comp,dn_expand,fscanf}.3
+%{__rm} $RPM_BUILD_ROOT%{_mandir}/it/man7/latin2.7
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -1462,8 +1476,8 @@ fi
 %dir %{_libexecdir}/getconf
 %attr(755,root,root) %{_libexecdir}/getconf/*
 
-%dir %{_datadir}/locale
-%{_datadir}/locale/locale.alias
+%dir %{_localedir}
+%{_localedir}/locale.alias
 
 %{_mandir}/man1/getconf.1*
 %{_mandir}/man1/getent.1*
@@ -1743,7 +1757,7 @@ fi
 %attr(755,root,root) %{_sbindir}/nscd*
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/nscd
 %attr(640,root,root) %ghost /var/log/nscd
-/usr/lib/tmpfiles.d/nscd.conf
+%{systemdtmpfilesdir}/nscd.conf
 %dir /var/run/nscd
 %dir /var/lib/nscd
 %attr(600,root,root) %ghost /var/lib/nscd/passwd
This page took 0.133255 seconds and 4 git commands to generate.