]> git.pld-linux.org Git - packages/glibc.git/blobdiff - glibc.spec
- added tmpfiles config for systemd
[packages/glibc.git] / glibc.spec
index 5b9ab14c5877be7804f7101e7f1dd79f1502b571..99a3209d4d1be29b5af702095c0e1b0e95e2494c 100644 (file)
@@ -19,7 +19,7 @@
 %undefine      with_memusage
 %endif
 
-%define                ports_version   2.13
+%define                ports_version   2.14.1
 %define                llh_version     7:2.6.20.4-1
 
 Summary:       GNU libc
@@ -33,14 +33,14 @@ Summary(tr.UTF-8):  GNU libc
 Summary(uk.UTF-8):     GNU libc версії
 Name:          glibc
 Version:       2.14.1
-Release:       1.1
+Release:       4
 Epoch:         6
 License:       LGPL v2.1+
 Group:         Libraries
 Source0:       http://ftp.gnu.org/gnu/glibc/%{name}-%{version}.tar.xz
 # Source0-md5: 55501b8d037a4f1d330312b30fd6d4bc
-Source1:       http://ftp.gnu.org/gnu/glibc/%{name}-ports-%{ports_version}.tar.bz2
-# Source1-md5: 483f37cfdd619e81d8ca9e9d713944b5
+Source1:       http://ftp.gnu.org/gnu/glibc/%{name}-ports-%{ports_version}.tar.xz
+# Source1-md5: 3b3afcb6b99fea9e3a2474cc4778ec88
 Source2:       nscd.init
 Source3:       nscd.sysconfig
 Source4:       nscd.logrotate
@@ -50,6 +50,7 @@ Source5:      http://qboosh.pl/man/%{name}-man-pages.tar.bz2
 Source6:       %{name}-localedb-gen
 Source7:       %{name}-LD-path.c
 Source8:       nscd.upstart
+Source9:       nscd.tmpfiles
 Patch0:                %{name}-restore-rpc+nis.patch
 Patch1:                %{name}-pl.po-update.patch
 Patch2:                %{name}-pld.patch
@@ -85,7 +86,8 @@ Patch37:      0061_all_glibc-2.13-static-memset.patch
 Patch38:       1055_all_glibc-resolv-dynamic.patch
 Patch39:       %{name}-git.patch
 Patch40:       %{name}-bad-fix.patch
-Patch41:       %{name}-revert-dso-breakout.patch
+Patch41:       %{name}-pr12892.patch
+Patch42:       %{name}-pr13013.patch
 URL:           http://www.gnu.org/software/libc/
 %{?with_selinux:BuildRequires: audit-libs-devel}
 BuildRequires: autoconf
@@ -950,8 +952,8 @@ mv %{name}-ports-%{ports_version} ports
 %patch38 -p1
 %patch39 -p1
 %patch40 -p1
-# revert broken fix
 %patch41 -p1
+%patch42 -p1
 
 # cleanup backups after patching
 find '(' -name '*~' -o -name '*.orig' ')' -print0 | xargs -0 -r -l512 rm -f
@@ -1036,7 +1038,9 @@ diet ${CC#*ccache } %{SOURCE7} %{rpmcflags} -Os -static -o glibc-postinst
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT{/etc/{default,logrotate.d,rc.d/init.d,sysconfig,init},%{_mandir}/man{3,8},/var/log,/var/{lib,run}/nscd,/var/cache/ldconfig}
+install -d $RPM_BUILD_ROOT/etc/{default,logrotate.d,rc.d/init.d,sysconfig,init} \
+       $RPM_BUILD_ROOT{%{_mandir}/man{3,8},/var/log,/var/{lib,run}/nscd,/var/cache/ldconfig} \
+       $RPM_BUILD_ROOT/usr/lib/tmpfiles.d
 
 cd builddir
 env LANGUAGE=C LC_ALL=C \
@@ -1114,6 +1118,8 @@ rm -f $RPM_BUILD_ROOT%{_mandir}/*/man8/tzselect.8*
 : > $RPM_BUILD_ROOT/var/lib/nscd/group
 : > $RPM_BUILD_ROOT/var/lib/nscd/hosts
 
+install %{SOURCE9} $RPM_BUILD_ROOT/usr/lib/tmpfiles.d/nscd.conf
+
 rm -rf documentation
 install -d documentation
 
@@ -1174,8 +1180,36 @@ done
 #   sr@ijelatin or sr@ijekavianlatin? (currently not supported)
 #   sr@ijekavian and sr@ijekavianlatin exist in: akonadi-googledata, amarok, k3b, konversation, ktorrent, wesnoth
 #
-# bn is used for bn_BD or bn_IN? Assume bn_IN as nothing for bn_BD appeared
-# till now.
+# Short forms (omitted country code, used instead of long form) for ambiguous or unclear cases:
+# aa=aa_ER
+# ar=common? (AE, BH, DZ, EG, IQ, JO, KW, LB, LY, MA, OM, QA, SA, SD, SY, TN, YE)
+# bn=bn_BD
+# ca=ca_ES
+# ckb=ckb_IQ
+# de=de_DE
+# en=common? (en_AU, en_CA, en_GB, en_NZ, en_US are used for particular variants)
+# eo=common
+# es=es_ES
+# eu=eu_ES
+# fr=fr_FR
+# fy=fy_NL
+# gez=gez_ET (?)
+# it=it_IT
+# li=li_NL
+# nds=nds_DE
+# nl=nl_NL
+# om=om_ET
+# pa=pa_IN
+# pt=pt_PT
+# ru=ru_RU
+# so=so_SO
+# sr=sr_RS [cyrillic]
+# sv=sv_SE
+# sw=sw_TZ (or common for KE, TZ, UG?)
+# ti=ti_ER (?)
+# tr=tr_TR
+# ur=ur_PK (?)
+# zh: no short code used (use zh_CN, zh_HK, zh_SG[not included yet], zh_TW)
 #
 # Omitted here - already existing (with libc.mo):
 #   be ca cs da de el en_GB es fi fr gl hr hu it ja ko nb nl pl pt_BR ru rw sk
@@ -1394,16 +1428,12 @@ fi
 %endif
 %attr(755,root,root) %{_bindir}/locale
 %attr(755,root,root) %{_bindir}/rpcgen
-%attr(755,root,root) %{_bindir}/sotruss
 %attr(755,root,root) %{_sbindir}/zdump
 %attr(755,root,root) %{_sbindir}/zic
 
 %dir %{_libexecdir}/getconf
 %attr(755,root,root) %{_libexecdir}/getconf/*
 
-%dir %{_libdir}/audit
-%attr(755,root,root) %{_libdir}/audit/sotruss-lib.so
-
 %dir %{_datadir}/locale
 %{_datadir}/locale/locale.alias
 
@@ -1511,6 +1541,10 @@ fi
 %defattr(644,root,root,755)
 %attr(755,root,root) %{_bindir}/catchsegv
 %attr(755,root,root) %{_bindir}/ldd
+%attr(755,root,root) %{_bindir}/sotruss
+%dir %{_libdir}/audit
+%attr(755,root,root) %{_libdir}/audit/sotruss-lib.so
+
 %{_mandir}/man1/catchsegv.1*
 %{_mandir}/man1/ldd.1*
 %lang(es) %{_mandir}/es/man1/ldd.1*
@@ -1680,6 +1714,7 @@ fi
 %attr(755,root,root) %{_sbindir}/nscd*
 %attr(640,root,root) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/nscd
 %attr(640,root,root) %ghost /var/log/nscd
+/usr/lib/tmpfiles.d/nscd.conf
 %dir /var/run/nscd
 %dir /var/lib/nscd
 %attr(600,root,root) %ghost /var/lib/nscd/passwd
This page took 0.08387 seconds and 4 git commands to generate.